exchange server 2003 w/ external dns & SSL

My main goal is to access exchange server with mobile devices and offsite outlook, but let's get the basics together

i have port forwarded udp+tcp, 25 54 80 110 3389

my forward external dns seems to be functioning properly
and my exchange and domain controller are working beautifully too
local dns and domain are and set to send mail as
outlook w/ exchange is working locally and I am able to send and receive e-mail to my gmail
but other places  like my throw it right into spam/junk  i'm figuring because of not having SSL and or reverse dns working properly

I realize that hosting your own DNS is insecure I am doing this all for learning purposes!

I have the domain w/ godaddy and they are not even doing the dns hosting, I have nameserver set to

i have the zone for with nameserver pointing to the external IP address and obviously mx record for hte FQDN

I created the primary reverse zone with the first 3 sections of IP address and proceeded to set a ptr for the fqdn/host and enter in the correct 4th digit section of the ip address from what i've read i have done this correctly

I read somewhere you have to call your ISP for them to set you up with the reverse dns which for me is Qwest  (i already have a static ip obviously)

if this is true should for this exchange situation do I just ask qwest to setup reverse dns for and nothing else? I don't want to call them without knowing exactly what I need to do
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.


Okay first of all to troubleshoot mail delivery to external providers in your case Hotmail and Gmail, you need to ensure you're clean and compliant.

Having SSL is not a requirement for safe delivery, that is more for secure webmail connectivity, your SSL certificate may be used to TLS authentication for inbound and outbound delivery.

Yes as a matter of best practice you need to setup a reverse DNS record and your ISP have to set that, I've seen many scenarios where your ISP may refer you to your DNS provider. In that scenario just tell your ISP you want a PTR record set for your public IP address, if they don't understand that, ask to speak to their manager or someone who knows about DNS.

For your test environment I would ensure that your reverse DNS record matches the DNS record for your static IP. You could also ensure that the EHLO string matches your PTR record, on Exchange 2003 this would be on your Virtual SMTP adaptor in ESM, on Exchange 2007/2010 this would be on your Send Connector.

For example: = (PTR RECORD) = (A RECORD) implied that (MX RECORD)

For authenticating emails coming from your IP and prevent spoofing I would recommend setting up an SPF record, this is fairly simple to setup and I would consider this a must for any email server setup. A fairly simple record you could use to validate that emails from your MX record as authentic is listed below. I've used the ~ (tilde) as opposed to the strict - (hyphen), which should pass SPF lookups by Google and Hotmail.

"v=spf1 mx ~all"

I think this may be a question typo, DNS operates on port 53 UDP as opposed to port 54. I personally wouldn't open up port 110 unless you need external POP3 access.

Please see the following links for further reading:

Hope this helps and best of luck!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dr_patsoAuthor Commented:
I just got reverse working..

but my Ip address resolves to  (i set this up with qwest) when the exchange is set to send as  but is actually

when I run the smtp test @ it says reverse failed still, even though reverse lookup comes up with correct thing I set up,

here is the error from smtp test for @ mxlookup

smtp: (external ip address)                smtp  
220 Microsoft ESMTP MAIL Service, Version: 6.0.3790.0 ready at Sat, 2 Apr 2011 16:57:09 -0700
 Reverse DNS FAILED! This is a problem.

Do i need to set my PTR with qwest to be please help before tech support closes lol!

dr_patsoAuthor Commented:
oh smtp test works now, on mxlookup result is this

green dots all the way!

I just tried e-mailing my mom's msn accoutn but it still went straight to spam =(

smtp: IP)                smtp  
220 Microsoft ESMTP MAIL Service, Version: 6.0.3790.0 ready at Sat, 2 Apr 2011 17:59:01 -0700

 OK - resolves to
 OK - Reverse DNS matches SMTP Banner
 0 seconds - Good on Connection time
Not an open relay.
 0.515 seconds - Good on Transaction time
dr_patsoAuthor Commented:
thanks much for your help I got reverse dns working correctly!
Glad to hear everything is okay.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.