XP cannot browse the workgroup, not accessible??

I have been configuring networks both Workgroup and Domain environments for years.  This one is strange.

We recently acquired a customer with this simple LAN setup.

9 XP PRO workstations drawing from a database on an XP PRO pc/server.

Problem:  from any pc ,  even the xp server - you cannot browse the workgroup.  "workgroup is not accessible"  ...... path not found.

1. All users have the same login and pass,  all pcs are in the same workgroup.
2. The router is simply connected DHCP to cable ISP and is the gateway
3. All pcs get ips from the router DHCP table.
4. I have reset the router to factory to rule out old dhcp table etc.
5. We introduced a new pc (XP) to the lan - initially we could browse and see all LAN pcs in the workgroup,  now it TOO! cannot - same error as above.

*OF note - the only change recently was a new 16 port switch was installed*

6.  We formatted one of the existing XP pcs - same error!

There really is NO DNS so I cant see a problem there.

Does anyone have input on this?   Is there somehow a chance the switch could be the problem?  NOTE - all other networking, speeds and programs are working fine on the LAN??

PLease help!
LVL 1
j-teksolutionsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

j-teksolutionsAuthor Commented:
I have read a bit about checking the adapter and that it is "Auto" detecting speeds - this is verified and I am sure would only apply if a single pc was the problem.
0
afthabCommented:
Check below settings

Enable "Client for Microsoft Networks".
Enable "File and Printer Sharing for Microsoft Networks"

and also see http://support.microsoft.com/kb/318030
0
hamza_ajCommented:
the problem some time happen because you don't have DNS server

first of all, make sure you have a shared folder or driver on every computer you want to access through. maybe this will resolve the issue.

if you already have, try to access through the IP for computer's not the name
by typing for example: \\192.168.1.2 (but your correct IP address) .  this will solve your problem.

after that you can create a map network drive for shared folder you want.

Regards
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

j-teksolutionsAuthor Commented:
afthab this is all enabled - remember everyone this is Every pc on the network

I know I would prefer an actual server running dns and dhcp but I have to work with this xp box.
I can use ips no problem to grab printer shares etc on pcs   I cannot use netbios though
0
ToxaconCommented:
Try

net config server /hidden:no

Open in new window


Then start Computer Browser in that device. That will cause a Browser Election and the first one will become the Master Browser. The Master Browser maintains a list of browsable objects.
0
New_AlexCommented:
Problem not seeing network
Here is what I did, (which is long, but I suspect the solution could even be shorter)
When Access to Share Denied between 2 XP machines (with no password protection)

1. Click Start, click Run, type regedit in the Open box, and then click OK.
2. Locate and then double-click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
3. In the right pane, double-click restrictanonymous.
4. Make sure that the value in the Value data box is set to 0, and then click OK.
5. In the right pane, double-click limitblankpassworduse.
6. Make sure that the value in the Value data box is set to 0 when you Don't Use Password
      (and 1 if you use passward), on the Master PC and then click OK.
7. Close Registry Editor.
8. Restart the computer.
1st of all Run the Network Wizard in All the PCs.
Configure the Network
1. First try this:  Go to: Control Panel/System and click on the "Computer Name" Tab. Then click on "Network ID", select "This Computer is part of a business network...." then, "My Computer uses a network without a domain".
Don't forget to give a name for both the WORKGROUP and the PC.
2. If the Above didn't sort the issue, go to control panel and run the wizard: "Network Setup Wizard"

Then I had a problem Windows 7 not recognizing the 2 operating systems…..
This is how I sorted  the problem out….
On each XP computer…..
1.      Go To “Control Panel” /“Network Connections”
2.      Choose “Create a new connection” link from the left panel click Next /Next
3.      Tick the “Connect to the network at my workplace” and click Next / Next
4.      Tick the “Yes, use the existing shared connection for this computer’s Internet access”
5.      Next,  Next
6.      Here you put your Workgroup name which must be the same in all PCs (e.g. WORKGROUP)
7.      Follow with Next until you reach the end of the Wizard.
8.      Now you will notice that Windows Firewall has set itself to ON….
9.      Go Back to the “Network Connections” and click once on your “Local Area Connection”
10.      Find “Change Windows Firewall settings” from the “Network Tasks” list at the left Panel.
11.      DISABLE WINDOWS XP FIREWALL…..
12.      Go Back to the “Network Connections” and right click on your “Local Area Connection”
13.      From the Pop up menu click on ”properties” and from there click on the “General”  tab.
14.      Find  the line “This Connection Uses the Following items:” and …..
15.      Un-Tick an item called something like “Microsoft Service Advertising Protocol”
16.      Now Click “Unistall” and stay there.
17.      Do the above procedure on the other XP PC as well.
18.      On the Windows 7 PC make sure you are in a “Work Network“ and Not Home Network.
19.      Go to "Advanced Sharing Settings" in Windows 7
Tick "Turn off password protected sharing" there and also...
Tick "
20.      Restart both XP PCs and also the Windows 7 PC.
20.      On the Windows 7 PC go to "My Computer"
21.      You should now see the 3 computers names in the Windows 7 List

As said the above solution is the result of experiments. Only a part of it could fix the problem !!!!
Share an External USB Hard Drive (Windows XP)
I can set the 'Share' setting on the folder to share, but none of my networked computer can access the files. They do see the shared folder but when I clicked on it, it comes back with an error message "\\pc1\folder is not accessible, you may not have permission ...."
Solution
I faced the same problem and solved the problem by googling around and after I this page: http://support.microsoft.com/default.aspx?scid=kb;en-us;177078
Follow the below instruction and restart computer.
1. Click Start, and then click Run.
2. Type regedit, and then click OK.
3. Navigate to the following key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
4. In the right pane, double-click the IRPStackSize value.
NOTE: If the IRPStackSize value does not already exist, use the following procedure to create it:
      a) In the Parameters folder of the registry, right-click the right pane.
      b) Point to New, and then click DWord Value.
      c) Type IRPStackSize.
IMPORTANT: Type "IRPStackSize" exactly as it is displayed because the value name is case-sensitive.
5. Change the Base to decimal.
6. In the Value Data box, type a value that is larger than the value that is listed.
If you created the IRPStackSize value using the procedure described in step 4, the default value is 15. It is recommended that you increase the value by 3. Therefore, if the previous value was 11, type 14, and then click OK.
7. Close the Registry Editor.
8. Restart the computer.
If the problem persists after you complete the preceding procedure, try to increase the value of IRPStackSize even more. The maximum value for Windows 2000 is 50 (0x32 hex).
Actually for me the solution worked only after changed the decimal value to 21.
good luck guys.

Share USB or Folder from Any Drive (Windows 7)
Windows 7 – No Permission to use this network resource…
When sharing a Folder with other computers on your network, you might see that it is listed as shared but in fact it cannot be accessed. Other users trying to access your partition might receive the following error message: '\\ComputerName\Partition OR FOLDER is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. Access is denied.'
In this tutorial we will show you how to solve this problem. This is because the group called Everyone is not listed and you need to add it.
First, open Windows Explorer and right click on the Folder which you have shared. Click Properties.
In the Properties window, go to the Security tab. Here you will see a list with the defined groups and permissions. If the group called Everyone is not listed, then you need to add it. If it is listed, you need to check the defined permissions and set it to at least Read & execute. To add the group, click Edit.
Now click Add.
In the 'Select Users and Groups' window, type 'Everyone' and click OK.
In the Properties window, click OK.
Now you will see a window titled Windows Security. Wait until it disappears.
From now on, your shared partition will be accessible from other computers.

To change the Log-In username...
Right click on my computer and select 'manage'
Then click on the + sign next to 'local users and groups'.
Then select the users folder. You'll see the user accounts on your system listed on the right.
To rename an account, right click on it and choose rename.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
New_AlexCommented:
Ok the above post is long but I suspect the following to get you sorted

1st of all Run the Network Wizard in All the PCs.
Configure the Network
1. First try this:  Go to: Control Panel/System and click on the "Computer Name" Tab. Then click on "Network ID", select "This Computer is part of a business network...." then, "My Computer uses a network without a domain".
Don't forget to give a name for both the WORKGROUP and the PC.
2. If the Above didn't sort the issue, go to control panel and run the wizard: "Network Setup Wizard"
0
j-teksolutionsAuthor Commented:
New Alex wow that is extensive - remember shares are not the problem - if I go by IP i can see all shares on the server
This has to do only with browsing - the users are used to going via my network places and browsing computers by name they cant do this anymore

Toxacon - I am going to try your suggestion - I think you may be on the right track - should I do this on the serving xp box?
0
j-teksolutionsAuthor Commented:
NEw Alex I can try this but - In 10 years of networking I have never used the wizard in all honesty - with our new setups this has never happened - however  I have no idea what the previous IT has done here - I am attempted to rebuild the whole thing but it will be costly to the client.

Does anyone think the switch in anyway could be involved??  It is unmanaged so I cant possibly see how - the client is about an hours drive away - I am tempted to bring a small test switch and place the server and one pc on it as a test - however i really cant imagine the switch is involved
0
ToxaconCommented:
It is possible that the switch is involved but is very-very unlikely. Usually, it's the broadcast control that ruins the browsing but it's not likely that an unmanaged switch has that.
0
j-teksolutionsAuthor Commented:
The only reason I point to this is that as you know with IT troubleshooting "what was changed recently"
With our take over with replaced 3 daisy chained old dlink switches with a proper rack mount patch panel and 16 port DLINK GIG switch.
0
New_AlexCommented:
Is it XP you use or some streamlined version. (I personally use TinyXP version)

Anyway,

Try

Control Panel /System / Computer Name

There should be the name of your Computer. Play with the settings there. (Network ID etc)

Also check the Area Connection Properties. The computer I am writting from is a part of a network and has the following elements in the Area Connection Properties Window.

 AreaConnectionProperties.

Ok

0
New_AlexCommented:
Other than that I suspect a virus around
0
New_AlexCommented:
Are you sure in "Network ID", options "This Computer is part of a business network...." and then, "My Computer uses a network without a domain" are selected?
0
ToxaconCommented:
If you can see the WORKGROUP in the My Network Places but you can't browse it, it could be vital to see why on very low level. I suggest you install Microsoft Network Monitor to one PC and capture traffic to see what kind of request and response you send/get to/from the network when you start to browse it.
0
upalakshithaCommented:
if you can, set static IPs to workstations.
change work group name
check computer browser service on all pcs.
after doing these turn off network switch & restart all pcs. you can do this with two pcs instead of all.
what is about anti virus ?

0
vivigattCommented:
I think you may have a name resolution issue.

You may want to setup a WINS server in this network. But if this is not an option, then, try to force the type of NetBIOS name through DHCP option.

http://support.microsoft.com/kb/121005

...

NetBIOS Node Type (46): The NetBIOS node type option allows NetBIOS over TCP/IP clients that are configurable to be configured as described in RFC 1001/1002. The value is specified as a single octet that identifies the client type as follows:

   Value         Node Type
   -----         ---------
    0x1           B-node
    0x2           P-node
    0x4           M-node
    0x8           H-node
________                        

You want an H-node (Hybrid) so that your clients can perform all types of name resolutions, including broadcasting. If your DHCP server is on your router, you will have to customize its setting.

also, make sure that you do share the IPC$ admin share on all your computers.
Just run
NET SHARE IPC$
from cmd on all the Windows XP computers.

HTH

0
j-teksolutionsAuthor Commented:
We are trying to convince the client to get an actual server
0
vivigattCommented:
Let's split the points...
There have been very valuable leads and, last but not the least, some of teh experts' comments may help others in the future.
New_Alex deserves some points for sure. Toxacon too. And maybe myself and few others...
0
LeeTutorretiredCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.