windows 2003 R2 won't allow a tcp socket connection

I have a windows 2003 R2 server that I need to connect to via tcp on port 25333. When I try to connect via telnet, I receive the following message:  
   "Connecting To 192.168.100.105...Could not open connection to the host, on port 25333: Connect failed".

I ran netstat -aon and see the localhost 127.0.0.1 listening on that port, but not the server's ip.

I don't have an active firewall, or any other restriction that I know of.  I have tried starting the telnet service but that does no good either.

Any help greatly appreciated before I lose the rest of my (sparse) hair!
dhenderson12Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Glen KnightCommented:
If you telnet on the server itself to 127.0.0.1 on that port what happens?

What service are you trying to connect to on that port?
0
dhenderson12Author Commented:
I can telnet to the localhost, no problem.  I am just trying to establish a telnet connection from a command window.
0
Glen KnightCommented:
There must be a service listening on the port you arresting to connect to? What isit?
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

dhenderson12Author Commented:
here is the entry from nestat -aon:
 TCP    127.0.0.1:22222        0.0.0.0:0              LISTENING       1828
0
Glen KnightCommented:
And what has a process ID of 1828 in task manager under processes? You will have to enable the column.

Perhaps you can explain what you are trying to achieve? If you have a service listening on the ports you want to connect to they need to be listening on the LAN IP.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dhenderson12Author Commented:
I found my problem.  There is another service that had a bad entry.  Thanks for you help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
TCP/IP

From novice to tech pro — start learning today.