Disable of Reporting Services

Hello, in the related question, it's mentioned to "disable the 2008 version of Reporting Services",,,is that thru "programs, control panel, admin tools, services"? When I bring Services up and open it, I do see 2 reporting services running....disable it there?
LVL 8
CamilliaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Raja Jegan RSQL Server DBA & Architect, EE Solution GuideCommented:
In order to disable Reporting Services completely, follow the steps below:

1. Open SQL Server Configuration manager from Start Menu -> Microsoft SQL Server -> Configuration Tools
2. Under Services you can see Reporting Services
3. Right click SQL Server Reporting Services and Click Properties
4. Click on Service Tab
5. Change Startup type to Disabled
6. Now Stop Reporting Services if it is Running.

This would completely disable your Reporting services..

>> I do see 2 reporting services running.

Then you probably have 2 instances of SQL Server installed in your machine.
Just follow the above steps twice for both of them..
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Daniel_PLDB Expert/ArchitectCommented:
It seems you have two instances of Reporting Services installed. Following least service rule, if you don't need RS, it would be better to uninstall RS. When you pnly want to disable it stop service and set it's startup mode to disabled using SQL Server configuration manager. Start->all programs->Microsoft SQL Server 2008->Configuration Tools->SQL Server configuration manager

Here in microsoft blog you have procdure for SQL Server Agent:
http://blogs.msdn.com/b/sqlagent/archive/2010/09/24/start-sql-server-agent-using-sql-server-configuration-manager.aspx
Look for 3) Set SQL Agent Service start up mode = “Automatic” - you need to set it to disabled
0
CamilliaAuthor Commented:

I'm all confused because I'm not a DBA but have been asked to do this...

Yes, there are 2 versions of reporting services. I want to be able to use the R2 (latest version)..

I want to only disable the old one (not the R2) one...afriad of removing it since I'm not familair with it....so disable by folowing your steps or Daniel's?

Also, I need to reconfigure the R2 version..AFTER I disable the old one.., any steps for that?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Daniel_PLDB Expert/ArchitectCommented:
When you're not sure don't uninstall anything, just disable unused service. rrjegan17's procedure is the same as mine so no worries, I didn't notice it while replying.
Is your default instance the R2 version? If so you should keep SQL Server Reporting Services (MSSQLSERVER) and turn off named one e.g.  SQL Server Reporting Services (SQL01) . When your R2 installation is not default instance (it is named instance) you should do exactly inversely.
0
CamilliaAuthor Commented:
>>When your R2 installation is not default instance (it is named instance) you should do exactly inversely.

The R2 is the named one.  But after "turning off" the orig one, do I need to reconfigure the R2 version?? how can i tell we're using the 2008 R2? write a report?
Our report HTML source shows the version number 10.0.3798.0 which means we're not using 2008 R2 but normal 2008. 2008 R2 has version numbers 10.50.xx.xx.  
0
Daniel_PLDB Expert/ArchitectCommented:
You need to configure R2 report server. You connect to reports by http://<your server name>/reportserver. So when you're connecting to named instance you use http://<your server named instance name>/reportserver
0
CamilliaAuthor Commented:
Yes, that's my question: "You need to configure R2 report server.". I've installed it. I see it in programs, i can connect to it and I see "SQL Server 2008 R2". So that's it??
0
Raja Jegan RSQL Server DBA & Architect, EE Solution GuideCommented:
>> You need to configure R2 report server

Here you go:

1. Open SQL Server Configuration manager from Start Menu -> Microsoft SQL Server -> Configuration Tools
2. Under Services you can see SQL Server Reporting Services (R2 Instance name)
3. Right click SQL Server Reporting Services and choose Configure
4. It will open up a wizard and just follow the link to configure that.
http://www.mssqltips.com/tip.asp?tip=1453

And disable the other instance of Reporting Services as told earlier..
0
CamilliaAuthor Commented:
thanks, will try it tomorrow. Thanks as always. Kamila.
0
Raja Jegan RSQL Server DBA & Architect, EE Solution GuideCommented:
Welcome, Kamila
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.