no link light

I hooked up a Cisco router provided by an ISP to a Sonicwall 2040 and got no link lights. reset the sonicwall to factory with no results. Is the Sonicwall 2040 to old a devise
meteormanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kuohCommented:
Did you try both a straight through and crossover cable?  Check each device with something else, like a PC?  We're going to need a bit more on what you have already tried to be able to provide better advice.

KuoH
meteormanAuthor Commented:
yes I tried a crossover and straight cable with no success. I tested the Cisco router with a laptop and it worked. The link light on the Sonicwall comes on when I plug it into a switch ruling out defective nic. I'm stumped. The Internet frovider tells me the Cisco router 'doesn't conflict with any Firewall ???
kuohCommented:
The next step would be to connect the laptop again, and assign it either the Cisco or Sonicwall IP, depending on which device is connected at the time, and verify that simple communications like pings are working.  Then you can proceed to the next step, which is verifying that both configurations are correct.

KuoH
CompTIA Network+

Prepare for the CompTIA Network+ exam by learning how to troubleshoot, configure, and manage both wired and wireless networks.

meteormanAuthor Commented:
I plugged a network cable from the Cisco router into the Sonicwall firewall and no link light  appeared as well as the wan port had a red x next to it on the status page in the GUI would that mean no matter what I do on the Sonicwall there will not be any connectivity? There was no link light after a factory reset from within the GUI
kuohCommented:
Then I would double check that you did indeed use different cables in testing, because if Cisco to switch and Sonicwall to switch both get links, then there should be no reason that Cisco to Sonicwall doesn't get a link unless there is a problem with the cable.  Chances are, you need a crossover cable, and the one you have either isn't or may have a break in it.

KuoH

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
meteormanAuthor Commented:
I'll have to go back on site and try that cross over cable again.
jimmyray7Commented:
On the sonicwall, try specifying the port speed and see if you get a link (it's on the advanced tab).  I'd try 100 Mb full duplex first, but try them all and see if you get a link.  The auto-detection might be failing.
meteormanAuthor Commented:
It was a faulty Cross over cable.

Tahnk you
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Architecture

From novice to tech pro — start learning today.