Folder permissions not inheriting from parent (Server 2008 R2) ?

am facing an issue with sub folders files where if change any permission on the top level folder it will not inherits while the inheritable option is enabled .

so this is happening & is there any way to rest the default value of the folder , sub folder  & files permissions ??

human1900Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SaadAhmedFarooquiCommented:
Someone must have unticked the check box "Inherit From Parent........". This box neeeds to be checked you will find it when you properties of the folder go to security and go to advance.
0
Firmin FrederickSenior IT ConsultantCommented:
If you're not propagating permissions to lower (sub) folders properly then firstly take full ownership of the root folder and all sub folders then change you settings and permission and select "Replace all child object permissions with inheritable permissions from this object" and "include inheritable permissions from this object's parent" and then click apply, then OK.
0
human1900Author Commented:
thanks for all of you , i know what all of you taking about  & alreadi tryeid that but
for some resone its not going applyed for the sublevevels files .

the folder size is arround 3GB & its containing maybe 7-10 levels of subfolders & files which is really headacble to drill every file & change the permision on .

therefore am looking on awy to rest the defult value of security for that folder .
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Firmin FrederickSenior IT ConsultantCommented:
there is a utility that will do it for you unfortunately I do not know it offhand and will have to get back to you.
0
Firmin FrederickSenior IT ConsultantCommented:
hi there sorry to take so long had to get home first.

OK - the tool provides a "right button click" shell command to explorer that then allows you to give "admin" full control of all sub directories and therefore allowing you to further propagate permissions.  If this fails then I'd suggest running chkdsk in the /f mode to look for problems in the drive/data.

Copy the following exactly to a .txt file and then save it as a .reg file.

You can see for yourself the code is harmless and everyone/anyone who thinks it is suspect will say so I'm sure:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\runas]
@="Grant Admin Full Control"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant everyone:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant everyone:F"

[HKEY_CLASSES_ROOT\exefile\shell\runas2]
@="Grant Admin Full Control"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\exefile\shell\runas2\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant everyone:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant everyone:F"

[HKEY_CLASSES_ROOT\Directory\shell\runas]
@="Grant Admin Full Control"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant everyone:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant everyone:F /t"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
human1900Author Commented:
i did nt fix up the issue but its  a good solution
0
Firmin FrederickSenior IT ConsultantCommented:
sorry to hear your problem hasn't been reolved do you require further assistance?
0
haggishkCommented:
we have this same frustrating problem -

Folder A - permission for certain users only
  child folder 1 - inherits from parent but changes user permisions to special and this folder only
    child folder 2 - no inheritance from child 1

if we go back to folder A then try to replace all permissions on the child folders, nothing happens, just the warning but the permissions dont change.

when viewing the permission further in, folder A is correct, child one changes to special permission and child 2 reverts to system, admin and an unknown account.  when trying to change the permissions on the child folders the only way to get it working is to not inherit then and add the users, however you are back to square 1 the next level in.

anyone from microsoft able to respond to this very frustrating problem
0
Firmin FrederickSenior IT ConsultantCommented:
Hi there - have you tried the reg file i posted above?
0
lesterpenguinneCommented:
Image of permissions showing check boxOn the root folder under advanced security edit the user/group permission and look at the bottom left corner see if the little box is checked, if it is uncheck it. this may be your issue as it only allows the permissions to go to the next level only and will give you that special permissions on any folders below.
Good luck
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.