Cannot Install VMWare Tools b/c IDE Controller is not available

We have a P2V'd virtual server that we cannot install VMWare tools on.

After the P2V we tried installing the tools but noticed the Tools CD never mounted.  Upon further investigation it appears that the IDE Controller is not working which would explain why the CD never mounts.  

In Device manager the status is "This device is not configured correctly.  (Code 1)"

I have tried removing it and letting Windows find it again.

I have a feeling that this would be fixed by the guest tools install but I have no idea how to get them on the VM now (the NIC does not work either).

Windows Server 2003 SP2
The physical was a Dell PowerEdge 2950

Any help getting the Tools installed would be appreciated.

Thanks -
Jason
jasonracAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

coolsport00Commented:
I assume you're using ESX/ESXi? What version are you using? In the VM's 'Edit Settings' area, is the SCSI controller IDE? If so, you need to change it to LSI Logic. That may help. See this KB:
http://kb.vmware.com/kb/1016192

You can download VMware Tools directly from VMware's site and install on your VM, but without network connectivity, I'll have to think how you can get the Tools ISO on your VM...

Regards,
~coolsport00
0
jasonracAuthor Commented:
Thanks for the response coolsport -

The SCSI Controller is set to "LSI Logic Parallel" and the CD Drive is IDE 0:0
0
coolsport00Commented:
Is the 'Mode' for the CD set to passthrough or emulate IDE?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

jasonracAuthor Commented:
Emulate - should I try Passthrough?
0
coolsport00Commented:
Yes, try Passthrough
0
coolsport00Commented:
Also, provide the specific error VMware gives you when you try to do the Tools install (if changing the CD 'mode' doesn't help).

~coolsport00
0
jasonracAuthor Commented:
Trying the new CD type now - there is no error though, just nothing ever happens.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Remove the CDROM device and add a new one.
0
jasonracAuthor Commented:
Removed and added as passthrough but no luck

Any other way to get a file onto the machine?  I do have the ISO of the tools, it's just not on the guest.
0
coolsport00Commented:
Remove the CD hardware as suggested by "hanccocka", then re-add it and see if that works.
0
jasonracAuthor Commented:
I removed the CD Drive, then added it again - is there something else I should be trying?
0
coolsport00Commented:
What does your Hard Disk show for SCSI?...1:0 or 0:0? If anything other than 0:0 (your CD I believe should show 'IDE 1:0'), then I think there in lies the problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jasonracAuthor Commented:
The harddisk is SCSI 0:0

The CD is IDE 0:0
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I'd remove the CDROM drive whilst off, start-up the machine, then shutdown, and add the CDROM drive backup again, does the VM "Plug and Play" and detect the new hardware, it's possible that plug and play is not functioning.

Have you removed all the hidden devices, after P2V?

1) Open the “Start” menu and choose “Run…”
2) Type in “cmd” (without the quotes) and click “ok”.
3) At the cmd prompt, type in “set devmgr_show_nonpresent_devices=1¿ (without the quotes) and press enter. (Note that nothing seems to happen–this is ok. We are actually setting an environment variable which is going to help us to see hidden devices)
4) On the next cmd prompt line, type in “devmgmt.msc” (without the quotes) and press enter. This will launch the Windows Device Manager Console.
5) In the Device Manager Console, from the “View” menu, select “Show Hidden Devices”.

Now, as you expand the different drivers and devices in device manager you will see not only the items that Windows currently detects as installed on your pc (these are the usual items displayed), but you will also see drivers, devices, and services which have been loaded in the past but were not uninstalled or are not currently started. You can find your offending device, right-click, and choose “uninstall” to remove it from the system completely.

you may also just want to check this article about P2V, by fellow expert Bestway

http://www.experts-exchange.com/Software/VMWare/A_3639-VMware-vConverter-P2V-for-Windows-Servers.html

Sometimes, after a P2V, you can have weird issue like this, with CDROM, NICs, and Mouse control.
0
JRoyseCommented:
How about using a floppy image:

http://kb.vmware.com/kb/1006956
0
jasonracAuthor Commented:
I tried removing the old IDE controllers from Device Manager but the new virtual IDE Controller is still not working, with error code 1 (which according to Microsoft means there is no suitable driver found).

I also tried putting the NIC drivers on a floppy image but I cant get the floppy to work.  I used MagicISO to create the floppy image, I am not sure if that is the correct format for VMWare though.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Have you removed all the hidden devices?

At present, I would concentrate on all these errors, before worrying about VMware Tools.

VMware Tools will not resolve the CDROM, or plug and play issues, which you appear to be having at present.

What was the source physical server you have tried to convert?

After conversion, at startup, did you see it plug and play, and find lots of new hardware?
0
jasonracAuthor Commented:
I finally solved this problem!  Thank you both for your suggestions, I will award points equally as your suggestions lead me down this road.

There was a service named "WebClient" that was stuck in the "Starting" phase - for some reason no other services were starting during this time, including "Plug and Play" - so none of the new hardware was being seen.  I disabled this service and killed all the svchost.exe processes, then immedaitely all the normal "New Hardware" messages popped up.  I rebooted and was able to see the CD drive and install Tools - all is well now.

Thank you
0
coolsport00Commented:
Glad it's resolved. Never heard of that type of issue before, but good info for others who may run into this problem.

Regards,
~coolsport00
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.