NT Workstation Not Booting

Hi, we have recently bought a second hand panel bending machine, £150k's worth of machine.

The machine has NT workstation 4.0 installed as the OS with the propriety machine software installed.

There was some concern over no backup being available for this machine if the pc inside it stopped working, so under instruction, I was asked to create a clone of the hard disk.

I took the hard drive out, cloned it in another pc and this is where the problem starts.

When I attempt to reboot the NT pc, have reinserting the hard drive, it boots so far until I get the BSOD with the INACCESSIBLE_BOOT_DEVICE error.

Any ideas as we have no backup of the machine software, as this machine was bought from a company closing down.

Thanks in advance
SoricAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jerrypdCommented:
I am assuming that this is an IDE drive.
Are you certain you reconnected it to the correct connector inside the machine? If you connected it to the "slave" connection this is the error you would get.
Has anything else inside the machine been touched? CD-ROM or anything like that?
Do you get the blue screen with NT 6.0 and the "dots" on the screen?
0
zazagorCommented:
Hi,

My guess is that this a RAM memory issue. Try this:
1) Remove 1 or more RAM-modules.
2) Try replacing the RAM modules with other compatible modules.

//zaZagor
0
SoricAuthor Commented:
Yep, its an ide drive. Gets all the way through the boot up process with 'dots' until the point where it is about to ask for login details.

Nothing else been touched inside the machine.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

jerrypdCommented:
Well the point where NT goes from text-based to graphics-based is right there. That is when the windows kernel is loaded.
It is also the first time that the bootstrap loader is looking for a specific drive in a specific place. If the cables are all attached the way they were originally, then i fear there is another issue having to do with the drive itself.
Question: when you pulled the drive to clone it did you have any "weirdness" at all? Did the cloning software throw any exceptions or errors?
I would next recommend that you pull the drive again and do a chkdsk on that drive. It sounds as if there is a corrupt file(s)...

0
SoricAuthor Commented:
Just checked the drive, no errors reported.

Have tried the drive and cd in every posible cable configuration and back to the original setup.

Tried a system repair, but cant get anywhere without the original ERD.

Read somewhere, earlier at http://www.bleepingcomputer.com/forums/topic83063.html about the removing a disk from an nt machine and then replacing it causes problems. Does the resolution outlined ther make sense?

Thanks
0
jerrypdCommented:
i see where they are going with that solution - and yes it *may* work.
Did the second computer ask you to add the drive when you mounted the original disk?
did you change any jumper settings on the drive when you did this operation?
If not, then i guess you have no choice but to try the solution outlined on bleepingcomputer...
0
SoricAuthor Commented:
Thats a task to try tomorrow then.

Having a 150k machine unusable is something I need to sleep on first.

Thanks for your help
0
oBdACommented:
The issue here is not the one described in the bleepingcomputer link. The method described there is an excerpt of a Microsoft KB article and applies to Windows 2000, not to NT4.
How to troubleshoot "Stop 0x0000007B" error messages in Windows 2000
http://support.microsoft.com/kb/822052

The problem here is very probably that you've put the NT4 drive into a machine running a later Windows version, and the file system on this disk has now been converted to NTFS5. NT4 can only handle NTFS5 if SP4 or later is installed, which is very probably not the case for this installation.
The issue is described here (it's about dual booting, but the conversion also takes place automatically even if you "only" mount the drive in a different machine running W2k or later):
Dual-Booting Windows NT 4.0 and Windows 2000 on NTFS Partitions
http://support.microsoft.com/kb/184299
Note the part about "If you are installing Windows 2000 to dual- boot with Windows NT 4.0 on a volume using NTFS, you may not be able to boot Windows NT 4.0." and "If you plan to dual-boot Windows NT 4.0 and Windows 2000 for evaluation purposes, you must first install Service Pack 4 or later on Windows NT 4.0."
Since it's somewhat impossible to install a service pack on a machine that won't boot, the only thing that I can think of that might perhaps revive this installation would be to replace ntfs.sys with a newer version.
The first difficult task is to find SP6 for NT4; since support for NT4 has expired quite some years ago, Microsoft doesn't offer the SP for download anymore. Google for "sp6i386.exe"; you'll have to judge yourself how reliable the download locations are (http://www.filewatcher.com/m/sp6i386.exe.35720696.0.0.html has a lot of links). The size should be about 34MB.
Then open sp6i386.exe in any zipper, and extract ntfs.sys.
In whatever machine you've already used to clone the drive, rename the original ntfs.sys in %SystemRoot%\System32\Drivers, and copy the one from the SP into the folder.
Put the drive back into the original machine and try your luck.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jerrypdCommented:
This sounds feasible. The only thing I can find fault with is that i have not seen an NT system that doesnt have SP6.
if you need a copy of SP6 NTFS.SYS i can probably hunt one down.
0
SoricAuthor Commented:
have a copy of SP6...will try it now. the original disk shows SP3 installed

thanks, will elt you know how it goes
0
SoricAuthor Commented:
Perfect solution, problem solved, pc up and running again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.