Importing file to Excel

When I import a text file to excel in Office 2010, it changes some of the numbers to dates. Not all of them, it just seems to be random numbers that change. It works just fine in Office 2003 when importing the same document, Is there something in 2010 that needs to be disabled or enabled?
LVL 3
WinsoupAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brian BEE Topic Advisor, Independant Technology ProfessionalCommented:
Not sure I have a direct answer, but a couple of items to look at:

It could be your default date format. Any chance the dates that are not importing correctly have a date bigger than 12?

Are you importing the data into a new sheet, or an existing sheet. If its existing, make sure the cells are all formatted the same.
0
WinsoupAuthor Commented:
I attached an image of some of the numbers. To the right of the dates I put what the number should be. This is from a program called MC2 which pulls info from another program and automatically exports it an excel sheet. So they are all new sheets. I can look at the info before it gets transferred to excel and it all looks good.  Excel Example Excel Example
0
ragnarok89Commented:
During the import process, you have the option to specify the format of each column of information to be imported. At this point, you could select that column, and tell excel to import it as text. This prevents excel from trying to reformat the text into something else.
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

WinsoupAuthor Commented:
I don't think we have that option. It automatically opens up an excel sheet and transfers the data once you tell MC2 to export it.
0
Brian BEE Topic Advisor, Independant Technology ProfessionalCommented:
I see the problem. If I type those numbers in manually, it does the same thing. If you look at the underlying cell, Excel has turned it into some sort of future date. The reason the others don't do it is that they don't look like date serial numbers.

Clearing the formatting doesn't seem to help. Maybe specifying the default cells for Excel are text would do it. I'll check further and see wha tI can find, but if another expert knows feel free to jump in rather than wait for me.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
WinsoupAuthor Commented:
Thanks for the lead. I created a template that was formatted for text only and saved it to the XLSTART folder so it uses that by default. It seems to be working fine now.

Thanks you!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Excel

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.