• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 834
  • Last Modified:

Exchange 2003 removal from coexistence with 2010 - SMTP 5.0.0 problem

Experts,

I have a problem with inbound delivery to our Exchange 2010 server after removing our Exchange 2003 server.

Prior to removal, all inbound emails were being pointed to our Barracuda and fwded to Exchange 2010 (was setup this way for about a week).  Outbound email has no problems.

Right after the removal, I am getting this NDR from external senders and no inbound mail is being received.


Delivery has failed to these recipients or distribution lists:

recipient@domain.com
An error occurred while trying to deliver this message to the recipient's e-mail address. Microsoft Exchange will not try to redeliver this message for you. Please try resending this message, or provide the following diagnostic text to your system administrator.

Diagnostic information for administrators:

Generating server: mail.domain.com

recipient@domain.com
#< #5.0.0> #SMTP#

the error code doesn't really tell me much.  What could be the problem here?
0
Pro4ia
Asked:
Pro4ia
  • 8
  • 6
  • 2
2 Solutions
 
Glen KnightCommented:
Have you confirmed the barracuda is sending to the 2010 server? Are you authenticating from the barracuda? If not setup the default receive connector to ensure anonymous access is ticked.
0
 
Pro4iaAuthor Commented:
thanks for response.  on barracuda log, I did see that the mails had "delivered" status so it looks like mails are passing barracuda fine.

perhaps it has to do with recipient connector or routing groups.  prior to uninstalling Exchange 2003, I did remove the Ex03 <-> Ex10 routing group connectors.  

I did check the default receive connector and made sure anonymous is checked.  should i try recreating it?
0
 
ChopperCenturyCommented:
Have you updated the SPAM filter to send emails to the new Exchange server? Also if you want to bypass the Baracuda you can change the NAT on your firewall from the Baracuda to your Exchange server.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Pro4iaAuthor Commented:
yes as mentioned in OP, barracuda has been pointing to the Exchange 2010 for almost a week now.
0
 
Glen KnightCommented:
You shouldn't need to recreate it.

You have all the accepted domains configured?
0
 
Pro4iaAuthor Commented:
yes the setting has been copied over during coexistence with Ex 03.
0
 
Pro4iaAuthor Commented:
after removal of Exchange 2003, is rebooting Exchange 2010 recommended?
0
 
Glen KnightCommented:
It may be worth a go, can't say I've ever had to.

Can you telnet to the exchange server on port 25 and send an email following these steps: http://support.microsoft.com/kb/153119

From the exchange management shell run: get-accepteddomain and post the results please
0
 
Glen KnightCommented:
Also, can you set port 25 to go directly to the exchange server instead of the barracuda? This will help is eliminate this as the problem.
0
 
Pro4iaAuthor Commented:
[PS] C:\Users\pro4ia\Desktop>get-accepteddomain

Name                           DomainName                     DomainType                   Default
----                           ----------                     ----------                   -------
domainfoods.org                 domainfoods.org                 Authoritative                False
domainfoods.com                 domainfoods.com                 Authoritative                False
domain.com                      domain.com                      Authoritative                False
domainfoodsco.com               domainfoodsco.com               Authoritative                True

domainfoodsco.com is our primary public email domain
0
 
Glen KnightCommented:
Can you try the telnet test and the port 25 redirect?
0
 
Pro4iaAuthor Commented:
I have successfully performed the manual SMTP test from inside the network.

currently our MX is pointing to barracuda and no telnet is allowed to Exchange 2010 server directly from outside.  could this be a problem?
0
 
Glen KnightCommented:
It shouldn't be as long as the barracuda is doing what it's told.

You should be able to change port 25 to go to your exchange server instead of the barracuda on your router/firewall.

This will help identify if the problem is exchange or the barracuda.
0
 
Pro4iaAuthor Commented:
we might have something here.. after redirecting tcp 25 directly to Exchange 2010, I was able to receive an outside email.. i'm rebooting barracuda as I type this
0
 
ChopperCenturyCommented:
I guess when I mentioned trying to change the NAT on your firewall in my first post this was overlooked?
0
 
Pro4iaAuthor Commented:
chopper - sorry it looks like i overlooked it.  I don't manage the barracuda myself so after looking at the setting myself, there was a tab in there that has all accepted domains and which server it should be pointing to.  corrected this and inbound emails are now happy again.  will split points.

appreciate the help from both of you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

  • 8
  • 6
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now