Can only send email with attachments through OWA and can only set OOF through OWA

Hi Guys,

We've migrated an SBS2003 server over to SBS2008 and this has been working fine except on Friday users (only on 2007) were getting certificate errors. I managed to change the internal url through the shell and this then went away.
Over the weekend the Exchange System Attendent appeared to stop, i restarted it this morning and now no-one can turn their Out Of Office on or off or send any kind of attachment through email in Outlook however if they log onto OWA they can do both.
The OOF issue only appears to be on Outlook 2007 as the 2003 users appear to be able to do this fine but no-one can send emails from Outlook with attchements (this only works through OWA)
I am assuming it's certificate related ? but don't know where to go from here.
I have also tried sending a plain email (i.e no signature) with an attachment but it still bounces back.
The bounceback states :

Delivery has failed to these recipients or distribution lists:
 
John Doe
The e-mail system had a problem processing this message. Microsoft Exchange will not try to redeliver this message for you. Please provide the following diagnostic text to your system administrator.
 
  _____  
Sent by Microsoft Exchange Server 2007




 
Diagnostic information for administrators:
 
Generating server: server.internaldomain.local
 
users@destinationemailaddress.co.uk
#550 5.6.0 M2MCVT.StorageError; storage error in content conversion ##

Any ideas would be great.
LVL 1
NetexpertsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NQMidsCommented:
Did you also change the url for the EWS?

Set-WebServicesVirtualDirectory -Identity "Servername\EWS (Default Web Site)" -InternalUrl https://server-fqdn/ews/exchange.asmx

That might explain your OOF, but not sure about the attachments, I don't get that. Have you applied all the available service pack and updates?

FYI, You might also need to set the URL for the OAB, Set-OABVirtualDirectory
praveenkumare_spCommented:
if u had made changes to ews then oof, availablility service will have a hit

check whether ur autodiscover service is fine by doing a test-email autocinfig


let me know if u need more info
NetexpertsAuthor Commented:
Thanks

I've just tried the

Set-WebServicesVirtualDirectory -Identity "Servername\EWS (Default Web Site)" -InternalUrl https://server-fqdn/ews/exchange.asmx

Changing the server-fqdn and servername for my own but i get the error

'The operation could not be performed because object 'servername\EWS <Default Web Site>' could not be found on domain controller servername.domain.local

I'm assuming i only needed to change the servername and server-fqdn in this syntax ? If so then i guess this is part of the issue.

Ian
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

NetexpertsAuthor Commented:
Also i've tried the Test Email Autoconfig and this has returned 'Autoconfiguration was unable to determine your settings!'
NetexpertsAuthor Commented:
Sorry for the extra additions.

I've just ran get-webservicesvirtualdirectory | fl and it's return the information of:

InternalNLBBypassUrl : https//server.internaldomain.local/ews/exchange.asmx (which i presume is ok)
InternalUrl : https://sites/EWS/Exchange.asmx (which doesn't look right)

not sure if this helps ?
NQMidsCommented:
Sorry, I've not worked on 2007 only 2010, so I can't say to definite what the syntax should be. Check out Technet. Also have a look in IIS manager, as your on an SBS server the EWS might not be under Default Web Site.
NetexpertsAuthor Commented:
Thanks,

In IIS it actually shows under SBS Web Applications so i changed the command to this and it now accepts it and shows the internal URL as https://servername.internaldomain.local/ews/exchange.asmx
I have tested the Outlook again but it still bounces back. Do i need to restart any services or site ?
NetexpertsAuthor Commented:
I think i can see the issue.
If i run test-outlookwebservices -identity user | fl it shows an error when connecting to :
https://remote.domain-name.local/autodiscover/autodiscover.xml 'the remote name could not be resolved 'remote.domain-name.local

We do not have a domain-name.local domain.
Out external email domain is domain-name.co.uk and our internal domain is domainname.local

Where do i need to change this to either look for remote.domain-name.co.uk or remote.domainname.local

Hope this makes sense
NQMidsCommented:
EWS - Is servername.internaldomain.local the fqdn for your server, if you ping servername.internaldomain.local does it respond?

Autodiscover - Use "Set-ClientAccessServer -Identity servername -AutodiscoverServiceInternalUri https://serverfqdn/autodiscover/autodiscover.xml" then configure a DNS Autodiscover SRV record for your primary SMTP domain.


NetexpertsAuthor Commented:
ping responds with an IPV6 response (not sure if that's an issue) for servername.internaldomain.local but a ping for servername.domain-name.local doesn't repspond.

whe you say primary SMTP domain i presume you mean our default email domain address ?
NQMidsCommented:
Yes, primary SMTP is default email domain.

Not sure about IPv6, but you got a response so that's good. Try using the Set-ClientAccessServer command above to set the autodiscover address to servername.internaldomain.local

Once that is done you'll need to make sure servername.internaldomain.local is listed in your certificate, but lets just see if it works first.
NetexpertsAuthor Commented:
I think i may be confusing things a bit:
Going back to your last response.
EWS, is servername.internaldomain.local (which pings fine) but
 test-outlookwebservices -identity user | fl is trying to contact remote.external-domain.local
What i mean by this is that the external-domain.co.uk is our SMTP address (with a dash) and internaldomain (no dash) is our internal domain so it's taken the external-domain and added it to .local to make up what looks like a new domain.

In effect we have a sort of micro-soft.com as our SMTP and microsoft.local as our internal and this is contacting micro-soft.local which is not a domain we use or have set anywhere.

does that makes sense ?
NQMidsCommented:
Ok, think I understand.

Your Autodiscover isn't working and without it your going to have problems. Take a quick read of this and if it makes any sense.

http://technet.microsoft.com/en-us/library/bb332063(EXCHG.80).aspx
NetexpertsAuthor Commented:
It appears that the service connection point is pointing to the wrong domain by the looks of the link.
 I can't see any way of changing it though.
NetexpertsAuthor Commented:
I've checked through ADSI edit and gone to the following container (in the screenshot) but under services i have CN=Microsoft Exchange but nothing under that but in the screenshot it shows a CN=Microsoft Exchange Autodiscover container, does anyone else have this or is this because we have SBS 2008 and it shouldn't be there ?
NQMidsCommented:
Can you run an Autoconfig Test from an Outlook client again and post the log please.
NetexpertsAuthor Commented:
I've replaced the entry domain names with the micro-soft and microsoft one's for this post (obviously)

Log shows:
Attempting URL https://remote.micro-soft.local/autodiscover/autodiscover.xml found through SCP
Autodiscover to https://remote.micro-soft.local/autodiscover/autodiscover.xml starting
Autodiscover to https://remote.micro-soft.local/autodiscover/autodiscover.xml FAILED (0x800C8203)
Autodiscover to https://micro-soft.co.uk/autodiscover/autodiscover.xml starting
Autodiscover to https://micro-soft.co.uk/autodiscover/autodiscover.xml FAILED (0x800C8203)
Autodiscover to https://autodiscover.micro-soft.co.uk/autodiscover/autodiscover.xml starting
Autodiscover to https://autodiscover.micro-soft.co.uk/autodiscover/autodiscover.xml FAILED (0x800C8203)
Local autodiscover for micro-soft.co.uk starting
Local autodiscover for micro-soft.co.uk FAILED (0x8004010F)
Redirect check to http://autodiscover.micro-soft.co.uk/autodiscover.autodiscover.xml starting
Redirect check to http://autodiscover.micro-soft.co.uk/autodiscover.autodiscover.xml FAILED (0x80072ee7)

Just to re-confirm we have our SMTP as micro-soft.co.uk and our internal domain as microsoft.local but we don't have a micro-soft.local domain at all
We have DNS zones for microsoft.local and remote.microsoft.co.uk


NQMidsCommented:
Ok, I think you the easiest is for you to create an SCP record.

Sorry I can't point you at a decent tutorial, but you'll need to reference servername.microsoft.local

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
NetexpertsAuthor Commented:
I've followed this on the old SBS2003 box (as we've not removed it yet)
http://technet.microsoft.com/en-us/library/bb125157(EXCHG.80).aspx

You can also locate the SCP point manually by using Adsiedit.msc:

DC=<domain>, CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=First Organization, CN=Administrative Groups, CN=Exchange Administrative Group, CN=Servers, CN=<CAS Name>, CN=Protocols, CN=AutoDiscover, CN=<CAS Name>

And the entry was there, i've changed it and now we have successfull Autodiscover but the original problem is still there. Any thing with an attachement bounces back with #550 5.6.0 M2MCVT.StorageError; storage error in contect conversion

NQMidsCommented:
Does the OOF work now?
NetexpertsAuthor Commented:
Yes, the OOF works fine now.
NQMidsCommented:
Some progress then, unfortunately I don't know what is causing your problems with attachments. Hopefully someone else can help you.

NetexpertsAuthor Commented:
We have resolved this by rebooting the server and it worked. Looks like something had hung however in the event viewer we noticed registry issues so it looks like it had gone corrupt.
Have awarded points relative to time and responses given as both had helped resolve the other issues along the way.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.