Why isn't the YOUTUBE video embeded on my website working in IE?

Hi Experts,

Why isn't the video I have embedded on a homepage I'm working on working in IE?

It works in FF, and Safari, but not IE

http://www.djmgraphix.com/st_peters_armenian_church/index.html

Thanks,
DJM
DJMgraphixAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jschristian44Commented:
you need to install the IE flash drivers.  just go to youtube.com and click on a video.  it will then ask you to install the drivers.  you probably have them installed in firefox and safari already.
0
DJMgraphixAuthor Commented:
Of course my Site5 server is currently down!  So I can't test it now.  I'm on a Mac and don't have IE on my computer.  I have another Laptop with IE.  Do I have to do it on that laptop or something with the website?  My main concern is that others who don't have the driver installed that they will just get a red x also in place of the video.
0
jschristian44Commented:
yes you need the laptop to have the drivers, not the explorer.  i am pretty sure anyways.  well you just need to have IE have flash installed to it.  and they install that to your hard drive, so yes your laptop needs to have it.
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

DJMgraphixAuthor Commented:
so the websites are up and running again... I checked out the laptop and it does have the drivers loaded.... I have other websites with embedded youtube videos on them and they work fine.  Just with this website.  Not sure why...
0
jschristian44Commented:
the youtube video worked fine for me.  it must be something to do with your code.  you need to enable it for IE.  do you have the latest IE?  maybe it is the new version of IE 9 that is needing different code i am guessing since im guessing you created the other websites with IE 8?  am i right?  i bet any money it has something to do with IE 9.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DJMgraphixAuthor Commented:
I updated the embeded link with the latest code from youtube.  The one that I had was considered their, "older" version.  And yup... the laptop had IE9 installed on it.

Thanks for your time and help!
0
jschristian44Commented:
heh, glad i was able to help you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.