DNS / DHCP?

Of course no one admits to having changed anything, but this morning complaints came in that shortcuts to internal servers etc were responding "cannot be found" when clicking on them.

Before I get further into detail, here's what seemed to fix the problem:

1.  Manually add the IP of the Primary DNS server (win 2008 R2) on the properties of IPv4 network adapter (win 7).  Close out of the properties pages.
2.  Remove what was done in step 1.
3.  Ipconfig /FlushDNS, RegisterDNS

I don't even know where to begin looking since nothing has changed since all was working well  Friday.

Thanks for sharing where I should begin and what further details I should provide.

Monday





i_need_answersAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bill30Commented:
make a login script to copy a serverside host file with all the DNS entries

login script is in this format
cp \\<servername><path to host file to be copied> c:\<path to "etc" folder>
0
Hypercat (Deb)Commented:
Were these workstations shut down over the weekend? If not, did you try just rebooting them or running ipconfig /release, ipconfig /renew to refresh the DHCP settings?
0
Svet PaperovIT ManagerCommented:
Is your DNS server up? You can test it with the nslookup command from one of the stations.

Or, try to empty the cache of the DNS server.  
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

i_need_answersAuthor Commented:
Thanks for your responses, This issue is not getting the attention it deserves and has been temporarily band-aided by inputting static DNS entries on the clients, but the page loads are still very slow for all sites as mentioned below.  

We have checked all the things like server and services up and running etc.  We're pretty sure it is DNS / DHCP related, but not sure.  Some other points.

1.  Verified that DHCP is passing DNS servers and correct helper address on routers
- ipconfig /all has all correct information, but
2.  If you try to connect to a fileshare on some server within the domain you get "connection cannot be established", but then
- run ipconfig /renew and ping that server and the fileshare is then browseable
3.  Internet page loads are very slow (this may be a separate issue, but happened at the same time)

I don't know how all of this could happen seemingly overnight and I'm the only one working on it so bare with me if a day goes by before I respond.

Thank you!

0
Hypercat (Deb)Commented:
Are you using only internal DNS servers for all your server and workstation TCP/IP settings? If not, then remove any external DNS servers listed there.

Does your domain include more than one IP subnet? IOW, are you passing DNS/DHCP information across internal routers?
0
i_need_answersAuthor Commented:
@ hypercat, so we found that we had 2x conditional forwarders pointing to external dns servers and the 127 loop-back address.  Again, there was no problems this time last week and only 3 of us that could have made changes and didn't.  Our ISP stated that the two dns servers we were pointing to have not changed in any way.  Our problem seems to have certainly been related to misconfiguration of DNS servers and requests that were timing out before name resolution occurred.  Removing the above forwarders and adding 4.2.2.2 looks to have solved our problem.  
What I don't understand is why simply pinging the resource we wanted to connect to but could not connect to before pinging and running ipconfig /renew was then accessible after doing so?

I don't handle the network/switches/routers etc, but our users are only on one subnet and yes I believe we are passing the DHCP/DNS info across our internal routers.

Thank you!  
0
Hypercat (Deb)Commented:
It sounds to me as though you were running into a response time issue with the external DNS forwarders. It could even have been caused by a problem with a router inbetween your network and your ISP's DNS servers - anyway something was apparently causing those DNS servers to respond unreliably and intermittently.  They might have thought everything was working fine but in fact it wasn't.
0
i_need_answersAuthor Commented:
@ hypercat,
are you able to shed any light on my question below?  Example:  trying to connect to \\net-app\folder from a workstation.

What I don't understand is why simply pinging the resource inside our domain we wanted to connect to but could not connect to before pinging and running ipconfig /renew was then accessible after doing so?

Thank you!
0
Hypercat (Deb)Commented:
I really can't answer that question. You said something about "conditional forwarders" and I'd have to know more details about that - what were the conditions?  Also, you  mentioned something about 127.0.0.1 being listed - was that on your forwarders list? This would definitely be incorrect - your own server IP address or loopback should never be listed as a "forwarder - although if it was there it seems to have worked fine for some time. If these external DNS servers were listed anywhere other than in the properties of the DNS service itself then they certainly could have been causing problems. But I would think that the problems would have been going on for a longer time and would have been much more severe.  The symptoms sound like somehow the external DNS servers were being queried for internal name resolution - I just can't see from what you've told me how that was happening.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
i_need_answersAuthor Commented:
@ hypercat Thanks for the responses!
0
i_need_answersAuthor Commented:
We resolved our own problem via MS, but hypercat stuck with us and provided insight.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.