Domain Controller hanging everyday

I have this situation:

Yesterday, the 4th of April I was unable to RDP into a domain server (95.95.95.54) located in another country. I then tried to RDP to Server 95.95.95.53 (which is part of the domain) but could not authenticate myself when I tried to log in. We found that the Domain controller was in a hung state and so we rebooted the server. After that, I was able to RDP to the domain controller 95.95.95.54. Note that during this time, I was able to ping the domain controller.

Today, the 5th of April, I am able to ping the domain controller 95.95.95.54. But it takes a very long time to RDP into the server. When I do get connected, I get a blank screen and am unable to get my log in window. I then tried to log in to 95.95.95.53 and performed a RDP to 95.95.95.54. At one stage I was able to log in, but after that it just hanged. Now the same thing happens, I'm unable to get the log in screen.

What is happening? Yesterday when I checked the event logs, I didnt see any errors.

Also, I have a backup software (Symantec Backup Exec 12) running on this server.
ben1211Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bcdudleyCommented:
Check the fans on the server to make sure they are all spinning and the server is receiving adequate ventilation. Also, clean the heat sinks good with pressurized air.

Throughout the day, keep an eye on the memory usage to see if there may be a program that is using up all the memory. Also, if it is possible to shut it down for a maintenance window, run a program like memtestx86 on it to see if there are any problems.
NivleshCommented:
Do you have any backups running during the time that the server hung? Are there any other scheduled tasks/jobs that might be using a lot of system resources? Also, is this a virtual or a physical server? BTW what is the version of the OS, Memory, HDD free space?
Kini pradeepDevelopment ManagerCommented:
1. are you using the /console /admin switch when using RDP ?

2. even if its blank if you do a ctrl+ alt+ del and the enter username tab pwd, do you get to the desktop.

3. is this DC in a english language ?

4. what are the errors reported if any in winlogon etc.

5. if you connect to the server using TS manager when the issue happens does it show any disconnected sessions etc ?
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

ben1211Author Commented:
I checked the event logs. The backup is scheduled to run at 7:30pm and the error message that I saw was triggered about 30 minutes later:

RSM cannot manage library Tape0. Failed to communicate with device or obtain device setup information.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


After the above error message, a serious of error messages appeared:
An I/O operation initiated by the Registry failed unrecoverably. The Registry could not read in, or write out, or flush, one of the files that contain the system's image of the Registry.

I also checked the Symantec Backup Exec 12 logs and found this:
Problem

Error "Insufficient memory available. V-79-57344-33996- No more free buffers" appears while performing a backup to tape with Symantec Backup Exec for Windows Servers
Error


After rebooting the server, I found this error:

The DHCP service failed to see a directory server for authorization.

I checked the DHCP and found it to be running fine. Any command I can run to check on the DHCP?

ben1211Author Commented:
not using /console or /admin for RDP. The method I used is the same way I used last week and it worked fine. I assume that the server was out of memory and therefore I couldn't get the log on window to key in my credentials.

Yes the server is in English Language.

How do I connect using TS Manager?
mil-sysCommented:
If you are able to login by any means of rdp (mstsc.exe /console or mstsc.exe /admin for version 6 and above), verify proper DNS configuration first. I know this is basic but sometimes even the experts forget it :).
If you only get a blank screen or hanged screen attempt to send the ctrl+alt+del, maybe the server is servicing too many requests.
Few point to double check:
1) if it hangs after login in and appears hung, it could be DNS
2) if you can ping the server but cannot login due to domain unavailable issues from another RDP attempt (like from 95.95.95.53), check for the IPSec service and if you do not use policies for RAS/VPN then disable it and reboot the server.
3) Attempt to see the services/DNS/event logs from another server byt running compmgmt.msc at the run command. You can attempt to view services/dns/events/etc.. from another computer to the one that is not responding appropriately, and possibly review errors.
4)Attempt to reboot the DC by typing: shutdown.exe /m 95.95.95.54 /r /f /t 60 at the command prompt (As long as there is no issues with the IPSec service, this command will work ok)
5. Run tsadmin.exe at the run command and try to connect to the 95.95.95.54 server to review opened/closed/inactive RDP sessions. You may close them from the tsadmin.exe console.
6. Attempt a pathping.exe command and maybe this is just a latency issue (since it is in a different country). Maybe a router is not working ok.
7. DNS, FRS, needs to be working (Configured) properly including Sites and Services with proper Global Catalog servers per physical location. A server may be attempting to obtain its LOGONSERVER variable from a further physical location and may need to be a closer LOGONSERVER location.
8. Roaming profiles. Are they turned on? are there any GPO's active for Roaming Profiles or MyDocuments Re-Direction.

Hope this pin points you towards resolution.
Kini pradeepDevelopment ManagerCommented:
The terminal server manager can be invoked through Tsadmin or through administrative tools. you may connect to a remote computer using the Tsadmin, and manage connections, disconnect inactive sessions etc
Vinchenzo-the-SecondCommented:
You need to log on via the /console switch?  This will show if there any error messages on the server.  To rule out the backup sofware stop the services, and see if the DC hangs next day.  You can run a windows backup to backup the system state.

How much memory does the server have?  What version of Windows is it?  How is your page file configured?

RDP is Terminal Services, you have a maxium of two connections per server.

The DHCP error could be a result of the DC hanging...
aco007Commented:
My advice is that you check your network connection.
ben1211Author Commented:
The reason for the Server hanging is because from Symantec Backup Exec, I had checked an option called AOFO (Advanced Open FileAgent Option).

This, it seems according to the symantec website, takes up memory. How I don't know, but it does. After un-checking this option, the server worked fine :)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ben1211Author Commented:
I managed to figure out why the server was hanging. The solution I provided was the cause of the problem.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.