RDP on VM machines

i am running tw VMs on an SXi host.
i can RDP whitin the same network, but unable to RDP from outside.
how do i fix this?
pdsmicroAsked:
Who is Participating?
 
nchandruCommented:
Are you able ping/RDP of the VMs in same vlan/network outside the ESX box?
   - Check the vswitch settings
   - Check the ESX firewall settings
   - Check the VLAN on the firewall whether it is routable

0
 
Justin CAWS Solutions ArchitectCommented:
How is your network configured outside of the ESXi host, and do you have the Windows Firewall turned on within the VMs?
0
 
bcdudleyCommented:
Check your gateway setting on both the VM's as well as the ESXi server.
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
pdsmicroAuthor Commented:
windows firewall is turned off.
DG for ESXi is 192.168.1.
DG for VMs is 192.168.1.1
0
 
Justin CAWS Solutions ArchitectCommented:
Can you ping the VM's from the network you are trying to RDP from?  
0
 
Brian GeeCommented:
Is this ESXi server behind consumer grade router (i.e., Linksys, Netgear, etc.)? And are you trying to RDP from a remote location to your network at home?

If the above is true (and you don't have a static IP at your location), you'll need to setup the DDNS configuration in your router settings along with registering a free DDNS service, like dyndns.org. Unless you're going employ the use of SSH to connect to your network, you'll then need to setup port forwarding (RDP default port 3389) in order to be able to establish connections to the VM guest OSes. More than one guest VM connection using the port forward option would necessitate changing the RDP listening port on other guest VMs (along with setting up the corresponding port forwardings as well) so as to easily connect using, for example, pdsmicro1.dyndns.org:3389, pdsmicro1.dyndns.org:3390, etc. Realistically though, if connecting outside your network, leveraging an SSH connection would make connecting to your network somewhat easier (you could leave all RDP port at defaults) and increase security to your network and remote connections in kind. But SSH would be the subject for another discussion....

If any of the above is far off from what you were intending or asking, then please forgive my ramblings.
0
 
pdsmicroAuthor Commented:
nchandru:
i see the network :none
how do i make that 192.168.1.1-192.168.1.254?

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.