Exchange 2007 (SBS2008) is rejecting mails as spam

I have just installed a SBS2008.
Now several senders complains that their mails is being rejected as spam.
See below:

(part of mail from senders receive from administrator)

            < pasmtpB.tele.dk<http://pasmtpB.tele.dk> #5.0.0 X-Postfix; host XX.XX.XX.XX[xx.xx.xx.xx] said: 550 5.7.1    Message rejected as spam by Content Filtering. (in reply to end of DATA    command)>

Can anyone tell me how to fix this?
OhmitAsked:
Who is Participating?
 
Glen KnightCommented:
you shouldn't need to but restarting the Microsoft Exchange Transport service won't hurt.
0
 
Glen KnightCommented:
do you use a postfix service? This is rejecting your messages.
0
 
OhmitAuthor Commented:
Im not sure what you mean with POSTFIX SERVICE?
I use a smart host for sending but the mx record points to my SBS2008 directly.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
Glen KnightCommented:
Sorry, I have misread the message above, it looks like that may be their system.

In the Exchange management console go to, Server Configuration > Hub Transport > Anti-Spam, check the IP Block list, does it contain any IP addresses?  if so you may want to remove them.

Secondly, under Organisation Configuration > Hub Transport > Anti-Spam, what is enabled here?  if you set them all to disabled, does the mail start coming in?
0
 
OhmitAuthor Commented:
Hi Demazter

It really looks like your the man to solve all my problems :-)

Ok - There is no blocked ip addresses present in the IP BLOCK LIST.
I have tried to disable all under anti spam organisation configuration.

we'll see tomorrow how things is doing.
0
 
Glen KnightCommented:
Good luck :)
Glad to be of assistance :)
0
 
OhmitAuthor Commented:
Ok problem is still not solved completely!

First there was a problem with the ISP who formely hosted the mail.
They have corrected a problem with the MX record but still this is not ok!

the mail domain is "multiformaarhus.dk"

It is not entirely correct that the mail is being rejected as spam.
In most cases the mail just disappers out in the thin air??

BUT!
I have just received this error report from a sender:

(translated from Danish)

THERE WAS A PROBLEM WITH THE SMTP COMMUNICATION WITH THE RECIPIENTS EMAIL SERVER.
EXSMTP01.EXSERVER.DK #5.5.0 SMTP;554 vr@multiformaarhus.dk: RELAY ACCESS DENIED.
0
 
Glen KnightCommented:
In the Exchange Management Console, under Server Configuration > Hub Transport ,can you check the properties of the Default receive connector, does it have annonymous user checked?
0
 
OhmitAuthor Commented:
Under AUTHENTICATION the following is checked:

TLS
Basic authentication
  Offer basic authentication only after starting TLS
Exchange Server authentication.
Integrated Windows authentication

If I look the "Permission group" only the following has access:

EXCHANGE USERS
EXCHANGE SERVERS
LEGACY EXCHANGE SERVERS
0
 
Glen KnightCommented:
you must have anonymous user selected under permission group unless you receive email directrly from a spam filtering service?
0
 
OhmitAuthor Commented:
NOPE!
Im not recieving mail through an ISP's spam filter!

So I must check the ANOYMOUS USERS?
0
 
Glen KnightCommented:
Yes, otherwise you will have to give every other email server in the world a username and password to connect to your server :)
0
 
OhmitAuthor Commented:
do I need to restart any services after this?
0
 
OhmitAuthor Commented:
you're the man!

testing again .......
0
 
OhmitAuthor Commented:
From now on it will be SIR DEMAZTER
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.