catalyst 3750 multicast

I can´t get multicast working on our Catalyst 3750 (ip services).
Can anyone spot in the conf what´s wrong?
I primarily wish to multicast from the interface gigabitethernet1/0/1, to all others.
Directed broadcast works, but I think multicast might be quicker, right?

Regards
John
L3SKI#show running-config
Building configuration...

Current configuration : 6728 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname L3SKI
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
switch 1 provision ws-c3750g-12s
system mtu routing 1500
ip routing
!
!
ip vrf VrfConAirExt
 rd 10:2
!
ip vrf VrfConAirInt
 rd 10:1
!
ip multicast-routing distributed
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 no switchport
 ip address 192.168.0.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/3
 no switchport
 ip address 192.168.4.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/4
 no switchport
 ip address 192.168.8.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/5
 no switchport
 ip address 192.168.12.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/6
 no switchport
 ip address 192.168.16.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/7
 no switchport
 ip address 192.168.20.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/8
 no switchport
 ip address 192.168.24.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/9
 no switchport
 ip address 192.168.28.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/10
 no switchport
 ip address 192.168.32.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/11
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2,200,250,251,350-353
 switchport mode trunk
!
interface GigabitEthernet1/0/12
!
interface Vlan1
 ip address 172.21.0.1 255.255.255.0
 ip directed-broadcast
!
interface Vlan2
 description SkoleTMG
 ip address 172.21.1.1 255.255.255.0
!
interface Vlan3
 description SkoleCA
 ip address 172.21.2.1 255.255.255.0
!
interface Vlan200
 description CAIntK01
 ip vrf forwarding VrfConAirInt
 ip address 10.128.192.1 255.255.192.0
 ip helper-address 172.21.2.11
 ip helper-address 172.21.2.12
!
interface Vlan250
 description CAIntTMG
 ip vrf forwarding VrfConAirInt
 ip address 172.20.0.200 255.255.255.0
!
interface Vlan251
 description CAIntHot
 ip vrf forwarding VrfConAirInt
 ip address 172.20.1.200 255.255.255.0
!
interface Vlan350
 description CAExtTMG
 ip vrf forwarding VrfConAirExt
 ip address 172.19.0.1 255.255.255.0
!
interface Vlan351
 description CAExtHot
 ip vrf forwarding VrfConAirExt
 ip address 172.19.1.1 255.255.255.0
!
interface Vlan352
 description CAExtASA
 ip vrf forwarding VrfConAirExt
 ip address 172.19.2.200 255.255.255.0
!
interface Vlan353
 description CAExtSrv
 ip vrf forwarding VrfConAirExt
 ip address 172.19.3.1 255.255.255.0
!
ip default-gateway 172.21.0.1
ip classless
no ip forward-protocol udp tftp
no ip forward-protocol udp time
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
no ip forward-protocol udp tacacs
ip route 0.0.0.0 0.0.0.0 172.21.0.2
ip route 10.128.0.0 255.192.0.0 172.21.1.10
ip route 10.192.0.0 255.255.252.0 172.21.1.11
ip route 10.192.4.0 255.255.252.0 172.21.1.12
ip route 172.19.1.0 255.255.255.0 172.21.1.10
ip route 172.20.0.0 255.255.0.0 172.21.1.10
ip route vrf VrfConAirInt 0.0.0.0 0.0.0.0 172.20.1.1
ip route vrf VrfConAirInt 172.21.0.0 255.255.0.0 172.20.0.1
ip route vrf VrfConAirExt 0.0.0.0 0.0.0.0 172.19.2.1
ip route vrf VrfConAirExt 10.128.0.0 255.192.0.0 172.19.1.20
ip route vrf VrfConAirExt 172.21.2.0 255.255.255.0 172.19.0.10
ip http server
ip http secure-server
!
ip pim rp-address 172.21.0.1
ip pim autorp listener
ip pim accept-rp 172.21.0.1 1
!
ip sla enable reaction-alerts
access-list 1 permit 224.77.145.61
access-list 1 permit 239.255.255.254
access-list 1 permit 239.255.255.253
access-list 1 permit 239.255.255.250
access-list 1 permit 239.192.152.143
access-list 1 permit 229.55.150.208
access-list 1 permit 224.0.1.60
access-list 1 permit 224.0.1.24
access-list 1 permit any
arp 172.21.1.10 0100.5e7f.010a ARPA
arp vrf VrfConAirExt 172.19.0.10 0100.5e7f.000a ARPA
arp vrf VrfConAirInt 172.20.0.1 0100.5e7f.0001 ARPA
!
!
!
line con 0
line vty 0 4
 password 7 104F130A1D13110D1A
 login
 length 0
line vty 5 15
 password 7 12181F040A0F0F023C
 login
!
end

L3SKI#show running-config
Building configuration...

Current configuration : 6728 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname L3SKI
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$PB5d$I8m/3J8uFnXLFSqc2gYGw0
enable password 7 110803160F16080A12
!
!
!
no aaa new-model
switch 1 provision ws-c3750g-12s
system mtu routing 1500
ip routing
!
!
ip vrf VrfConAirExt
 rd 10:2
!
ip vrf VrfConAirInt
 rd 10:1
!
ip multicast-routing distributed
!
!
crypto pki trustpoint TP-self-signed-1986956288
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1986956288
 revocation-check none
 rsakeypair TP-self-signed-1986956288
!
!
crypto pki certificate chain TP-self-signed-1986956288
 certificate self-signed 01
  3082023E 308201A7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31393836 39353632 3838301E 170D3933 30333031 30303031
  34335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 39383639
  35363238 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100E5BD 83796A1E 43ABB073 B92EAAD3 D2C4079C 508BF2AE 9DEB90AE 47B4467C
  18CEF424 2EE5A457 927B14D0 95AF200F 1099ED01 7B79BD5A CC62949B FD2DF780
  899AF9DC 07D6C8BC 99C8F95F AB0C9F20 33C6191B ECDD779C 031C98A7 BEEB7762
  8F5211EB AA3B9C73 A3A2F341 7CB28A9E 17CFFA66 6F8069E5 4C955679 DEC23EBA
  9A170203 010001A3 66306430 0F060355 1D130101 FF040530 030101FF 30110603
  551D1104 0A300882 064C3353 4B492E30 1F060355 1D230418 30168014 58BEB502
  68797511 62B747F5 85026A8E 0F6BC8C4 301D0603 551D0E04 16041458 BEB50268
  79751162 B747F585 026A8E0F 6BC8C430 0D06092A 864886F7 0D010104 05000381
  8100A722 EB3B5589 E685105C 776D72C0 4B22E40A 3BACF88A AC6E8BA0 F1DC209C
  70133965 1BC84920 A31CC608 1065BA28 01CF3528 8AC1600C 8EB2BBB0 557C0BF1
  A5417667 ABFAA2EF D9FA5972 F91BB431 14769D30 1718B7D9 A237472A 5FE630F5
  F37E8AF9 EC4DE0A1 0B701E40 67585DB3 5CA6775F 37F80410 38E40BC8 7DD0B587 FC86
  quit
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 no switchport
 ip address 192.168.0.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/3
 no switchport
 ip address 192.168.4.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/4
 no switchport
 ip address 192.168.8.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/5
 no switchport
 ip address 192.168.12.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/6
 no switchport
 ip address 192.168.16.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/7
 no switchport
 ip address 192.168.20.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/8
 no switchport
 ip address 192.168.24.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/9
 no switchport
 ip address 192.168.28.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/10
 no switchport
 ip address 192.168.32.1 255.255.252.0
 ip helper-address 172.21.0.11
 ip directed-broadcast
 ip pim version 1
 ip pim sparse-dense-mode
!
interface GigabitEthernet1/0/11
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2,200,250,251,350-353
 switchport mode trunk
!
interface GigabitEthernet1/0/12
!
interface Vlan1
 ip address 172.21.0.1 255.255.255.0
 ip directed-broadcast
!
interface Vlan2
 description SkoleTMG
 ip address 172.21.1.1 255.255.255.0
!
interface Vlan3
 description SkoleCA
 ip address 172.21.2.1 255.255.255.0
!
interface Vlan200
 description CAIntK01
 ip vrf forwarding VrfConAirInt
 ip address 10.128.192.1 255.255.192.0
 ip helper-address 172.21.2.11
 ip helper-address 172.21.2.12
!
interface Vlan250
 description CAIntTMG
 ip vrf forwarding VrfConAirInt
 ip address 172.20.0.200 255.255.255.0
!
interface Vlan251
 description CAIntHot
 ip vrf forwarding VrfConAirInt
 ip address 172.20.1.200 255.255.255.0
!
interface Vlan350
 description CAExtTMG
 ip vrf forwarding VrfConAirExt
 ip address 172.19.0.1 255.255.255.0
!
interface Vlan351
 description CAExtHot
 ip vrf forwarding VrfConAirExt
 ip address 172.19.1.1 255.255.255.0
!
interface Vlan352
 description CAExtASA
 ip vrf forwarding VrfConAirExt
 ip address 172.19.2.200 255.255.255.0
!
interface Vlan353
 description CAExtSrv
 ip vrf forwarding VrfConAirExt
 ip address 172.19.3.1 255.255.255.0
!
ip default-gateway 172.21.0.1
ip classless
no ip forward-protocol udp tftp
no ip forward-protocol udp time
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
no ip forward-protocol udp tacacs
ip route 0.0.0.0 0.0.0.0 172.21.0.2
ip route 10.128.0.0 255.192.0.0 172.21.1.10
ip route 10.192.0.0 255.255.252.0 172.21.1.11
ip route 10.192.4.0 255.255.252.0 172.21.1.12
ip route 172.19.1.0 255.255.255.0 172.21.1.10
ip route 172.20.0.0 255.255.0.0 172.21.1.10
ip route vrf VrfConAirInt 0.0.0.0 0.0.0.0 172.20.1.1
ip route vrf VrfConAirInt 172.21.0.0 255.255.0.0 172.20.0.1
ip route vrf VrfConAirExt 0.0.0.0 0.0.0.0 172.19.2.1
ip route vrf VrfConAirExt 10.128.0.0 255.192.0.0 172.19.1.20
ip route vrf VrfConAirExt 172.21.2.0 255.255.255.0 172.19.0.10
ip http server
ip http secure-server
!
ip pim rp-address 172.21.0.1
ip pim autorp listener
ip pim accept-rp 172.21.0.1 1
!
ip sla enable reaction-alerts
access-list 1 permit 224.77.145.61
access-list 1 permit 239.255.255.254
access-list 1 permit 239.255.255.253
access-list 1 permit 239.255.255.250
access-list 1 permit 239.192.152.143
access-list 1 permit 229.55.150.208
access-list 1 permit 224.0.1.60
access-list 1 permit 224.0.1.24
access-list 1 permit any
arp 172.21.1.10 0100.5e7f.010a ARPA
arp vrf VrfConAirExt 172.19.0.10 0100.5e7f.000a ARPA
arp vrf VrfConAirInt 172.20.0.1 0100.5e7f.0001 ARPA
!

Open in new window

LVL 1
DucknaldiAsked:
Who is Participating?
 
Marius GunnerudConnect With a Mentor Senior Systems EngineerCommented:
VLAN 1 is the RP but ip pim sparse-dense-mode is not configured for the vlan. Also ip pim send-rp-announce <interface> scope 16 and ip pim send-rp-discovery scope 16 are not configured.

0
 
shubhanshu_jaiswalCommented:
How many streams are there which you want to multicast...?
0
 
DucknaldiAuthor Commented:
MAG03 you were spot on;)

Thanx...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.