help set up second router as a switch

Hi, I'm hoping to talk through a little router setup.

I have an existing modem that connects to a wireless router (dlink dir-825) and one of the wired ports connects to a port on a second wireless router (lynksys wrt-310n). Finally, there are three computers connected to the other 3 ports on the downstream lynksys router.

I'm hoping to get some help to make the second router a repeater for the wireless network that exists on the upstream dlink router. Is that possible?

I find if I connect a laptop to the lynksys router and disconnect the router from any other connection, then I can access the administrative page. But, as soon as I connect the downstream router to the upstream router, then I can't access the admin page of the downstream router. So, it's impossible (or at least hard for me) to look at some settings to see if I can make it become a repeater. I'm imagining I can just make it an extension of the wireless network on the dlink, but if this isn't possible, I guess I should turn off the second wireless network on the lynksys (downstream) router, and is that possible?

Generally, just hoping to discuss ways I can configure this second downstream router to fit in to the existing wired and wireless network. I've been experimenting, and it mostly works. I just have to work on dealing with the unconfigured open wireless network on the second router that needs to be turned off, or made to support or repeat the existing wireless network.
JeReLoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

naomelixesCommented:
If you disable the DHCP server on the second router, you can then use the router's switch ports as a switch. You should write down the IP set up on the LAN interface of the router, just so you can access it later withou resetting it.
0
wolfje_xpCommented:
Hi,

- Do not use the wan port on second router;
- Only use dhcp server on one router (ore don't use it at all);
- Give routers static ip addresses not in dhcp scope;
- repeater: can you connect both routers to each other using a cable? If yes, do this, and configure wireless the same way on both routers (same ssid, encryption, password, ...) but use other channel (eg 1 and 16);
  If not, search for a repeater setting in the interface. I'm not sure if linksys can do this, you can always try alternative firmware for it (openwrt or something)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JeReLoAuthor Commented:
Ok, good to know something's possible. More context:
First router is in Small Business Server 2011 network, so no dhcp on first router, as server manages that.

So, setting up second router, I will turn off dhcp.
Not sure if I should change first router's ip (which is 192.168.0.1), but second router is 192.168.1.1 and I'm not sure what you would recommend I set it to (or if it's really necessary).

Re Repeater, yes both are connected using cable, lan ports on both sides. Will try setting wireless network setting identical with different channels.
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

wolfje_xpCommented:
Your ip addresses should all be in the same network: if your first router is 192.168.0.1, you should take an ip in the same range for the second router, let's say 192.168.0.2. Assuming you have the standard 24bit subnet (255.255.255.0).
Be shure to place both routers far enough away from each other ...
0
JeReLoAuthor Commented:
Ok, second router has dhcp turned off. But I left the ip of second router at 192.168.1.1 and first at 192.168.0.1
On second router I set matching ssid, but left the setting for the chanel to auto (thinking it will set itself to an unused chanel).

Now, after reconnecting both routers, I can connect to the internet from a lan port of the second router. On the wireless network I don't see anything but the ssid I set.

However, I cannot log on to the administration page of the second router, by browsing to 192.168.1.1

Is this something I could correct by setting the ip of the second router. I don't understand the ip address impact of having that ip while on the sbs2011 managed network. Maybe that address gets blocked. If so, what address should I set it to, since usually the sbs server will set the address according to its own dhcp.
0
wolfje_xpCommented:
You should give the second router a matching ip ...
When you use router1 as a gateway (or your sbs, or any device in 192.168.0.1/24), and you instruct your browser to go to 192.168.1.1, the pc goes to the gateway, and the gateway 'checks' the request, and sees an address <i>outside</i> the network, so it will route the request to the WAN port.
Again: you should give router2 a compatible ip address.
Check the ip pool of the dhcp server on your sbs. Pick an address that is outside that range, and is not occupied by another device.
On the wireless you should see only one ssid. You connect let's say to router1, and you start moving. At a certain point you will be out of range for router1, but within range of router2. As it has the same ssid etc, you will automaticly connect to router2.
0
JeReLoAuthor Commented:
I'm sorry to say, but I'm not sure what to do in order to "Check the ip pool of the dhcp server on your sbs."

Do you have a guess as to what control panel or manager might be involved?
0
wolfje_xpCommented:
I don't have access to a sbs ... But on a regular server you can see it in computer management (local).
If you have a pool 192.168.0.10-100, you could use ip 192.168.0.1 to 192.168.0.9, and 192.168.0.101 to 192.168.0.254 for static assingments ...
A pool is just a range of ip addresses, your sbs chooses one to give to a client.
0
naomelixesCommented:
You can go to Programs -> Administrative Tools -> DHCP.
Expand the scope (probably just one in there). If you right-click the scope, you can see its properties. In "Address pool" you can set different IPs/ranges to exclude from distribution. Typically, you will have somethin like 192.168.1.1 through 192.168.1.254 with addresses 192.168.1.1 through 192.168.1.9 excluded. Customize it to what you desire.
0
JeReLoAuthor Commented:
Thanks all, I have this working fine now. I saw that the scope excluded 192.168.0.1 to 192.168.0.10, so I set the second router to 192,168.0.3 and this is working fine. I can access both routers by ip, and they both share the same wireless network name, protocol and wireless password.

Problem is solved!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.