windows server 2008 R2 VSS System writer failled

Backup Exec 2010 R2 is installed on this windows server 2008 Ent R2. i am trying to backup the syste state of this server but the backup fails with VSS problems.

I have checked the vssadmin list writers and it always shows
Writer name: 'System Writer'
   Writer Id: {e8132975-6f93-4464-a53e-1050253ae220}
   Writer Instance Id: {0c4a14f0-1349-4e2b-b351-5d7320497a9f}
   State: [7] Failed
   Last error: Timed out

when i reboot the server the vssadmin list writers shows everything is fine and no error but when i run the backup job then it fails and vssadmin list writers shows error

I also noticed an error on event viewr - application

event ID 12293
source VSS

Volume Shadow Copy Service error: Error calling a routine on a Shadow Copy Provider {b5946137-7b9f-4925-af80-51abd60b20d5}. Routine details EndPrepareSnapshots({8cdde2cb-e25d-4a18-8025-eb05d0815812}) [hr = 0x80070015, The device is not ready.
].

I tried to reregister the VSS but that did not help. Also checked the Experts Exchange site but that did not help either

Please let me know if you can help?

Thanks
ahannahAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

noxchoGlobal Support CoordinatorCommented:
Did you check if both system partition and snapshot target partitions are healthy and available?
Check if MSR partition can be mounted. Here in HKLM\SYSTEM\CurrentControlSet\Services\mountmgr check if the value is set to 0. If not set it.
0
ahannahAuthor Commented:
I am backing up Sys state that is the OS partition so it is healthy.

could you please let me know what particular Key i am looking for in registery?

Thanks
0
noxchoGlobal Support CoordinatorCommented:
HKLM\SYSTEM\CurrentControlSet\Services\mountmgr
in the right pane find NoAutoMount. Is it set to 0?
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

ahannahAuthor Commented:
No, it is set to 1

Now before I go ahead and change that i need to know the consequence of doing so. As i already have some partitions that are set to offline and they should not be automounted. these partitons are SAN volumes used for veeam backup.

I guess my question here is that if we change that key to 0 will that meean it will automount all partitions.
 
0
noxchoGlobal Support CoordinatorCommented:
Yes. And system state backup needs to mount MSR partition (which is 100MB or 128MB usually) to take backup. I have noticed when automount is disabled the backup fails along with SP1 installation as well.
Just to check this suggestion try to change it once to 0 and run backup. After that you can change it back to 1.
0
ahannahAuthor Commented:
that worked,

The problem now if i restart the server then it will go back to the original error as the reg key is set back to 1
0
noxchoGlobal Support CoordinatorCommented:
So you know where is the problem.
Now we need to find the solution. Can you try one thing, in Windows Disk Management please right click on MSR partition (100MB) and select Add drive letter and paths. Assign it a drive letter and then remove it.
Try to run backup again. Does it work?
0
ahannahAuthor Commented:
it works if i dont restart the server. Once the seerver restarted then it faills.

remember the NoAutoMount key was reset to 1 from yesterday

0
noxchoGlobal Support CoordinatorCommented:
Clean install of Windows 2008 always has this NoAutoMount set to 0. So I think setting it to 1 is not typical for Windows (I would consider it to be a bug).
You have two choices here IMHO:
1)remove MSR partition by moving boot files from MSR to C: partition setting C: active and deleting MSR. Then AutoMount value will not affect your system state backup.
2)Every time you want to take system state backup change the noautomount value back to 0.
0
ahannahAuthor Commented:
it seems every time I change the automount value, i need to restart the server to take effect. so to do option 2 i need to restart the server before and after changing the value.

so let me know if this process might cause any problems.

1. the current atuomount value is 0. Therefore we can do system state backup
2.if i change the value to 1 and dont restart the server. This will make sure that system state backup is working But not sure if every time the backup runs then it will mount all other partitions.

as long as Veeam concerned is that the automount value is disabled and in my step 2 above, it is exactly that but without restarting the server.

Do you think that is a safe option?

i have already done that and everything seems fine.
0
noxchoGlobal Support CoordinatorCommented:
Looks and sounds safe. But only practice will show how safe it is.
0
ahannahAuthor Commented:
After contacting veeam about this problem. they were adamant that automaunt key must be disabled otherwise it may re-signature the VMFS volums. This is just a normal behaviour of windows when it sees new volumes it try to re-signature it.

Thanks anyway for help
0
noxchoGlobal Support CoordinatorCommented:
Then do the step I suggested. Move boot files to system partition and delete MSR volume. Or try to keep it mounted by default.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ahannahAuthor Commented:
I have mounted/assigned a letter to the MSR partition and successfully backed up the System State.

does this has any side effect on anything else?
is it safe to assign a letter and mount the MSR partition?
0
noxchoGlobal Support CoordinatorCommented:
I performed several tests today on my test Windows 2008 R2 installation. Mounted MSR partition, several reboots, backups. Nothing noticed. Works ok.
So it is ok to mount this partition. It has only Boot Loader in it no other important data.
0
ahannahAuthor Commented:
I have ran a live backup over the weekend and everything seems fine.

Thanks for the noxcho
0
advserverCommented:
When backingup a VMware environment using VCB style backups such as VRanger, Backup Exec, Veeam, etc automount needs to be disabled within Windows on the backup server if you are using SAN mode for the backups.  Otherwise what may happen is Windows may attempt to mount the SAN volume which could corrupt it.  

Any time you have VMFS datastores presented to a Windows backup server, always have automount disabled on that Windows server.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.