sbs 2003 dhcp settings

hello

recently we have had broadband installed and the server cannot connect to the internet now.  i belive the problem is that the old routers ip address was 192.168.16.254 and the new routers ip address is 192.168.1.254.

BT have said that there is not a way to simply change the routers ip address so what i will need to know is what to change on the server.

the server had a fixed ip address 192.168.16.10 and was working as a dhcp giving out ip addresses

aany help greatly appreciated

i have tried just changing the default gateway on the server to the new ip address but that did not work
drzackzussAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AustinComputerLabsCommented:
I am pretty sure the router (gateway) has to be on the same segment as your LAN.
Your LAN is 192.168.16.x
The router is 192.168.1.x

The LAN ip of the router has to be changed. Who is BT?
Is the router yours or your ISP?
When you asked them to change the IP of the router, they may have thought you meant the WAN IP. I bet if you ask them to change the LAN IP of the router to 192.168.16.254 you will be all set.
0
waynej1979Commented:
You need to use the sbs admin console to change the ip address of the server. There is a section in there on changing the ip address.

You will need to change the ip of the server in here to 192.168.1.10 to make sure you can connec to the internet.

Using the wizard within the admin console should modify various services as well. You may need to check dhcp to ensure your scope options are set to the correct options, such as gateway 192.168.1.254 and dns servers match ip address of server and or new gateway address.
0
AustinComputerLabsCommented:
I would not recommend changing IP address of the server!!!!!!
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

AustinComputerLabsCommented:
What is the subnet mask of your network?
0
waynej1979Commented:
i have changed ip address of sbs servers plenty of times before. Not ideal but without acess to the router you may well have no other choice!!!
0
Vinchenzo-the-SecondCommented:
Two things you can do:
Option 1. Change the IP address on the server with the change IP Address Tool.  You will have to reconfigure your scopes again in DHCP.  This may also have knock on affect with other services though.

Option 2. Install an additional NIC, install RRAS - I'm not 100% it can act as a router, I will check in my lab when I get home
0
AustinComputerLabsCommented:
You are paying your ISP for a service that includes installing and configuring their devices to work with your existing setup.

They should not expect you to change your LAN to match their device.
0
waynej1979Commented:
Yes but unfortuantely that ISP happens to be BT!! Good luck with getting them to change it for you!!
0
Rob WilliamsCommented:
You have two choices;
change the router IP and run the CEICW (Configure internet and e-mail wizard" under server management | Internet and e-mail). This will associate the SBS with the new router and update gateway information.
change the server IP. To do so you MUST use the "change server IP wizard on the same page as above, and when complete you again have to run the CEICW. These steps  will update DHCP, DNS and  forwarders, Exchange, and much more.

With SBS the wizards must be used especially when changing the server IP. Not doing so can result in a server rebuild.

0
drzackzussAuthor Commented:
hello

thanks for all the help so far

i have changed the router ip address and that seems to have solved many of the problems

i have ran the email and internet connection wizard

the server now connects to the internet and the computers connected to the server can access network folders and the internet

however exchange emails are not working

i am guessing that due to the broadband change that emails are not forwarded to the new public ip address

how can i find out what the routers wan ip address is?

i am guessing that i will need to contact my domain host to forward emails to this new ip address. does this sound correct??
0
waynej1979Commented:
www.whatismyip.com from computer behind router. If they have changed your ip address you will need your isp to forward to this address. Your mx record may need to be updated to point to your new IP.
0
Rob WilliamsCommented:
>>"how can i find out what the routers wan ip address is?"
http://www.whatismyip.com
or you can check the router's status page.

>"i am guessing that i will need to contact my domain host to forward emails to this new ip address. does this sound correct?? "
Yes you need to update the public DNS Host record that points to your site. when the change is made it can take up to 48 hours to propagate all Internet based DNS servers though it usually is about 8 hours.

Also the router must forward the appropriate ports to the SBS
25 for SMTP (e-mail)
443 for OWA, RWW
444 for Sharepoint
1723 PPTP VPN
4125 for RWW
0
waynej1979Commented:
I would also confirm with BT that they have provisioned you a new static ip address, i have known them to "forget" to re-apply a static ip in the past.
0
drzackzussAuthor Commented:

ok i have gone onto the domain host and changed the A record for the mail domain to point to the new public ip address and they have said it will take 2 -24 hours to propogate.

will this change have to take place in order for outgoing emails to work as they do not seem to be working at the moment?

the forwarding of those ports, do they just need to forward to the servers ip address?
0
Rob WilliamsCommented:
>>"will this change have to take place in order for outgoing emails to work "
No, outgoing will work fine.
Having said that you should update your reveres DNS record with your ISP (not DNS host) as well. Some mail servers will bounce e-mail if you do not have a proper reverse DNS record. If you are using a smarthost (sending e-mail via ISP's SMTP server as recommended by SBS, you do not need a reverse DNS record.

>>"the forwarding of those ports, do they just need to forward to the servers ip address? "
Yes, again this will not affect outgoing e-mail
0
Rob WilliamsCommented:
0
AustinComputerLabsCommented:
the MX record at the host will only help incomming mail.

Yes, The ports will need to be forwarded to the servers LAN IP address.
0
drzackzussAuthor Commented:
hello

thank you so much it seems all is sorted for incoming emails and will just have to wait for the change at host to propogate.

however outgoing emails are definitely not working.

what settings should i be checking to see what is wrong with outgoing emails?
0
Rob WilliamsCommented:
>>"what settings should i be checking "
I would run the BPA, it is very good at determining configuration issues. You can then report your findings.

Can you send mail internally?
0
waynej1979Commented:
Do you get a bounce back message or are emails "disappearing" can you check your out bound mail queue on your exchange server and see the emails queueing up.
0
drzackzussAuthor Commented:
sorry to be a pain but i do not have a great deal of experience with exchange.

how can i check the outbound mail queue on the exchange server

i am running sbs 2003

thank you
0
drzackzussAuthor Commented:
hello

gone into the exchange system manager and on the "small business SMTP connector" there are 51 messages in the queue.

it seems as if it may be sending to old isp "post.mail.demon.net"

demon was our old ISP.  do i need to point this to my new ISP?
0
waynej1979Commented:
Yes you will need to point to BT or for now send via DNS temporarily, you may be required to speak to bt to allow your email domain to be sent via them if they do not currently host it. I have had to do this before with them, but try to send via them first without speaking to them
0
Rob WilliamsCommented:
You change this by running the CEICW. There is a page where you select sending by DNS or your ISP (a smarthost) if the latter enter the updated SMTP server name.
0
drzackzussAuthor Commented:
hello

thank you again soooo much

al is working except for incoming mail

i have change the A record with our host to point to our new ip address but mail is not coming through yet.

i also cannot remotely connect to the server when entering the new ip address into rdp from a remote machine (this worked before)

is this likely to be that i  have bot forwarded ports on the router for these services or is there something in sbs that needs to be changed?



thank you
0
Rob WilliamsCommented:
>>"is this likely to be that i  have bot forwarded ports "
                                                      ^not?
No incoming service will work until you forward the ports.
You also need to re-run the CEICW.
0
waynej1979Commented:
Agreed you will need to open  3389 for rdp to the server and smtp 25 to the server. Also any other services you may run on the server will need their ports opened on the new firewallm device
0
Rob WilliamsCommented:
To add, you are much safer to use Remote Web Workplace and ports 443 and 4125 than to open 3389.
0
drzackzussAuthor Commented:


so on the router exactly what ports do i need to forward to the routers local ip address?

and are there any changes that need to be made on the server itself.  do i need to run the email and internet connection wizard again after the ports have been forwarded?
0
drzackzussAuthor Commented:
sorry meant

so on the router exactly what ports do i need to forward to the servers local ip address?
0
Rob WilliamsCommented:
>>"i need to run the email and internet connection wizard again after the ports have been forwarded? "
No but you do after swapping the router. If you have already done so you are fine.

port 25 SMTP
port 443  RWW & OWA
port 444 Sharepoint (if used)
port 1723  PPTP VPN (if used)
port 3389  RDP (not recommended)
port 4125 RWW
0
Happy_ComputingCommented:
Hi,

Just read the post.  Had the same problems with BT in the past as their tech support don't know how to use their own routers.

To get incoming email working you need to setup an MX record to point to a hostname that points to your static up address.

I would also setup each e-mail account with your website hosting company and set their server as a backup MX.  Then configure the SBS POP3 connector to pick up e-mail every 15 minutes.  This was if your server or internet connection goes down your server will pickup e-mail when it is back on-line.

You should also contact BT and get them to setup your RDNS to point to the hostname to help stop outgoing messages from being marked as spam.

Do not forward port you will be hacked.  Instead configure a random port to redirect to 3389.

If you need more specific instructions let me know.

Minesh
0
Rob WilliamsCommented:
Sorry but I would tend to agree on all accounts with the last post. Sorry to be difficult.
-The MX record already exists and points to a host record. The host record needs to be updated.
-Using and ISP and the POP connector will work, but for $25/ year you can subscribe to a backup MX service that doesn't tax the server. Or for $2/mailbox/year you can have backup MX, spam filtering, and mail archiving.
-Do not change the RDP port on an SBS it will break RWW which is a much more secure service to start with.

This is SBS not Server std.
0
Happy_ComputingCommented:
Sorry just noticed a typo,

I mean to say:


Do not forward port 3389 you will eventually be hacked.  Instead configure a random port to redirect to 3389.

Thanks for agreeing with me RobWill, just though I would add a bit more to clarify.

Most routers and I'm sure the BT router, will allow you to redirect port 39402 (for example) to 3389 so when you connect with remote desktop you type in hostname.example.com:39402 and the router automatically redirects to 3389.

This way if someone tries to connect to 3389 they will be rejected, but you can connect.  There is no need to change the port in the registry on the server as it will break RWW.

Also only forward the ports that you need.

So if you only want to use outlook web access but not sharepoint or RWW, then you don't need to forward port 444.

Server Standard 2003 does not have the SBS POP3 connector so cannot be used to pickup e-mails via POP3 without an additional bit of software.

I have never used a specific backup MX service as checking for e-mail every 15 minutes doesn't really tax the server.

I host all of my customers web sites for £50 a year and I include unlimited POP3 or IMAP e-mail accounts with this, so I just configure my server as the backup MX and configure their POP3 connector to pick up e-mails every 15 minutes.  This way it does not cost them any extra for the backup.  I would check with whoever is hosting your website before you pay for anything extra.

If they don't offer this, then either change hosting or subscribe to a dedicated backup mx service.

Unfortunately BT's cabling is not that reliable and it will be a godsend if some idiot drives their car into a BT cabinet and takes down phones and internet for the whole area.  (Just happened to one of my customers.)  They are now running almost normally through a backup 3G modem, without me needing to visit the site, because everything is already setup.  I don't think this would have worked with a dedicated backup mx as these just try to connect to the existing primary mx, which in my customers case is still off-line.

To setup the RDNS, you need to e-mail Reverse.dns@btbroadbandoffice.com from an address on your registered domain requesting that they change the RDNS on your IP address to your hostname.

Once you have done this I would also setup an SPF record with all the servers allowed to send e-mail from your domains.  Again this helps stop your outgoing e-mail being marked as spam

Let me know if you have any question on setting any of my suggestions up.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
drzackzussAuthor Commented:
hello

i am really so grateful for all the help

i have forwarded the smtp port on the router to the server and emails started coming in almost instantaneously (actual router has preset for SMTP and other choices)

i will need to make sure that owa and rww are working next. i have forwarded the RWW port to the server but there is not a default setting for OWA

what would i need to enter for these options

protocol: tcp or udp
port range: from - to
protocal timeout:
map to host port:
apllication type: choices of (ftp, h.323,direct x game, irc,pptp,sip)

also how can i find out what my RWW address is set to?


0
waynej1979Commented:
protocol for owa should be https, there should be pre-defined rule for this but it will be tcp 443 if not
0
drzackzussAuthor Commented:
sorry i havent set up OWA before but it was already set up before the broadband changes were made.

i understand that i will need to forward a port to have it working but am unsure what settings exactly need to be filled in from the options

protocol: tcp or udp
port range: from - to
protocal timeout:
map to host port:
apllication type: choices of (ftp, h.323,direct x game, irc,pptp,sip)

also rww was set up and i have forwarded the port for rww but unsure what to enter ti remotely access this page.

one last thing is that emails aren't coming through to phones so unsure at the moment why that is

any help with any of these questions would be greatly appreciated


0
waynej1979Commented:
have you run the internet connection wizard through the server admin console? This should take care of reconfiguring the settings required on the server
0
Rob WilliamsCommented:
protocol: tcp or udp  = TCP
port range: from - to  = 443 - 443
protocal timeout: =  N/A
map to host port:  =  443
apllication type: choices of (ftp, h.323,direct x game, irc,pptp,sip)  = HTTPS

>>"also rww was set up and i have forwarded the port for rww but unsure what to enter ti remotely access this page."
The same as it was before but it will not work if the host record with whoever manages your public domain's DNS has not changed the IP to which it points. It was probably  SBSname.YourDomainName.com  but can be anything.

>>"one last thing is that emails aren't coming through to phones so unsure at the moment why that is"
The phones require that the host name mentioned above be updated, some require OWA to be working, and you may have to create and install a new certificate.
0
drzackzussAuthor Commented:
hello

on the host site i changed the A record so that mail.companyname.co.uk now points to the new public ip of the router

the cname record is unchanged server.companyname.co.uk points to mail.companyname.co,uk

the mx record is unchanged and is set to mail.companyname.co.uk with priority set to 10



should i have changed more than just the A record?
0
Rob WilliamsCommented:
>>"should i have changed more than just the A record? "
If that is all the DNS entries you have that is fine and correct.
You would access the server with:
https://mail.companyname.co.uk/remote
and/or
https://mail.companyname.co.uk/exchange
0
drzackzussAuthor Commented:
good news

all seems to be working

i changed the a record with host

forwarded the suggeste ports on router to the server

turned off dhcp server on the router as the server is doing this

and all emails, internet, owa and rww are working :)


there is a slight problem with 2 computers being unable to connect to the router but BT (myISP) believe this is a problem with the router itself and are sending a new one.

thaank you soo much i will read through all the comments again this evening in order to award points fairly
0
AustinComputerLabsCommented:
Glad to hear all is well.
0
waynej1979Commented:
If BT are sending a new router be aware that you will have to recreate all your rules again.
0
Rob WilliamsCommented:
Good to hear.
Also with SBS every time you change a router you may need to re-run the CEICW even if the settings do not change.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.