Can't save documents with deny delete permissions on shared drive

We have a shared directory on a Windows Server 2003. For user accounts, I have given them full access for the share permissions, and with the NTFS permissions I have allowed everything while denying "delete" and "delete files and subfolders."

Since this is for a school's computer lab, we need to meet certain requirements.

1. All students use 1 account to log in.
2. Students need to be allowed to create, modify, and save their work.
3. Students cannot be allowed to delete any files.

The problem exists with PowerPoint that prevents someone from being able to save their work if they are prohibited from deleting files, because Office deletes the temp files that are created when working on the file.  With Word and Excel this is not a big deal, as it just leaves some temp files in there that need to be cleaned out.  But with PowerPoint it won't let the user save without generating error messages that the file already exists, is read-only, etc.  The only way around this according to Microsoft and other posts I have read is to allow the users to have the delete permissions.

This is a REALLY foolish shortcoming on Microsoft's part.  Anyone have any thoughts on how to work around this?
Ad-ApexAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ewkellyCommented:
You could set your temp and tmp folders to something local, or to a network share where they can delete.
0
Ad-ApexAuthor Commented:
Can you please tell me where to do this?
0
ewkellyCommented:
Windows control panel, system settings, advanced, environment.
0
Ad-ApexAuthor Commented:
That doesn't work. The files exist on a shared drive.  When they open them it automatically creates the working copy in that location and not in a local temp drive.

I looked into this further, and it seems there is no way around it except to give every user their own login and set right so that only they can delete their own files.  There is no other way around it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ad-ApexAuthor Commented:
I accepted my own answer because there is no solution to this problem according to Microsoft. I have to change the actual procedure that I am using.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.