Can't connect SQL Management Studio to SQL Express 2008 R2 from local machine

I need a SQL testbed.  I'd like to have it work on my laptop.

I'm running a newish Dell with a 64 bit i7 processor with 8 GB of RAM and Windows 7 Pro.

I've been working on this for some time and have installed several versions of the MSSQL server software and its associated applications and tools.  Yesterday I downloaded fresh installers from the Microsoft Download site for both the MSSQL Express 2008 R2 Database Engine and the MSSQL Express 2008 R2 SQL Server Management Studio.  Both products installed with no errors or anything out of the ordinary.  I used the default settings for both installs, Windows Authentication, Etc…  

After the install and a reboot I went into the SQL Server Configuration Manager and set Enabled TCP/IP and Named Pipes protocols.  I confirmed that both the SQL Server service for my instance was running as was the SQL Server Browser service.  The SQL Server Agent service is stopped.

When I try to connect to my local server instance using SQL Management Studio I get a SQL Error 53 and an error message about remote connections not being configured.  See error attached.
I’ve been developing in SQL since before SQL 2000 and have installed more recent SQL versions on servers or other test environments many times recently so I’m not a novice SQL user/installer.  I’m running out of ideas on how to get this connected.
 SQL Error
TicoTimeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

EvilPostItCommented:
If its SQL Server express default install i think it have installed a named instance of SQLEXPRESS so you would connect using local\SQLEXPRESS

Have a look in services it should show you what the instance name is in the service name.
0
Ephraim WangoyaCommented:

Use the name of your local instance

YOURPC\YOURINSTANCE
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
EdmoroCommented:
If you are not sure of what is the name of your instance you can browse it from the drop down menu in the Server Name field instead of write it yourself.
0
TicoTimeAuthor Commented:
I had tried it so many different ways, but I was always using local or just dot, but never my machine name.  That worked.  Thanks ewangoya!  Why doesn't local work?

0
EvilPostItCommented:
It will be dependant upon you tcp/ip settings under SQL Server Config Manager. Local never works on clusters for instance and they dont just work on all nic's it only works on the virtual address.

Look for the 127.0.0.1 address in the ip settings and enable it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.