• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 376
  • Last Modified:

Connection to Server over Gigabit Lan - Extreme variations in throughput, dropped connections

We are currently running Windows Server 2003 in our work environment, with workstations running both Windows 7 and Windows XP.  I have several users who lose their connection to the server intermittently for no apparent reason.  The connection drops and then reconnects, but because we have users connected to Quickbooks, and other databases on the server, the disconnect often causes their systems to lock up.  I have certified the network connections and patch cords, and all certify for gigabit, so I don't believe I have a cabling issue.  

Yesterday, I used LanTraffic V2 to test the bandwidth between several computers and the server. Sending traffic to the server, my tx throughput averaged 20k, despite the computer having a gigabit connection.  This morning I ran the same test on the same computer and the connection averaged 746Mb/s.    This has happened again and again, with the connection varying from 600-700Mb/s to 20-30 Kb/s.  The network utilization does not vary significantly, so I cannot figure out what would cause such a massive difference in bandwidth.  I appreciate any advice.  
0
ryangWT
Asked:
ryangWT
  • 5
  • 4
  • 2
  • +2
1 Solution
 
ttalbertCommented:
What brand and model of switch are you using?  
0
 
AndrewK80Commented:
Any chance there's some circular patching between switches. I've seen similar issues caused by having more than one uplink between switches.
0
 
AustinComputerLabsCommented:
Have you disabled auto tuning and unchecked IPv6 on the non-XP boxes?
0
WEBINAR: 10 Easy Ways to Lose a Password

Join us on June 27th at 8 am PDT to learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees. We'll cover the importance of multi-factor authentication and how these solutions can better protect your business!

 
ryangWTAuthor Commented:
The switch is a TRENDnet TEG-448WS.

I will double check on the patching between switches to make sure that is not causing a problem.  I'll post the findings here shortly.
0
 
AustinComputerLabsCommented:
From: http://www.speedguide.net/faq_in_q.php?qid=247

To disable TCP/IP autotunning, in "Elevated" Command Prompt type:

netsh interface tcp set global autotuning=disabled

To verify that it is dsabled:

netsh interface tcp show global

To set back to the default Windows Vista behavior:

netsh interface tcp set global autotuningl=normal
0
 
ryangWTAuthor Commented:
I checked and there is only one uplink connecting the switches.  The second switch is  TRENDnet TEG-240ws.  This switch only has 2 or 3 ports in use and then one uplinking to the main switch.  

As far as I know, IPv6 is not unchecked on the Win7 machines.  Could that cause this type of issue?  Does autotuning need to be disabled on both Vista and Windows 7 machines?
0
 
AustinComputerLabsCommented:
Many clients network speed is increased by disabling auto tuning and by unchecking ipv6.
0
 
AustinComputerLabsCommented:
Sorry:
That applys to Win 7 and Vista
0
 
bcdudleyCommented:
It will also help if you enable jumbo frames on the devices connected to the switch. You will be able to see significant increases in speed ad stability.
0
 
ryangWTAuthor Commented:
So just to confirm, does the ipv6 and auto tuning setting need to adjusted on all of the Win 7 and Vista machines on the network, or only the machines that seem to be having problems?  Also, it's worth noting that one of the machines with issues is an XP machine.  Could the Win 7 machines be causing this XP machine to have network disruptions?  
0
 
ryangWTAuthor Commented:
Also, I have enabled jumbo frames in the switch, as well as on one of the win 7 workstations. However, the server does not support Jumbo Frames as it's Server 2003.  Does that fact eliminate the advantage of enabling jumbo frames?  
0
 
bcdudleyCommented:
Windows 2003 does support jumbo frames. It us up to the nic driver as to weather it will work or not. You need to enable it on all the devices for it to make a difference.
0
 
AustinComputerLabsCommented:
If you disable auto tuning and uncheck IPv6 (not on the server) that will rule out those to potential causes.
You may find that after doing that the XP box has a completely different issue.
The auto tune and ipv6 steps do not apply to XP, but it is a good idea to apply to all Vista and Win 7 systems.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

  • 5
  • 4
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now