OAB not updating in cached mode

Problem looks simple , address book is not updating once client is in cached mode. removing the cache mode resolves the issue but I guess that's even a temporary workaround. I feel OAB stopped being updated once we stopped old exchange 2003 services.

This is a 2010 enviornment ( transitioned from 2003) . 2003 server is still in the enviornment but its services are turned down.
everything is migrated to 2010 server , including OAB , public folders and most of the system folders. there is one system folder in 2003 that couldn't be replicated to new enviornment ( gives access denied error ) and is called " system configuration"


I see lots of related threads but none of them solved my issue . here is what I've checked:

- Accessing the address book URL from a web browser gives me "Forbidden error" .
- in IIS , OAB is not using SSL , internal url is http://server.local/OAB
- Default offline address book is migrated to 2010 server and web based is selected , it's updating public folders as well.
- Mail store is configured to use default OAB

Any thoughts ?

LVL 10
akhalighiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MegaNuk3Commented:
0
MegaNuk3Commented:
What OUtlook clients are you using?
0
akhalighiAuthor Commented:
Outlook 2007 and 2010
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

akhalighiAuthor Commented:
Meganuke

Samething with http://caservername.internaldomain.local/OAB ; it gives 403 forbidden error .

I wil try your article later ... needs a dedicated time-frame..


0
MegaNuk3Commented:
A normal user will only have rights to the http://CAS/OAB/<gUID> folder and not above so that's probably why you are getting the 403 forbidden.

In the outlook autoconfig test you should see a full URL like http://CAS/OAB/<GUID>/OAB.XML which a standard user should be able to get to.
0
akhalighiAuthor Commented:
You are right , I tested the full URL and I can access that.

I turned on exchange 2003 services and after sometime redownloaded the address book and it worked.. OAB is already migrated to 2010 ... any thoughts ? what can possibly cause this ?

I have a free+busy error in 2010 end... could that be related ?
0
MegaNuk3Commented:
Do
Get-offlineaddressbook | fl
Have a look at the Server and ExchangeVersion values, also ensure WebDistribution=True

If you have multiple OABs then look for the one that shows as IsDefault=True
0
akhalighiAuthor Commented:
I Think you have a good point ; I ran that command and It looks to point to old exchange 2003 server , also WebDistribution is not set to true.

Strange , I moved it to 2010 three weeks ago ... in GUI it shows that is moved to 2010 and web distribution is marked but in powershell it still points to 2003 . should I restart any services ?|

|
0
MegaNuk3Commented:
You can either try move-offlineaddressbook or delete it and create a new one

Move-offlineaddressbook :
http://technet.microsoft.com/en-us/library/aa998191.aspx
0
MegaNuk3Commented:
Or try
Get-offlineaddressbook | ft identity, server, isdefault

And see if it is listing more than one and which one is default...
0
akhalighiAuthor Commented:


Sorry , it seems I made a mistake yesterday ... here is the results :

I only have ONE addressbook and generating server is 2010 server but public folder distribution still points to 2003 . Web Distribution is enabled but Global web distribution is not.



RunspaceId                       : 142a73da-b00a-4a40-8a95-2xxxxxxxxx
Server                           : 2010EXCHSERVER
AddressLists                     : {\Default Global Address List}
Versions                         : {Version4}
IsDefault                        : True
PublicFolderDatabase             : 2k3Server\First Storage Group\Public Folder Store (151-TOR-S)
PublicFolderDistributionEnabled  : True
GlobalWebDistributionEnabled     : False
WebDistributionEnabled           : True
LastTouchedTime                  : 4/8/2011 5:02:32 AM
LastNumberOfRecords              : 149
MaxBinaryPropertySize            : 32768
MaxMultivaluedBinaryPropertySize : 65536
MaxStringPropertySize            : 3400
MaxMultivaluedStringPropertySize : 65536
ConfiguredAttributes             : {OfficeLocation, ANR, ProxyAddresses, ANR, PhoneticGivenName, ANR, GivenName, ANR, P
                                   honeticSurname, ANR, Surname, ANR, Account, ANR, PhoneticDisplayName, ANR, DisplayNa
                                   me, ANR, ExternalMemberCount, Value, TotalMemberCount, Value, ModerationEnabled, Val
                                   ue, DelivContLength, Value, MailTipTranslations, Value, ObjectGuid, Value, IsOrganiz
                                   ational, Value...}
0
MegaNuk3Commented:
If all your mailboxes have been moved to Exchange 2010 then you can turn off PF distribution of the OAB
0
MegaNuk3Commented:
Did you not have any PF content to replicate to Exchange 2010?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
akhalighiAuthor Commented:
Yes , all PFs are replicated . I guess I can turn off public folder distribution.
0
MegaNuk3Commented:
Either turn off PF distribution or point it at your E2k10 server
0
akhalighiAuthor Commented:
alright some updates here .. I guess we're close ! thanks for all your helps :

I disabled public folder distribution , still it wasn't working . then I increased level of logging and noticed an event like this :

-------------
OABGen encountered error 80040115 while cleaning the offline address list public folders under /o=company/cn=addrlists/cn=oabs/cn=Default Offline Address List.  Please make sure the public folder database is mounted and replicas exist of the offline address list folders.  No offline address lists have been generated.  Please check the event log for more information.
- \Default Offline Address List
-------------

I noticed that some 2003 OAB  related systemfolders were not replicated to exchange 2010 , I added 2010 server as a replica then tried again . those errors went away but I got a warning this time :

----
OABGen could not generate full details for some entries in the offline address list for address list '\Global Address List'.  To see which entries are affected, set event logging for the offline address list generator to at least medium.
----

I forced another OAB update and I am only getting this warning , rest of the events are informational and all successful. howeve I still don't see the changes in address book..

I did a "Get-offlineaddressbook | fl" and I noticed that at the very end of the results , exchange 2003 is still the originating server. Is that normal ? this address book was moved from 2003 to 2010 , so right now 2010 is generating server but 2003 is originating server...



0
MegaNuk3Commented:
On the CAS server restart the Ms Exchange File Distribution service, wait 5 minutes and then try and download the OAB from Outlook.

OriginatingServer is the name of the GC/DC the info was pulled from. Is your e2k3 server a DC?
0
akhalighiAuthor Commented:
it takes some time for me to restart that service , so I will close this question for now. I think OAB issue is resolved.  
You are right ,Originating server name is my DC.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.