• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 887
  • Last Modified:

Connecting Virtual Server in VSphere to Physical CD Drive

Hi Everyone,

I am just getting started learning about V Sphere and VmWare so this is a bit of a stupid Question but here's what I'm trying to do.  I am in VSphere4 where I have three virtual servers; I click on the server that I want to connect the CD drive to and then I go to the icon to connect the physical CD drive to the virtual server.   I have the option of selection either the E Drive or the F Drive.  When I go to the actual  Virtual Server - it shows the CD Drive as a D Drive.  So,  I clicked on connect to F Drive since there was no D Drive. The virtual server in VSphere seems to think it is connected because if I go back I have the option to disconnect.  But the virtual server does not get connected to the physical CD Drive - nothing happens.  I didn't try connecting to the E Drive because that is  shared files data on the virtual server.

I would appreciate very much if someone could help me get the virtual server connected to the cd drive since I have a cd that needs to be installed on there.

Thanks for any and all help.
 
0
NewbieITGal
Asked:
NewbieITGal
  • 3
  • 2
2 Solutions
 
Ady FootSharePoint ConsultantCommented:
Please check all the other virtual machines - you can only assign the physical CD drive to a VM if it is not currently assigned to another VM (i.e. you must always disconnect it first).

Let me know how you get on.

Ady
0
 
coolsport00Commented:
For the particular VM you want to have connected to the CD drive of either your workstation or the ESX/ESXi host the VM is on, you rt-click on the VM -> Edit Settings -> then select CD\DVD in the 'Hardware' tab. On the right side of the Settings window, if you click 'Client Device', that means the VM will 'see' your workstation's CD drive. If you click 'Host', that obviously means the VM will 'see' the ESX/i host's drive. You can also have the VM 'see' files stored on the datastore (which is the 3rd option for 'ISO'). Once you choose which option you want, click the 2 check boxes at the top - 'Connect', and 'Connect at power on'. Click OK, then reboot your VM and it should 'see' the CD drive. I'm assuming you're using ESX/ESXi with vCenter and vSphere Client? Or, are you using another hypervisor (Workstation, Server, or Player)?

Regards,
~coolsport00
0
 
NewbieITGalAuthor Commented:
I disconnected the cd drive from one of the other Virtual Servers at the icon on the toolbar as Afoot recommended.

I followed the procedure that Coolsport00 recommended.  I checked the Connect and Connectat power on boxes and selected host device, rebooted and click on the cd icon on the toolbar and chose F Drive. It didn;t work then I disconnected it from the icon and tried choosing client device then rebooted, tried connecting again at the icon when it came back up but still not working.  Yes,  it is ESX/ESXI with the vcenter and vsphere client.  

Still not working.  I'm thinking this shouldn't be this much of a problem.  What am I doing wrong?

Any other suggestions?  Thanks
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
coolsport00Commented:
Ok...so, two things come to mind, are you sure you're clicking the CD\DVD toolbar icon or the floppy icon? If you have the console/window of your VM up, it's basically the last icon on the toolbar that looks like a CD/disc. Just wanna rule out things here. Mine only shows to Connect to D:\. Let's start by trying to connect to your local CD drive...the one that is on the workstation you're using to connect to vCenter with the vSphere Client. So, go back into the VM's Settings and select "Client Device". Click 'OK' out of the Settings. Then click the toolbar icon to 'Connect' to the CD\DVD drive, go into your VM's guest OS and see if you now have a D: drive. If you don't have a CD\DVD in your workstation drive, that's ok, you should still see the drive though.

~coolsport00
0
 
coolsport00Commented:
If it still doesn't work, post a screenshot of the VM's settings and the toolbar icon your clicking on.
0
 
NewbieITGalAuthor Commented:
Thanks Coolsport00   -  its working!

Here's what made the difference of it working.  I had a choice of choosing an E or F Drive.
Previously, I kept trying the F Drive and it would fail.  Today, I tried connecting to the E Drive
and it worked both ways - client and host.    I'm not quite sure why I have a choice between and E and F Drive.  It seems like it should just be a d drive.   Thanks for all your help.  I really appreciate!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now