DAG Setup Error - the exchange trusted subsystem is not a member of the local administrators group

I've tried this on 2 servers.  1st server was a DC I found out that it should be a non-DC server so I moved it to non-DC server.  Added the "Exchange Trusted Subsystem" group to the Local Admins group of that server and it still has the same error.  Reboot all servers involved and it still has the same error.  It doesn't create the Folder or Folder Share for the Quorum although the wizard says it is completeing, albeit with this error message.
LVL 1
ChocolateRainAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dustin99352Commented:
Did you add the Witness Server to the Exchange Trusted Subsystem group?  That should make the error go away if you have not.
0
ChocolateRainAuthor Commented:
Yes I have.  Didn't do anything.  Just to clarify here the group membership are as follows:

1)  The Exchange Trusted Subsystem group is a member of the Witness Server's Local Administrators group.
2)  The Computer Account of this Witness server is a member of the Exchange Trusted Subsystem group.

These action seem redundant and the book I've read "Exchange Server 2010 Administrator's Pocket Consultant" doesn't mention step #2 as you advised whatsoever.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dustin99352Commented:
Are you using Service Pack 1?  Perhaps this is your issue.

http://www.jbmurphy.com/2011/03/04/exchange-2010-sp1-and-new-databaseavailabilitygroup/
0
ChocolateRainAuthor Commented:
Had to remove the 1 Exchange server that was in the DAG group prior to reconfiguring it.  I call this a "jiggling the handle" solution as nothing fundamentally changed to get it working, just configuring and then reconfiguring settings the same way over and over again until it takes them without err.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.