Exchange 2003 Relay Internal Working External Not Working

I have an application server that sends email out using relay on my exchange 2003 server.  We specifically allow the IP address of the application server to relay off our exchage server.  We also use a barracuda spam/email server.  Everything was working fine.  I changed the IP address of our application server to a different subnet.  I modified the smtp connector to reflect the new IP address.

NOW I can send email from my application server to internal address.  I CANT send outboud to external addresses like yahoo.com.  

Any ideas?
MohonkAsked:
Who is Participating?
 
NetfloConnect With a Mentor Commented:
Hi Mohonk

I would take a look at your Default SMTP Virtual connector under protocols in ESM.

Right click on it, choose properties, select the Access tab.

Verify that under Connection Control that your application server is granted access to the virtual server. Press OK to come out of that menu.

Verify under Relay Restrictions that your application server is granted access to relay though the virtual server.

You may also want to check on the Users button, that the User account that the application runs under is permitted to relay. Press OK to come out of that menu. OK again. Finally OK to come out of the Default SMTP Virtual Server Properties.

Right click the Default SMTP Virtual connector, stop
Right click the Default SMTP Virtual connector, start

Please retest and let me know how you get on, pretty sure you'll pinpoint that only your local subnet was in the access list.

Best of luck!
0
 
AmitConnect With a Mentor IT ArchitectCommented:
Public email server will treat it as spam. Did you configured the reverse DNS entry for new IP. All Public email server checks for reverse entry, if not found it will be rejected.
0
 
MohonkAuthor Commented:
Under virtual smtp connector

- access control - anonymous access
- no secure communications
- connection control - All except list below and nothing under computers
- relay restrictions - only list below and IP address of application server is listed (allow all computers is unchecked) (users - authenticated users - submit permissons is checked)
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
MohonkAuthor Commented:
Is there any application i can run on the application server to test smtp relay?  I know I can do it through telnet.
0
 
NetfloCommented:
Can you try to telnet to your Exchange server and send an email out to say your personal Gmail or Hotmail. The error received here will help you troubleshoot your issue further. I would also enable SMTP logging and review the log files on your Exchange server to more information.
0
 
NetfloCommented:
The following link http://support.microsoft.com/kb/895853 will help on troubleshooting and pin pointing the issue.
0
 
MohonkAuthor Commented:
I created a new reverse lookup zone for my new 192.168.0.x network.

I created a ptr record for 192.168.0.10 and the application server name.

Still doest appear to be working.  
0
 
NetfloCommented:
Did you take a look at the MS article, which provides a thorough break down of troubleshooting? Is you application server that sends out email internal or external to your network? From my understanding its internal.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.