Help Configuring Domain wit hTwo Subdomains

Hello,

I need help configuring DNS for my domain.

I've registered a domain called: mydomain.com

Inside my LAN, I have two machines:

Machine A resides at 192.168.1.99.  This will be the Joomla web server for my domain.  It should respond to requests going to www.mydomain.com.
Machine B resides at 192.168.1.98.  This will be the Zimbra mail server for my domain.  It should respond to requests going to mail.mydomain.com.
Note that both machines need to have several ports exposed to the outside world for additional services, such as ssh and phpmyadmin.

I have a Linux box, running Fedora 14, that I'll use to route incoming traffic to these two servers on my LAN.  Could you please walk me through the steps to do this?  

I'm very computer literate, just not very wise in the ways of network administration.

Thanks,
Jason
SqueezeOJAsked:
Who is Participating?
 
farzanjCommented:
Lets have it this way:
/var/named/chroot/var/named/squeezeoj.com.zone
$TTL 1D
;
@	IN	SOA     ns.squeezeoj.com. admin.squeezeoj.com. (
                        2011042103              ; serial
                        28800                   ; refresh slaves
                        14400                   ; retry
                        3600000                 ; expire
                        86400                   ; Negative TTL
                        )
;
@                       IN	NS	ns.squeezeoj.com.
;
www                     IN	A	192.168.1.99
mail                    IN	A	192.168.1.98
ns.squeezeoj.com.	IN	A	192.168.1.99
@                       IN      MX  10  mail.squeezeoj.com.
;

Open in new window



0
 
farzanjCommented:
So your DNS should have A records and MX (mail server) record.  MX would point to mail.mydomain.com

You know if you issue the dig command, you would see pretty much the DNS record as it is.  You can easily see examples like

dig yahoo.com
dig mx yahoo.com
dig ns yahoo.com

This would give you all examples of how your DNS files would look like.  It would be pretty similar to what you would need.

On Fedora, your DNS files should be located to something similar to /var/named/chroot/var/named.
0
 
SqueezeOJAuthor Commented:
Here are the files I find in /var/named :

[root@localhost named]# ls -l
total 28
drwxrwx---. 2 named named 4096 Feb 18 10:07 data
drwxrwx---. 2 named named 4096 Feb 18 10:07 dynamic
-rw-r-----. 1 root  named 1892 Feb 18  2008 named.ca
-rw-r-----. 1 root  named  152 Dec 15  2009 named.empty
-rw-r-----. 1 root  named  152 Jun 21  2007 named.localhost
-rw-r-----. 1 root  named  168 Dec 15  2009 named.loopback
drwxrwx---. 2 named named 4096 Feb 18 10:07 slaves

Open in new window


All three of the directories are empty.

Here's the contents of named.ca :

[root@localhost named]# cat named.ca
; <<>> DiG 9.5.0b2 <<>> +bufsize=1200 +norec NS . @a.root-servers.net
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34420
;; flags: qr aa; QUERY: 1, ANSWER: 13, AUTHORITY: 0, ADDITIONAL: 20

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;.				IN	NS

;; ANSWER SECTION:
.			518400	IN	NS	M.ROOT-SERVERS.NET.
.			518400	IN	NS	A.ROOT-SERVERS.NET.
.			518400	IN	NS	B.ROOT-SERVERS.NET.
.			518400	IN	NS	C.ROOT-SERVERS.NET.
.			518400	IN	NS	D.ROOT-SERVERS.NET.
.			518400	IN	NS	E.ROOT-SERVERS.NET.
.			518400	IN	NS	F.ROOT-SERVERS.NET.
.			518400	IN	NS	G.ROOT-SERVERS.NET.
.			518400	IN	NS	H.ROOT-SERVERS.NET.
.			518400	IN	NS	I.ROOT-SERVERS.NET.
.			518400	IN	NS	J.ROOT-SERVERS.NET.
.			518400	IN	NS	K.ROOT-SERVERS.NET.
.			518400	IN	NS	L.ROOT-SERVERS.NET.

;; ADDITIONAL SECTION:
A.ROOT-SERVERS.NET.	3600000	IN	A	198.41.0.4
A.ROOT-SERVERS.NET.	3600000	IN	AAAA	2001:503:ba3e::2:30
B.ROOT-SERVERS.NET.	3600000	IN	A	192.228.79.201
C.ROOT-SERVERS.NET.	3600000	IN	A	192.33.4.12
D.ROOT-SERVERS.NET.	3600000	IN	A	128.8.10.90
E.ROOT-SERVERS.NET.	3600000	IN	A	192.203.230.10
F.ROOT-SERVERS.NET.	3600000	IN	A	192.5.5.241
F.ROOT-SERVERS.NET.	3600000	IN	AAAA	2001:500:2f::f
G.ROOT-SERVERS.NET.	3600000	IN	A	192.112.36.4
H.ROOT-SERVERS.NET.	3600000	IN	A	128.63.2.53
H.ROOT-SERVERS.NET.	3600000	IN	AAAA	2001:500:1::803f:235
I.ROOT-SERVERS.NET.	3600000	IN	A	192.36.148.17
J.ROOT-SERVERS.NET.	3600000	IN	A	192.58.128.30
J.ROOT-SERVERS.NET.	3600000	IN	AAAA	2001:503:c27::2:30
K.ROOT-SERVERS.NET.	3600000	IN	A	193.0.14.129
K.ROOT-SERVERS.NET.	3600000	IN	AAAA	2001:7fd::1
L.ROOT-SERVERS.NET.	3600000	IN	A	199.7.83.42
M.ROOT-SERVERS.NET.	3600000	IN	A	202.12.27.33
M.ROOT-SERVERS.NET.	3600000	IN	AAAA	2001:dc3::35

;; Query time: 147 msec
;; SERVER: 198.41.0.4#53(198.41.0.4)
;; WHEN: Mon Feb 18 13:29:18 2008
;; MSG SIZE  rcvd: 615

Open in new window


Should I start by copying this file?  What would the new file be called?  What changes would I need to make?  Do I need to copy & alter other files too?

Thanks,
Jason
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
farzanjCommented:
It is Fedora, right.

Looking like you are missing RPMS.

Issue command

rpm -qa | grep bind
rpm -qa | grep caching

You should have
bind
bind-utils
bind-libs
bind-chroot
caching-nameserver


Install whatever is missing



 
yum install bind bind-utils bind-libs bind-chroot caching-nameserver

Open in new window

0
 
SqueezeOJAuthor Commented:
Definitely Fedora 14.  

It seemed like I was missing bind and caching-nameserver, so I ran the yum statement you listed and bind was installed but not caching-named.  Then I reran the greps and here's what I got:

[root@localhost User]# rpm -qa | grep bind
bind-libs-9.7.3-1.fc14.i686
bind-utils-9.7.3-1.fc14.i686
bind-chroot-9.7.3-1.fc14.i686
bind-9.7.3-1.fc14.i686
PackageKit-device-rebind-0.6.12-2.fc14.i686
system-config-bind-4.0.15-2.fc14.noarch
samba-winbind-clients-3.5.8-74.fc14.i686

Open in new window


[root@localhost User]# rpm -qa | grep caching

Open in new window


The second grep didn't find caching-nameserver, so I try to install it again and Fedora reports that it's already installed:

[root@localhost User]# yum install caching-nameserver
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
Package 32:bind-9.7.3-1.fc14.i686 already installed and latest version
Nothing to do

Open in new window


Not sure if this matters.  So I move to the next step...

Good news is that I now have the directory you asked for: /var/named/chroot/var/named .  Bad news is it's empty and I'll just need you to explain again what I'm gonig to put in there.

I liked your Yahoo example.  I ran those commands and saw what they did.  I own another couple of domains that are currently hosted with an ISP.  Here's one: www.BinghamtonYoga.com .

If I run dig binghamtonyoga.com and the two other dig commands, I recognize most of the information.  Could I just run these three dig commands, copy the contents and put them into appropriate files.  Then change these files to reflect the new domain? Which, in this example is mydomain.com.

Thanks for your help!
Jason



0
 
farzanjCommented:
I would try to take a look after work tonight.
0
 
farzanjCommented:
Hi,
Sorry, I got extremely busy, I had to do my taxes.
Ok, once again, please give provide me accurate info/requirements, and this time I would make sure to do it.  If you still need help, I would be glad to provide it to you.  Please respond.
0
 
SqueezeOJAuthor Commented:
Welcome back, Farzanj!  I hope you're getting a big return.

Original desire is to use my Fedora 14 machine as a DNS server to outside connections.

Requests directed at www.MyDomain.com should be directed to machine at IP 192.168.1.99

Requests directed at mail.MyDomain.com should be directed to machine at IP 192.168.1.98



When we started, you had me check: your DNS files should be located to something similar to /var/named/chroot/var/named.  I didn't have this folder, so you had me install several yum packages and now I do.  This folder is currently empty.

I'd like to build the DNS files necessary to populate that folder and direct requests to the two IP addresses listed above.  As a point of reference, I suggested using dig on a domain name that I own for other activities (www.BinghamtonYoga.com).  This way, the information would be easily recognizable.

Thanks for your help!

0
 
expert_tanmayCommented:
Does your Fedora 14 machine have a public IP. In case you wish to use the the Fedora 14 machine as a DNS server you must put min two NS ptr with your domain registrar.

Since you wish to redirect network traffic for web as well as smtp to machines on private IP you need to write rules for port forwarding in IPTABLES. This will basically DNAT traffic on a port to a different IP and then again SNAT the server response packet with its own IP.

Cheers..
0
 
SqueezeOJAuthor Commented:
Yes - I've already got the name servers set up and they're working right.  My website is www.squeezeoj.com.  This website runs in the DMZ of my router.
0
 
farzanjCommented:
Ok.

You should already have the following RPMS installed.

STEP 1:
bind (includes DNS server, named)
bind-utils (utilities for querying DNS servers about host information)
bind-libs (libraries used by the bind server and utils package)
bind-chroot (tree of files which can be used as a chroot jail for bind)
caching-nameserver (config files for a simple caching nameserver)

If you don't have any one of these, install them with yum.
Edit: vi /var/named/chroot/etc/named.conf and add the following forward and reverse zone file directives:

STEP 2:
 
# Forward Zone for domain
zone "squeezeoj.com" IN {
        type master;
        file "squeezeoj.com.zone";
};

# Reverse Zone domain
zone "1.168.192.in-addr.arpa" IN {
        type master;
        file "192.168.1.zone";            
};

Open in new window

0
 
farzanjCommented:
STEP 3:


The forward file

Edit /var/named/chroot/var/named/squeezeoj.com.zone and paste the following code in it.
$TTL 1D

squeezeoj.com.             IN      SOA     ns.squeezeoj.com. (
                                201104140                 ; serial
                                2H                        ; refresh slaves
                                5M                        ; retry
                                1W                        ; expire
                                1M                        ; Negative TTL
                                )

@                       IN      NS      ns.squeezeoj.com.

www.squeezeoj.com.      IN      A       192.168.1.99

Open in new window


We will expand on it, but this is what you have for now.

Now check zone with this command
named-checkzone squeezeoj.com squeezeoj.com.zone

Open in new window


If everything works fine (no errors), restart the service
service named restart

Open in new window


Test the results using this command
 
dig @localhost www.squeezeoj.com

Open in new window


So now we are done with the forward lookup.
0
 
farzanjCommented:
STEP 4

This is for the reverse lookup.

Edit /var/named/chroot/var/named/192.168.1.zone and paste the following code in it.
 
$TTL 1D

squeezeoj.com.             IN      SOA     ns.squeezeoj.com. (
                                201104140                 ; serial
                                2H                        ; refresh slaves
                                5M                        ; retry
                                1W                        ; expire
                                1M                        ; Negative TTL
                                )

@                       IN      NS      ns.squeezeoj.com.

www.squeezeoj.com.      IN      A       192.168.1.99
        IN      NS      ns.squeezeoj.com.
99      IN      PTR     www.squeezeoj.com.

Open in new window


Now check zone with this command

 
named-checkzone 1.168.192.in-addr.arpa 192.168.1.zone

Open in new window


Restart the service again.
 
service named restart

Open in new window


Test the results using this command
 
dig @localhost -x 192.168.1.99

Open in new window



Sorry, I forget to put the mail MX entry, which one more line in each file.  Try these any ways and let me know how it goes.
0
 
SqueezeOJAuthor Commented:
Excellent information, Farzanj!

I'll try to work through it this weekend and get back to you with any questions.  I'm mostly away from the machine until Sunday evening.
0
 
farzanjCommented:
Ok.  Hope it works.
0
 
expert_tanmayCommented:
That was all about DNS records you also need port forwarding for DMZ.
#HTTP REDIRECTION
iptables -A INPUT -p tcp -m state --state NEW --dport 80 -i eth1 -j ACCEPT
iptables -A PREROUTING -t nat -i eth1 -p tcp --dport 80 -j DNAT --to 192.168.1.99:80

#SMTP REDIRECTION
iptables -A INPUT -p tcp -m state --state NEW --dport 25 -i eth1 -j ACCEPT
iptables -A PREROUTING -t nat -i eth1 -p tcp --dport 25 -j DNAT --to 192.168.1.98:25

Cheers..
0
 
expert_tanmayCommented:
Above -i eth1/eth0 etc is based on the NIC connecting your router.

Cheers.
0
 
SqueezeOJAuthor Commented:
Hi Farzanj,

I'm working through the detailed steps you gave me and I'm getting an error in Step three.  Let me explain:

* First, here's the /var/named/chroot/etc/ directory...
[root@localhost User]# cd /var/named/chroot/etc
[root@localhost etc]# ls -l
total 20
-rw-r--r--. 1 root root  3519 Apr  6 08:58 localtime
drwxr-x---. 2 root named 4096 Apr 19 08:09 named
-rw-r--r--. 1 root root  1577 Apr 19 07:42 named.conf     <-- File We Modified
drwxr-xr-x. 3 root root  4096 Apr  6 08:58 pki
-rw-r-----. 1 root named   97 Apr  6 10:09 rndc.key

Open in new window


* Next, I edited the named.conf file and added your lines near the bottom...
[root@localhost etc]# more named.conf
// Red Hat BIND Configuration Tool
// 
// Default initial "Caching Only" name server configuration
//

options {
	listen-on-v6 { any; };
	directory "/var/named";
	dump-file "/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
	/*
	 * If there is a firewall between you and nameservers you want
	 * to talk to, you might need to uncomment the query-source
	 * directive below.  Previous versions of BIND always asked
	 * questions using port 53, but BIND 8.1 uses an unprivileged
	 * port by default.
	 */
	 // query-source address * port 53;
};

zone "." IN {
	type hint;
	file "named.root";
};

zone "localdomain." IN {
	type master;
	file "localdomain.zone";
	allow-update { none; };
};

zone "localhost." IN {
	type master;
	file "localhost.zone";
	allow-update { none; };
};

zone "0.0.127.in-addr.arpa." IN {
	type master;
	file "named.local";
	allow-update { none; };
};

zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa." IN {
        type master;
	file "named.ip6.local";
	allow-update { none; };
};

zone "255.in-addr.arpa." IN {
	type master;
	file "named.broadcast";
	allow-update { none; };
};

zone "0.in-addr.arpa." IN {
	type master;
	file "named.zero";
	allow-update { none; };
};

# Forward Zone for Domain - Added April 19, 2011
zone "squeezeoj.com" IN {
        type master;
        file "squeezeoj.com.zone";
};

# Reverse Zone for Domain - Added April 19, 2011
zone "1.168.192.in-addr.arpa" IN {
        type master;
        file "192.168.1.zone";            
};

include "/etc/rndc.key";

Open in new window


* Next, I created the zone file: /var/named/chroot/etc/named/squeezeoj.com.zone ...
[root@localhost named]# cd /var/named/chroot/etc/named
[root@localhost named]# ls -l
total 4
-rw-r--r--. 1 root root 567 Apr 19 08:09 squeezeoj.com.zone
[root@localhost named]# more squeezeoj.com.zone
$TTL 1D

squeezeoj.com.             IN      SOA     ns.squeezeoj.com. (
                                201104140                 ; serial
                                2H                        ; refresh slaves
                                5M                        ; retry
                                1W                        ; expire
                                1M                        ; Negative TTL
                                )

@                       IN      NS      ns.squeezeoj.com.

www.squeezeoj.com.      IN      A       192.168.1.99

Open in new window


* Finally, I test them and receive an error...
[root@localhost named]# named-checkzone squeezeoj.com squeezeoj.com.zone
dns_rdata_fromtext: squeezeoj.com.zone:4: near '2H': not a valid number
zone squeezeoj.com/IN: loading from master file squeezeoj.com.zone failed: not a valid number
zone squeezeoj.com/IN: not loaded due to errors.

Open in new window


It's complaining abotu "2H" not being a valid number - so, it seems like it doesn't like the contents of my zone file.  What should I do to fix this?

Thanks!
Jason





0
 
farzanjCommented:
In the zone file change this line

squeezeoj.com.             IN      SOA     ns.squeezeoj.com.

with
squeezeoj.com.             IN      SOA     ns.squeezeoj.com. admin.squeezeoj.com.


Then see if it can get rid of the errors.
0
 
SqueezeOJAuthor Commented:
HI Farznaj,

I added the "admin.squeezeoj.com." to the zone file and now I get a new error:

[root@localhost named]# named-checkzone squeezeoj.com squeezeoj.com.zone
zone squeezeoj.com/IN: NS 'ns.squeezeoj.com' has no address records (A or AAAA)
zone squeezeoj.com/IN: not loaded due to errors.

Open in new window

One thing I noticed is that my public name servers are called ns1.squeezeoj.com and ns2.squeezeoj.com.  Both of these resolve to my server's address (74.202.86.48).  However, ns.squeezeoj.com does not resolve to anything.  If you try pinging it, you can see what I'm talking about.  Is ns.squeezeoj.com supposed to be an internal address?  Or should we be pointing somethign at ns1 or ns2?

What should I try next?

Jason

0
 
farzanjCommented:
Below this record
www.squeezeoj.com.      IN      A       192.168.1.99

Add another line
ns.squeezeoj.com.         IN   A    192.168.1.99

Or whatever the address is.

Also change the serial number to the current date.  If you don't update the serial number, DNS would not change.
0
 
farzanjCommented:
Is this machine one of 204.13.208.234 or 204.13.208.235?  What is the live IP on this machine?
0
 
SqueezeOJAuthor Commented:
No, those two addresses are hosted on a dedicated server in Texas.  They simply point back to my house, which is where I'd prefer to host squeezeoj.com.  My house's IP is 74.202.86.48.
0
 
SqueezeOJAuthor Commented:
I added the line you suggest above and incremented the serial number and the error is gone - initially at least.  Take a look at the Output:

[root@localhost named]# named-checkzone squeezeoj.com squeezeoj.com.zone
zone squeezeoj.com/IN: loaded serial 2011041910
OK     <-----This is Good!

[root@localhost named]# service named restart
Stopping named:                                            [  OK  ]
Starting named: 
Error in named configuration:
zone localdomain/IN: loaded serial 42
zone localhost/IN: loaded serial 42
zone 0.0.127.in-addr.arpa/IN: loaded serial 42
zone 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loaded serial 42
zone 255.in-addr.arpa/IN: loaded serial 42
zone 0.in-addr.arpa/IN: loaded serial 42
dns_master_load: squeezeoj.com.zone:2: unexpected end of line
dns_master_load: squeezeoj.com.zone:1: unexpected end of input
dns_rdata_fromtext: squeezeoj.com.zone:4: near '2H': not a valid number   <---Same Error New Place
squeezeoj.com.zone:11: using RFC1035 TTL semantics
zone squeezeoj.com/IN: loading from master file squeezeoj.com.zone failed: unexpected end of input
zone squeezeoj.com/IN: not loaded due to errors.
_default/squeezeoj.com/IN: unexpected end of input
192.168.1.zone:3: ignoring out-of-zone data (squeezeoj.com)
192.168.1.zone:13: ignoring out-of-zone data (www.squeezeoj.com)
zone 1.168.192.in-addr.arpa/IN: has 0 SOA records
zone 1.168.192.in-addr.arpa/IN: not loaded due to errors.
_default/1.168.192.in-addr.arpa/IN: bad zone
                                                           [FAILED]

Open in new window

However, now that "2H" error is popping up in a different way.  To combat it, I tried using pure number values, like the ones you find here:  http://www.linuxserverhowto.com/linux-dns-server/dns-zone-files-explained.html.   It makes no difference.  We get the same error.

What would you suggest I try next?
0
 
farzanjCommented:
In each zone file (both forward and reverse), you have a line looking like

squeezeoj.com.             IN      SOA     ns.squeezeoj.com.

I had forgotten to put the mail address, which is a mandatory field.  But the @ sign is changed by period.  It is supposed to be administrator's email address

So if you have admin@squeezeoj.com, would be written as admin.squeezeoj.com.

That field should be there on both forward and reverse files.

If it still complains about 2H, put 120 in lieu of it.  But I think we have to look at lines above it more carefully because if you look at your own output, it complains about lines terminating abruptly before it gives that error message.

Here is how the things work and you have to figure out the rest since you did the domain registrations.

DNS is a database of domain name conversion to IP addresses.  It is a network of databases--so when one DNS does not have answer, it forwards your request to the next.  They narrow down it to the DNS that is Source of Authority SOA for a particular zone.  In short, someone has to know that for squeezeoj.com. your server (IP) is the source of authority.  So that part is done through domain registrations -- so you know more details about that than me.  Once that request comes to your server, it would give the results.
0
 
SqueezeOJAuthor Commented:
Farzanj,

I've gotten the forward zone to do a named-check without any errors.  However, the reverse still gives me a "2H" related error.  The thing is - I've totally replaced 2H with a number and it still complains.  It's like it won't forget that there was once a "2H" in that file.

To fix this, I've tried everything from changing that file' serial number to rebooting the machine, but I still seem to get this error.  How do I clear the cache here?

Thanks,
Jason
0
 
farzanjCommented:
As I said, it needed that extra field-- the email address over here to.  Did you provide that field?
0
 
farzanjCommented:
So did you try this file
/var/named/chroot/var/named/192.168.1.zone
$TTL 1D

squeezeoj.com.             IN      SOA     ns.squeezeoj.com. admin.squeezeoj.com. (
                                201104210                 ; serial
                                2H                        ; refresh slaves
                                5M                        ; retry
                                1W                        ; expire
                                1M                        ; Negative TTL
                                )

@                       IN      NS      ns.squeezeoj.com.

www.squeezeoj.com.      IN      A       192.168.1.99
        IN      NS      ns.squeezeoj.com.
99      IN      PTR     www.squeezeoj.com.

Open in new window

0
 
SqueezeOJAuthor Commented:
Farzanj,

Forget that last comment - I had one of the files in the wrong directory.  I now have no errors!

Both Zones Checkout...
[root@localhost named]# named-checkzone squeezeoj.com squeezeoj.com.zone
zone squeezeoj.com/IN: loaded serial 2011042102
OK

[root@localhost named]# named-checkzone 1.168.192.in-addr.arpa 192.168.1.zone
192.168.1.zone:13: ignoring out-of-zone data (www.squeezeoj.com)
zone 1.168.192.in-addr.arpa/IN: loaded serial 2011042102
OK

Open in new window


The named service restarts OK...
[root@localhost named]# service named restart
Stopping named:                                            [  OK  ]
Starting named:                                            [  OK  ]

Open in new window


The dig commands run like this...
[root@localhost named]# dig @localhost www.squeezeoj.com

; <<>> DiG 9.7.3-RedHat-9.7.3-1.fc14 <<>> @localhost www.squeezeoj.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53200
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

;; QUESTION SECTION:
;www.squeezeoj.com.		IN	A

;; ANSWER SECTION:
www.squeezeoj.com.	86400	IN	A	192.168.1.99

;; AUTHORITY SECTION:
squeezeoj.com.		86400	IN	NS	ns.squeezeoj.com.

;; ADDITIONAL SECTION:
ns.squeezeoj.com.	86400	IN	A	192.168.1.99

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Thu Apr 21 22:45:52 2011
;; MSG SIZE  rcvd: 84



[root@localhost named]# dig @localhost -x 192.168.1.99

; <<>> DiG 9.7.3-RedHat-9.7.3-1.fc14 <<>> @localhost -x 192.168.1.99
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19661
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

;; QUESTION SECTION:
;99.1.168.192.in-addr.arpa.	IN	PTR

;; ANSWER SECTION:
99.1.168.192.in-addr.arpa. 86400 IN	PTR	www.squeezeoj.com.1.168.192.in-addr.arpa.

;; AUTHORITY SECTION:
1.168.192.in-addr.arpa.	86400	IN	NS	ns.squeezeoj.com.

;; ADDITIONAL SECTION:
ns.squeezeoj.com.	86400	IN	A	192.168.1.99

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Thu Apr 21 22:48:37 2011
;; MSG SIZE  rcvd: 121

Open in new window



Inside squeezeoj.com.zone added a line for my mail prefix:

           mail                    IN      A      192.168.1.98


I think I'm ready to go live....I'll cut-over and see waht happens.  If you have any other suggestions or something I missed, I'd be happy to hear about it.

THANKS for all the work you've done and I hope to close this soon...
Jason

0
 
SqueezeOJAuthor Commented:
Just to make sure all the info is out there.  Here are the zone files I've created:

/var/named/chroot/var/named/squeezeoj.com.zone
$TTL 1D
;
@	IN	SOA     ns.squeezeoj.com. admin.squeezeoj.com. (
                        2011042102              ; serial
                        28800                   ; refresh slaves
                        14400                   ; retry
                        3600000                 ; expire
                        86400                   ; Negative TTL
                        )
;
@                       IN	NS	ns.squeezeoj.com.
;
www                     IN	A	192.168.1.99
mail                    IN	A	192.168.1.98
ns.squeezeoj.com.	IN	A	192.168.1.99
;

Open in new window


/var/named/chroot/var/named/192.168.1.zone
$TTL 1D
;
@	IN	SOA     ns.squeezeoj.com. admin.squeezeoj.com. (
                        2011042102              ; serial
                        28800                   ; refresh slaves
                        14400                   ; retry
                        3600000                 ; expire
                        86400                   ; Negative TTL
                        )
;
@                       IN	NS	ns.squeezeoj.com.
;
www.squeezeoj.com.	IN	A	192.168.1.99
                        IN	NS	ns.squeezeoj.com
99                      IN	PTR     www.squeezeoj.com
;

Open in new window

0
 
SqueezeOJAuthor Commented:
Thanks for sticking with me, Farzanj!

You've taught me a lot about the infrastructure of the Linux DNS and I realize I have more to learn.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.