Configure cisco 2950 interface?

Hi Experts,

I have a cisco 2950 24 ports, I'd like configure the interface fastEthernet 0/5 which allows only 2 VLANs can go thru, these vlan are 8 and 9.

The VLAN 8 is our voice vlan and vlan 9 is our office internet.

Thanks.

LVL 1
SJCAAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gcl_hkCommented:
en
conf t
int fa0/5
switchport access vlan 9
switchport voice vlan 8
0
vikrantambhoreCommented:
interface FastEthernet0/1/5
 description -= ---------------------- =-  you can put anything
 switchport trunk allowed vlan 8,9,1002-1005
 switchport mode trunk


HTH
0
eeRootCommented:
Something like this...

en
conf t
int fa0/5
switchport trunk encapsulation dot1q
switchport mode trunk
switchport allowed vlans 8, 9
switchport access vlan 9
switchport voice vlan 8
spanning-tree portfast
spanning-tree bpduguard enable
exit
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

SJCAAuthor Commented:
I got this when I was trying to do this:

switch(config-if)#switchport trunk allowed vlan 8,9
Command rejected: Bad VLAN allowed list.
VLANs 1,1002-1005 are required.
switch(config-if)#

It seems that I have to include vlan 1, 1002-1005. Any ideas why it requires me to do add those extra vlans?

For 'Spanning-tree portfast', I thought we only need it when we are not on trunk mode?!
0
eeRootCommented:
The 2900 series have a few different ways of doing things, some commands are different depending on model and firmware level.

Vlans 1002 - 1005 are used by the system.  Most switches just include them automatically, but the 2900's tend to be a bit different.

"Spanning-tree portfast" can be used in trunk mode if the attached device is not a switch, or other network device
0
SJCAAuthor Commented:
I have a NEC phone (VoIP phone), it has  2 ethernet ports (port A and B) on its back, I was told that the port A will go to  int 0/5 and port B will go to my PC.

Here is the map:
Cisco 2950 int 0/5 -->phone --> my PC.

Is this phone considered a switch too? and do I still need to set 'spanning-tree portfast' for the int 0/5?
0
eeRootCommented:
No, a daisy chained phone+PC is considered an end-device, not a switch.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.