Exchange 2010 SP1 Upgrade Failure

I am trying to install the Exchange 2010 SP1 upgrade on a Windows 2008 R2 OS.
The upgrade clears all the pre-requisites and starts the update process but when it gets to the 'Languages' step of the upgrade the system immediately errors and the upgrade fails.
the Error is: The process cannont access the file 'C:\Program Files\Microsoft\Exchnage Server\V14\Logging\lodctr_backups\InstalledPerfCategories.log' because it is being used by another process.
Restarting the server makes no difference.
Deleting this log file has no effect.
Making sure 'everyone' has write access to an exitsing version of the log file has no effect.

I am trying to install the complete language bundle (which has been downloaded and is successfully verified).

I can restart the upgrade but it always fails in the same place.
dgewinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tsaicoCommented:
I had a problem installing SP1, and it turned out I was missing some R2 updates.  Once I updated the windows environment to current, I was able to install SP1 for Exchagne no problem.  My rig also passed all the pre-reqs, but it would just stall when trying to interact with the services.  

Also check out the even viewer, it can often have a extra errors that do not pop on the screen for isntallation.
0
dgewinAuthor Commented:
Thanks, the only update that hasn't been applied is the SP1 Rollup for Exchange. I am not installing that as SP1 has not finished installing yet.
The logs only showed some counter errors and ASP warnings.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

dgewinAuthor Commented:
This doesn't seem to be applicable as I can't actually get SP1 to install successfully.
The upgrade failes at the Languages step before getting to the Hub transport role et al.
If I restart the server after this failure all the services start except the  Transport service (which fails immediatly if you try to start it).
The users are able to open their mailboxes but do not receive any email.
0
waleedaCommented:
could you try to stop all exchange services and start the upgrade SP1
0
MegaNuk3Commented:
Or make a not of the exchange service settings (automatic/manual) then set all the exchange services to disabled, then reboot. Set the services back to what they were but leave them stopped then install SP1

If you have any monitoring software on there then disable it until SP1 is installed
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dgewinAuthor Commented:
Thanks for that. I shut down all 3rd party software and re-installed. The upgrade worked and my email is working again.
0
MegaNuk3Commented:
Glad it worked
0
waleedaCommented:
why i didnt get any points while i provided a correct solution..!!!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.