Exchange 2007 and attachment sizes

Hi, I have an Exchange Server 2007 running on SBS 2008.

We have an issue where our attachments exceed the default 10MB Exchange file limit.  I've gone into Exchange>Hub Transport > Transport Settings and adjusted them to 40MB.  I've restarted the Exchange services and SMTP services.  Still I am unable to send above 10MB.

I've looked into this and people mentioned a Global setting, but that was for Exchange 2003 and upgrade installs of 2007.  

Where else should I look for this setting?

Here's a dump from a failure message.


Delivery has failed to these recipients or distribution lists:

xxxx@xxxxxxxxxxxxx.com
This message exceeds the maximum message size allowed. Microsoft Exchange will not try to redeliver this message for you. Please make the message smaller -- by removing attachments, for example -- and try sending it again, or provide the following diagnostic text to your system administrator.

  _____  

Sent by Microsoft Exchange Server 2007







Diagnostic information for administrators:

Generating server: LERFS.lernet.local

xxxx@xxxxxxxxxxxx.com
#550 5.3.4 ROUTING.SizeLimit; message size exceeds fixed maximum size for route ##

Original message headers:

Received: from LERFS.lernet.local ([fe80::51a2:bbb8:fd00:79c9]) by
 LERFS.lernet.local ([fe80::51a2:bbb8:fd00:79c9%10]) with mapi; Wed, 6 Apr
 2011 00:06:20 -0400
Content-Type: application/ms-tnef; name="winmail.dat"
Content-Transfer-Encoding: binary
From: xxxxxxx <xxxxx@xxxxxxxx.com>
To: "xxxx@xxxxxxxxxx.com" <xxxx@xxxxxxxxxxxxxxx.com>
Date: Wed, 6 Apr 2011 00:06:12 -0400
Subject: test of attachment size limits
Thread-Topic: test of attachment size limits
Thread-Index: Acv0D+bOOZXCEqnJQVG+W7lK5SyElQ==
Message-ID: <641CF6EDBDEFE14EA8BE47532214CD8F29A84979DD@LERFS.lernet.local>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator: <641CF6EDBDEFE14EA8BE47532214CD8F29A84979DD@LERFS.lernet.local>
MIME-Version: 1.0
X-TM-AS-Product-Ver: SMEX-8.6.0.1374-6.500.1024-18056.004
X-TM-AS-Result: No--43.146500-5.000000-31
X-TM-AS-User-Approved-Sender: No
X-TM-AS-User-Blocked-Sender: No
SteelValleyAsked:
Who is Participating?
 
waleedaCommented:
you need to check some places:

for receiving and sending as well:
1st:
Organization Configuration->Hub Transport->Global Settings->Properties of Transport Settings
then you can set your transport send/receive limit

2nd:
Receive Connector:
Server Configuration->Hub Transport->Receive Connectors Pane->Properties of Default <hostname>
then you can set your receive connectors default maximum message size

3rd:
Send Connector
Organization Configuration->Hub Transport->Send Connectors->Properties of Default Send
then you can set your send connectors default maximum message size

note:
also check the database limits and user mailbox limits, if you have configured before


for more information please check the below URL:
http://technet.microsoft.com/en-us/library/bb124345.aspx
0
 
SteelValleyAuthor Commented:
We can now send larger attachments using the steps above, but receiving mail with large attachments is still causing issues.  Get a rejected message saying attachment size exceeds limits.
0
 
waleedaCommented:
Did u check your receive connectors
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.