Exchange 2010 Outlook Anywhere setup

Environment: Exchange 2010 on Server 2008; ADDC; also running DNS
This server is doing all Exchange roles -- it's a single server. There is another DC in the form of an old Server 2003 box, but it has nothing to do with Exchange.

Certificate is GoDaddy and appears fine.

Internal domain is abc.local; "real" domain is xzy.co.uk. Server is reffered to as mail.xyz.co.uk on the outside world and server02.abc.local internally.

Port 443 (https) is mapped over on firewall from the RIPE IP to the internal IP. The firewall is a Cisco PIX.

OWA works fine to this server from the outside world as well as interally. Internally either to https://server02.abc.local/exchange or https://mail.xyz.co.uk/exchange and externally just to https://mail.xyz.co.uk/exchange of course.

DNS is set up internally for xzy.co.uk as well.

I have been through the "Outlook Anywhere" wizard on the server with BASIC authentication; and it appeared to complete correctly.

If I ping mail.xzy.co.uk internally I get responses from internal IP 192.168.254.4 per DNS.
If I ping mail xzy.co.uk externally I get responses from correct RIPE IP per DNS.

IPv6 is deselected on the adapter settings of the single enabled network card on the server.

If I telnet to ports 6001, 6002 & 6004 internally it works and I get the correct response. The ports are blocked from the outside world, but I tested unblocking them and mapping across breifly and I got the same response -- but it didn't fix the issue so I closed them off again.

When I run the RPC over HTTP test at https://testexchangeconnectivity.com it all works until the point:

Attempting to ping RPC endpoint 6001 (Exchange Information Store) on server mail.xyz.co.uk.
  The attempt to ping the endpoint failed.
   Tell me more about this issue and how to resolve it
   Additional Details
  The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process.

Where do I go from here, please? (I have Exchange 2003 servers working fine, and it's supposed to be easy on 2010!!)

Many thanks in advance.
seworbyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

markpalinuxCommented:

Does simple OWA work across the Internet?

You have enabled Outlook Anywhere on the Exchange 2010. Just to confirm., I think you would see different errors if not

The traffic should flow only 443 only.


Check this
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_25203827.html

I would change that requestLimits maxAllowedContentLength="2147483648" setting and run the iisreset.

Thanks,
Mark



0
seworbyAuthor Commented:
Dear Mark,

Many thanks for your response.
I can confirm that OWA is fine; and that Outlook Anywhere was enabled with the wizard.
Thanks for your confirmation re: 443 only being required on the firewall which was as I had expected.

I undertook the following steps mostly thanks to your link:


Where abc is the local server name; domain is the local domain name, and xyz.co.uk is the domain to the outside world:-

Added:
192.168.254.4 abc
192.168.254.4 abc.domain.local
192.168.254.4 mail.xyz.co.uk
to the hosts file. Ping abc now gets replies from the server's RIPE IP rather than :::1.

This did not fix the problem, not in itself at least.

The following already existed in C:\Windows\System32\inetsrv\config\applicationHost.config

<requestFiltering>
 <requestLimits maxAllowedContentLength="2147483648" />
</requestFiltering>

so I did not make any changes.

ValidPorts key in HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\RpcProxy
read: abc:593;abc:49152-65535
which looked nothing like shreedhar's version in:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_25203827.html
so I left it alone. But note this is Exchange 2010 not 2007...

But sort of per his suggestion I added: mail.xyz.co.uk:6001-6002;mail.xyz.co.uk:6004 to ValidPorts_AutoConfig_Exchange in the HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\RpcProxy registry key so it now reads:
abc:6001-6002;abc:6004;abc.domain.local:6001-6002;abc.domain.local:6004;mail.xyz.co.uk:6001-6002;mail.xyz.co.uk:6004

To re-iterate the above, the mail.xyz.co.uk entries were originally *not* there.

The connectivity test then worked. But after a little while the entries were gone and it failed again!

I then went back and added them to the ValidPorts key in HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\RpcProxy instead even though it didn't really look like the right place to add them, and the tests then failed on port 6004:

Testing the Name Service Provider Interface (NSPI) on the Exchange Mailbox server.
  An error occurred while testing the NSPI RPC endpoint.
   Test Steps
   Attempting to ping RPC endpoint 6004 (NSPI Proxy Interface) on server mail.xyz.co.uk.
  The attempt to ping the endpoint failed.
   Tell me more about this issue and how to resolve it
   Additional Details
  The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process.
 

So I went back and added mail.xyz.co.uk:6001-6002;mail.xyz.co.uk:6004 back to ValidPorts_AutoConfig_Exchange in the HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\RpcProxy.

And, again per shreedhar's suggestion in:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_25203827.html

I changed HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeServiceHost\RpcHttpConfigurator\PeriodicPollingMinutes to 0 to turn off the RpcHttpConfigurator.

It's now working and apparently isn't automatically being disabled by the RpcHttpConfigurator.

I will run full checks now and confirm back shortly.

Simon
0
seworbyAuthor Commented:
Testing with Outlook confirms this fiix.
To clarify, I do not know if the hosts file entries were necessary for the fix, but certainly they didn't do any harm.

The fix was:

1. Change HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeServiceHost\RpcHttpConfigurator\PeriodicPollingMinutes to 0 to turn off the RpcHttpConfigurator.

2. Add mail.xyz.co.uk:6001-6002;mail.xyz.co.uk:6004 to ValidPorts_AutoConfig_Exchange in the HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\RpcProxy key.

Thanks for the help.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
seworbyAuthor Commented:
The solution was as detailed & in the link provided by Mark, but not the direct suggestion of changing the requestLimits maxAllowedContentLength="2147483648" setting and running the iisreset.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.