Lync 2010 install - Schema for child domain

Hi,

Im trying to install Lync2010 onto a child domain following the step by step guide on http://www.ocspedia.com/fe/Install_Microsoft_Lync_Server_2010.aspx?ArticleID=103 

In the instillation GUI when I run prepare schema it seems to be executing commands for the Parent domain:
Command: ldifde.exe -i -v -k -j "C:\Users\administrator.CHILDDOMAIN\AppData\Local\Temp\2" -f "C:\Program Files\Microsoft Lync Server 2010\Deployment\Setup\ExternalSchema.ldf" -c DC=X "DC=PARENTDomain,DC=internal" -s PD_DC-NAME.PARENTDomain.internal

ultimately when I run prepare current forest i get the following error message in the logs:

 SchemaValidationFailed: The topology XML is not a valid XML schema.
  SchemaValidationFailed: SCHEMA_VERSION_STATE_INVALID  
 SchemaValidationFailedResolution: Address the issues outlined in the logged validation errors.  
 Error: An error occurred: "Microsoft.Rtc.Management.Deployment.DeploymentException" "The schema is not ready. Cannot continue."

Anyone got experience on installing Lync on a child domain or any advice on this ?

Thanks
techaaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Vinchenzo-the-SecondCommented:
I've never installed this app, but any changes to the Schema needs to be on the Schema master.  The forest root will always hold this role, and not a child domain
0
techaaAuthor Commented:
thanks Vinchenzo-the-Second, that clears up that my first step was OK.
I've added a screen shot of the Log generated by running the Prepare Current forest in the GUI, which I believe should create security groups in the AD PrepareCurrentForrestError.pdf
0
Leon FesterSenior Solutions ArchitectCommented:
Did you wait for replication to normalize after running the command in the Parent domain?
You can check the schema version in adsiedit to confirm if the schema was successfully replicated to all all DC's.

As mentioned above, your need to update the root then child domains when doing schema changes.
I have installed Lync in my organization and ran the wizard directly in the Parent Domain first without getting any errors.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

techaaAuthor Commented:
Thanks, dvt Localboy, youre right, it took its time to replicate across to the child domain.

I do have a different error now:
Error: Computer is not a member of the root domain. For security reasons, this action must be run on a root domain computer.

Its because my server is in the Child domain - but this is where I want to install my Lync server, is this not possible? error - wrong domain
0
Leon FesterSenior Solutions ArchitectCommented:
You can install Lync in your Child Domain, it shouldn't be giving you any issues.

I'm not sure if you've installed Exchange before, but the same principle applies in terms of the schema upgrade. See link for more info on schema upgrades http://www.msexchange.org/tutorials/Forestprep-Domainprep-Explained.html

When I configured Lync, I ran the wizard for "Prepare Active Directory" in the Parent domain, so that I could do all neccessary installs.

After replication, I then ran the same wizard "Prepare Active Directory" in the Child Domain.

The main reasons for doing it like this was based on the Schema Upgrade requirements AND because the Groups were not being created when I ran the wizard in the Child Domain only. The Groups only appeared after I ran the wizard in the Parent Domain.

It's only when you run the "Install or Update Lync Server System" Wizard, that the application actually gets installed on your Server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
techaaAuthor Commented:
thanks Dvt Localboy, this helped, also 2008 R2 SP1 was causing issues, removing the SP1 resolved the problems above.
0
techaaAuthor Commented:
used another source to figure out problems related to SP1
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.