How to put Cisco 1811 with pppoe in Bridge mode

I have a Cisco 1811 which connects with pppoe to the internet on FE0 and it routes it to FE2~FE9 in VLAN.

What I need is to have the Cisco 1811 do the pppoe authentication, then bridge all traffic to a pfSense server on FE2 so that the pfSense server has control over our IP block and can NAT these to servers in the DMZ.

Before you suggest it: I tried to let the pfSense server do the  pppoe authentication but that doesn't work.

I came up with this but it doesn't work (no internet access on the pfSense server):
interface FastEthernet0
 description Link to EVPN CPE
 no ip address
 load-interval 30
 speed 100
 full-duplex
 pppoe enable
 pppoe-client dial-pool-number 1
 no shut
 bridge-group 1

!
interface Dialer1
 description Customer Traffic PPPoE Connection
 no shut
 ip address negotiated
 ip verify unicast reverse-path
 encapsulation ppp
 mtu 1492
 dialer pool 1
 dialer-group 1
 ppp pap sent-username uname password 0 pword
 ppp ipcp mask request
 ppp ipcp address accept

interface FastEthernet2
switchport access vlan 1

interface FastEthernet3
switchport access vlan 1

interface Vlan1
bridge-group 1
!

bridge 1 protocol ieee

Open in new window

nbommeljeAsked:
Who is Participating?
 
nbommeljeAuthor Commented:
I have solved my problem in a different way. I ditched the bridging idea.

I created a internal netwerk between the pfSense servers and the router. Then I NATted IP's from this network to all the external IP's and I used port forwarding for the ports I needed on the default IP (the IP assigned by the ISP). Then I NATted the IP's from the "in between" network to the IP's in the DMZ behind the router.

Works flawless thus far.
0
 
Istvan KalmarHead of IT Security Division Commented:
HI,

I think you need SNAT config for pfsense server, bridging not working in this scenario
0
 
Craig BeckCommented:
Why not use ip unnumbered Vlan1 on the Dialer interface, and put one of your Public IPs on the Vlan1 interface.  Then you can use the rest of your Public IP addresses on the pfSense and use the 1811 as a gateway.
0
 
nbommeljeAuthor Commented:
Solved by self.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.