Some of user unable to receive email from DL

We have a problem when sending email to DL. Our infrastructure is we have 2 exchange and AD different forest (contoso.som and fabrikam.com). Both forest are for our subsidary company. Authorised user from contoso.com will send an email to all staff at fabrikam.com. The issue is some of user at fabrikam.com unable to receive the email. I checked at messaging log at contoso.com and fabrikam.com exchange domain but no mail queue found for those user. I have access right on both forest.

On contoso.com
I created a CONTACT for all DL staff (fabrikam) at Contoso.com domain so that the authorized user at Contoso.com domain able to send from her Outlook and webmail.

The distribution settings is:
At fabrikam.com, there is all staff DL created with
a) "Accept the message from following user" - I created a CONTACT for auhtorized user (contoso.com) in fabrikam.com exchange forest and add this authorized user list.
b) The "Require all user are authenticated" is CHECKED by default.

When authorized user at fabrikam.com domain send to all staff, the mail able to reach their all staff.

I already checked on user who unable to receive this email, there is no rules, forwarding and etc on their Outlook and Mailbox. I have no clue now.

I already change the settings on all staff DL(fabrikam.com).
b) The "Require all user are authenticated" is UNCHECKED by default.
The problem still persist.

Please advice
LVL 19
suriyaehnopAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Miguel Angel Perez MuñozCommented:
Try to create a connector between Exchange servers, including smtp domains.
0
suriyaehnopAuthor Commented:
Currently, email from fabrikam.com domain will forward through internal via connector between Exchange but email from contoso.com to fabrikam.com will go through internet
0
suriyaehnopAuthor Commented:
We logged case with Microsoftand gave some logs. They said that there is no "expanding" activity when email from contoso.com reach fabrikam.com. They said that when the email reach Exchange server, the recipient was already listed and those who not receive the email, their name was not in the list.

Any email to fabrikam will reach their Symantec Bright Mail (anti-spam) 1st before it forward to Hub Transport server.

Since, there is a trust between domain, I did create a connector where email from contoso.com tof fabrikam will route through internal link. Once, it done, we did send a test mail and all DL_Allusers able to receive it. When Microsoft guy check the log, they said a "EXPAND" activitivy did happened.
Fabrikam.jpg
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
suriyaehnopAuthor Commented:
The problem already solved based on my solution
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.