Cisco 2960 Switches & 2821 Router with Mitel VOIP System

My company is putting in voice over IP in the form of a mitel solution.  We are putting in a 3300 ICP and i need some specifics on what i need to do with my switches and router.

Our setup is basically 6 access layer switches that all go through a core switch which goes through our core router (the 2821) and out through our cisco asa5510 to the internet.

right now the whole network is very basic.  everything is just on the default vlan 1.

I'm going to do DHCP off the mitel controller for the phones but i know i need to add a voice vlan to each switch and put it on a different subnet than the data nework.  

People computers will be connected to the network through their phones so i need my switch ports to support access to both the data and voice vlan.

We have Metro Ethernet going to our other facilities (there are 3) but right now we are only deploying the voip system at the main office.  eventually though we do what to roll out voip to the other locations over the metro e network we have with at&t so that should be a design consideration.

What i need to know is what i need to add to the config on my switches and/or core router.

I've enclosed a network drawing as well as a sample configuration that i've done on a switch so far as to what i think it needs to look like.

 Network Drawing
In this example I have made the voice 
vlan subnet 192.168.51.XXX and the voice 
vlan is 15.

My Mitel Controller will be 192.168.51.10 
and my switches will be 192.16.51.20-26, 
the router will be 192.168.51.30, and the 
phone DHCP pool will be 192.168.51.40-254

I have added the config information to 
ports 10-18 on the switch to make them be 
able to connect both a phone and a computer 
(I think.)

Building configuration...

Current configuration : 6983 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
service password-encryption
service sequence-numbers
!
hostname Mitel
!
enable secret 5 $1$CAHi$MPuyx97XYStgomWs54H2t0
!
no aaa new-model
clock timezone ZP5 5
switch 1 provision ws-c3750g-24ts
ip subnet-zero
ip routing
!
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
 description voice and data
 switchport mode access
 switchport voice vlan 15
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet1/0/11
 description voice and data
 switchport mode access
 switchport voice vlan 15
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet1/0/12
 description voice and data
 switchport mode access
 switchport voice vlan 15
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet1/0/13
 description voice and data
 switchport mode access
 switchport voice vlan 15
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet1/0/14
 description voice and data
 switchport mode access
 switchport voice vlan 15
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet1/0/15
 description voice and data
 switchport mode access
 switchport voice vlan 15
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet1/0/16
 description voice and data
 switchport mode access
 switchport voice vlan 15
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet1/0/17
 description voice and data
 switchport mode access
 switchport voice vlan 15
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet1/0/18
 description voice and data
 switchport mode access
 switchport voice vlan 15
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
 description Data Vlan
 ip address 150.50.1.5 255.255.255.0
!
interface Vlan15
 description Voice Vlan
 ip address 192.168.51.20 255.255.255.0
!
ip default-gateway 150.50.1.1
ip classless
ip http server
!
snmp-server community public RO
snmp-server community private RW
!
control-plane
!
!
end

Mitel#

Open in new window

gedruspaxAsked:
Who is Participating?
 
atrevidoCommented:
Well, the way I do it is set switchport mode trunk on the combo ports and access mode on the 3300 only port.  ANd then the phones get their VLAN info from my DHCP server, in this case my router.

But you can also do it where the phones get their VLAN info from CDP
This would be the example in that case

Switch1(config)# interface fa0/2 [the connection to the 3300 controller]
Switch1 (config-if)# no cdp enable [turn off unrequired CDP on this interface]
Switch1(config-if)# description "Connection to Mitel 3300 ICP"
Switch1(config-if)# switchport mode access [port defaults to standard Ethernet frame]
Switch1(config-if)# switchport access vlan 100 [sets the VLAN]
Switch1(config-if)# mls qos cos 6 [sets the Ethernet priority (802.1p) to 6]
Switch1(config-if)# priority-queue out [makes queue 4 a strict priority queue]
Switch1(config-if)# mls qos trust dscp pass-through cos [required to allow DSCP & 802.1p through]
Switch1(config-if)# spanning-tree portfast [bypasses the spanning the startup procedure]
Switch1(config-if)# exit
Switch1(config)# interface fa0/4 [the connection to an extension w/computer behind]
Switch1(config-if)# description "combo port"
Switch1(config-if)# switchport mode access [port defaults to standard Ethernet frame]
Switch1(config-if)# switchport voice vlan 100 [allows the IP set to learn the VLAN via CDP]
Switch1(config-if)# mls qos trust dscp pass-through cos [required to allow DSCP & 802.1p through]
Switch1(config-if)# priority-queue out [makes queue 4 a strict priority queue]
Switch1(config-if)# spanning-tree portfast [bypasses the spanning the startup procedure]
Switch1(config-if)# spanning-tree bpdufilter enable [stops spanning tree messages from being sent]

I'm attaching the MItel engineering guidelines, see appendix B and that should help you out











33-ENG-R9.0-EN.pdf
0
 
atrevidoCommented:
some of what I'm doing:

Router:
ip dhcp excluded-address 192.168.51.1 192.168.51.39
ip dhcp pool MyOffice
   network 192.168.51.0 255.255.255.0
   domain-name webcor.com
   dns-server 192.168.x.x
   netbios-name-server 192.168.x.x
   netbios-node-type h-node
   option 132 hex 0000.000f
   option 133 hex 0000.0007
   option 130 ascii "MITEL IP PHONE"
   default-router 192.168.51.30

I do the above on my data vlan/subnet to tell the phones, which are stupid when they come up to go to the right place.
VLAN 15 with priority 7.  So, the phone comes up in VLAN 1 and broadcasts hey, where is my address.
My router answers (yours might be a WIndows or Linux DHCP server but the principal is the same) with the above
special information.  THis tells the phone to do a directed broadcast on VLAN 15

My Qos and programming is much simpler than yours.  Not that there is anything wrong with yours, I don't know, mine works, that's all I care about. I have a large MPLS network with phones and 3300's everywhere so I won't even go into it.

Important point on the switches is that every port will now be a trunk port carrying both VLANs if you put your PC's behind the phones on one cable.  The exception would be where the actual 3300 is plugged in to, that is an access port as the 3300 NIC is not VLAN aware.

I'll let someone else give you more details on your router config
0
 
gedruspaxAuthor Commented:
so in port 10 - 18 on my test switch which i've posted above do i need to have it set to switchport mode trunk instead of switchport mode access on the voice/data combo ports?
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
gedruspaxAuthor Commented:
In doing some research on mitels site and with some engineers i'm told that the following port configs should be used.

[PORTS THAT ARE CONNECTED TO MITEL VOICE EQUIPMENT]

no cdp enable
description Connection to Mitel Equipment
switchport mode access
switchport access vlan 15 (our voice vlan)
mls qos cos 6
priority-queue out
mls qos trust dscp
spanning-tree portfast

[PORTS THAT GO TO A PHONE WITH A COMPUTER BEHIND IT]

description Combo Port
switchport mode access
switchport voice vlan 15
mls qos trust dscp
priority-queue out
spanning-tree portfast
spanning-tree bpdufilter enable

[TRUNK PORTS BETWEEN SWITCHES/ROUTERS]

interface fa0/1
description Connection from Switch 1 to Switch 2
switchport trunk encapsulation dot1q
switchport mode trunk
priority-queue out

So those are the 3 basic port configs i think i need to worry about, please correct me if I have any of that wrong.

The place where the voice and data VLANs converge will be on the core router 150.50.1.1

From what i understand I need to do something like the following

[ROUTER CONFIG]

int fa0/0
description "Default Gateway for 150.50.1.0/24 Network"
ip address 150.50.1.1 255.255.255.0
no shutdown

int fa0/0.15
encapsulation dot1q 15
description Default Gateway for 192.168.51.0/24 VOIP Network
ip address 192.168.51.1 255.255.255.0

-------------------------------------------------

Doing that should make traffic be routable between both vlan 1 subnet and vlan 15 subnet right?
0
 
gedruspaxAuthor Commented:
Mostly everything i needed was in appendix B of the engineering guidelines so i was able to figure it out from there.
0
 
atrevidoCommented:
Your comment with the config is exactly as I posted and I provided you with the Mitel engineering guidelines....so not sure what your problem was since I provided you all you needed to get your question answered
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.