SBS 2008 exchange problem

Hi
I have just installed SBS 2008 for a client. However I have a problem that when I send an email to that exchange server from an email client (outtlook etc)  I get

 The mail server responded:  5.1.1 <user@server.com>... User unknown. Please check the message recipient user@server.com and try again.

However if I send an email to the exchange server using gmail it gets sent and is received by the user. Starting to pull my hair out over this
BsgcompAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NetfloCommented:
Can you delete the cached entry from Outlook (start typing the persons name, press down to highlight the entry, then press delete) and send another message, type the beginning of the users name, followed by CTRL + K, or press Check Name. You may have a dud cached NK2 entry.
0
NetfloCommented:
Can you also try to send an email via OWA to eliminate Outlook, chances are you have a stale entry in Outlook.
0
BsgcompAuthor Commented:
I have used two different clients, outlook and thunderbird on three computers and both clients get
the error message
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Suliman Abu KharroubIT Consultant Commented:
Please check the receive connector "client".

from EMC-->server config-->hub transport. make sure all settings there are correct.
0
NetfloCommented:
On a fresh install of SBS 2008, you should not need to edit or add anything to the default connectors, have you changed anything on there?

Can you also verify that your internal domain, i.e doman.local is the default via EMC -> Org Config -> Hub Transport -> Accepted domains. Your public domain, i.e domain.co.uk should be listed as false. It may be labelled as "Windows SBS External Domain"

If you have to make the change, please restart the server and test again.

If you run SBS 2008 BPA, what does it report? http://www.microsoft.com/downloads/en/details.aspx?familyid=86a1aa32-9814-484e-bd43-3e42aec7f731&displaylang=en

Please let me know how you get on.
0
BsgcompAuthor Commented:
I have 3 recieve connectors
Windows SBS Internet Recieve
Windows SBS Fax sharepoint
default SERVERNAME

Which connector should I be working with (obviously not the fax sharepoint one)
And what should I be looking for?
0
NetfloCommented:
That's fine, providing you have not changed any features. Please take a look at my previous post and check your internal domain and the BPA test.
0
Suliman Abu KharroubIT Consultant Commented:
by default there are 2 connectors ( default and clients ), you are looking for clients.
0
NetfloCommented:
Thats not true, on SBS 2008 everything is setup for you. You get a Default SERVERNAME, SBS Fax Sharepoint Receive SERVERNAME and SBS Internet Receive SERVERNAME.

Providing nothing has been changed on these connectors, we shouldn't veer towards that.

Please check the internal domain and run a BPA, this will highlight where the issue is, clearly!
0
BsgcompAuthor Commented:
netflo

I have under accepted domains
domain.local = False
Windows SBS external dmain = true

 The BPA has returned
The cname resource record for the connect alias should point to a fqdn of the computer that is running sbs 2008

0
NetfloCommented:
Your local domain, should be TRUE, switch them over. Reboot and test.
0
BsgcompAuthor Commented:
ok i have fixed the cname problem
After i set my local domain to true can i just restart the exchange server or do i need to do a reboot
0
NetfloCommented:
You can get away with restarting Microsoft Exchange Active Directory Topology Service.
0
NetfloCommented:
Please also restart Information Store and System Attendant. Your uses will notice blip in connectivity.
0
BsgcompAuthor Commented:
Ok done and rebooted. still tjhe same problem
I've spent hours trying to fix this
0
NetfloCommented:
I've seen this same issue before and worked with Microsoft, your server has an issue resolving delivery to internal recipients. Can you try from OWA please.

What Service Pack is your Exchange on? Roll up?
0
BsgcompAuthor Commented:
Chaps will have to carry on with this tomorrow as I have to attend a meeting. its 17:30 here
0
BsgcompAuthor Commented:
running service pack 2
Our office is not using exchange so I cannot send from owa
0
BsgcompAuthor Commented:
the sbs internet receiver has a fqdn of remote.domain.com Should it not be mail.domain.com?
0
BsgcompAuthor Commented:
Think I have found the problem
Doing ans smtp test at mxtools gives an error
Reverse DNS does not match SMTP Banner

It seems this can cause 5.1.1 errors
0
NetfloCommented:
Your Exchange should be on SP3 and why cannot you use OWA for testing purposes? https://mailserver.domain.local/owa?

The reason why your SBS Internet Receive connector is remote, is due to how you set it up. You can change it via SBS Console -> Network -> Connectivity -> Set up your internet address.... When you're at the screen for Store your domain name, choose Advanced Settings and choose a new domain prefix.
0
NetfloCommented:
The reverse DNS does not match SMTP banner should not cause delivery to internal recipients from the inside of the network. Though as a matter of best practice you should correct that.

Can you please reiterate your question again, my understanding is that your client whom you installed a server for;

Is having problems on the inside when internal clients using Outlook attempt to send to internal recipients?

When you attempt to send an email from Gmail to a recipient, it delivers?

If you try to send an email from your Outlook (external to the organisation), does it deliver?
0
BsgcompAuthor Commented:
Spoke to isp and they say that the reverse dns is not the problem.

If i logon to clients owa and send test email works ok.

Ok. I'm external to the exchange server. If i use outlook, outlook express or thunderbird to send an email to a user in clients organisation I get the 5.1.1 error.
But if I use gmail to send an email it works ok
So basicly my client is not receiving emails from outside, except for gmail
Hope this is clear
0
NetfloCommented:
Okay, I understand now. Can you send from another external provider, say Hotmail, Yahoo or another corporate network?
0
BsgcompAuthor Commented:
Ok going to close this.
Turns out it was the isp that had messed things up. Not happy as I have spent many hours trying to sort the problem. ISP kept denying that its was caused by them.
Thank for all your input
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
NetfloCommented:
My previous question was leading to your ISP, I'm pretty sure they had hosting for your client and probably had mailboxes on their platform. Hence when sending emails from your Outlook would route within their platform and not deliver.

Never the less, glad to see you got to the bottom of this.
0
BsgcompAuthor Commented:
The problem was with the isp
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.