Cannot access company website which has same name as Windows 2008 Server Domain Name

Hello, our company has recently moved up in the computing world and setup a server which has a network of roughly 20 PC's (as well as 20 users).

Now, I have extremely little knowledge of how to setup a server but I somehow I've managed it! The server has 3 roles: AD DS, DNS Server, Print Services.

So from the top I've setup the domain to have the same name as our company website. (website: company.co.uk, domain: company.co.uk). We've noticed that from any of the workstations hooked up to the domain that the company site doesn't work. I'm assuming this has something to do with the naming of the domain as it was working perfectly beforehand.

So I've gone ahead and researched how to change the name of the Domain using "rendom", I think it was a matter of luck that I managed to change it without it braking, but the outcome of using "rendom" has changed the domain from "company.co.uk" to "company". This has succumbed to no avail and the problem still persists.

So really I need a little guidance on what to try next, I've had a look into the DNS zone stuff/thing but as you may tell I have no idea what I'm doing. If anyone can help me out I would be very grateful, please do understand that I don't know any server "buzz" words and I'm unsure of where many option and settings are located.

Thanks,

Ollie.
OllieEdgeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

maytrixCommented:
I suspect the issue is simply a DNS issue and your company website is hosted externally?

All you'd need to do is create a new A record in DNS for www.company.com and have it point to the external IP of your company website.  You could also set one up for company.com as well so the www isn't needed.
0
OllieEdgeAuthor Commented:
OK, thank you, however I don't know what or how to create a A record is? How would you go about doing this?
0
zjb100Commented:
We had a similar problem at my company. Here is what I did to resolve it.

1. Go to a computer outside of your network and open command prompt. Ping your website and write down the ip address.

2. From your Domain controller, go to start, administrative tools, DNS. You should see your domain controller. Expand the dc and right click on box that says forward lookup zone. Click add new zone. use your website name. example : yourwebsite.com without the www.

3. Once completed you should see if under forward lookup zones. right click on it and add new host (a or aaa).
4. Enter the name of your website (minus www) and add the ip address you recorded earlier.uncheck create ptr record.
5. At top, right click your dc and click update server data files.

I hope this helps.  
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Darius GhassemCommented:
No what you need to do is create an A record in DNS call www that has IP address of your external Web server

Here are the full instructions.

http://oddjobsintech.com/active-directory-tip-access-external-website-with-the-same-domain-name-as-your-internal-domain/

If your domain name is the same externallly and internally then you already have DNS zones created
0
zjb100Commented:
I agree, but he stated that he used a program to change the domain name.
0
Darius GhassemCommented:
First thing is you should change the domain name back to the orignal
0
maytrixCommented:
Yeah, you do not need to create a new zone.  And you can change the domain name back to what it was previously.

To add the A record, you go to Administrative tools and then DNS.  In there you will see your domain name listed - might have to expand a few entries.  Within your domain (company.com), right click and select new A record.  This is where you would enter www for the hostname and the IP address.  You should be able to do this prior to doing any domain renaming.
0
kevinhsiehCommented:
The full domain name should be along the lines of company.local, or maybe company.co.uk.local, but NOT company.co.uk. Having the AD domain name the same as the public DNS domain name will cause problems like the poster is experiencing. If the AD domain and the public DNS domain match, you can not get http://company.co.uk to work. Only http://www.company.co.uk is possible (unless you are hosting www.company.co.uk on EVERY domain controller, which is a bad idea).

So, I suggest renaming the domain again to company.local.
0
OllieEdgeAuthor Commented:
Solutions given opened up a opportunity for me to understand DNS zones a little more, thus, managing to use these comments along with google search to piece together the final solution.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Internet Protocols

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.