Shared folder permissions to allow Network Copier/Scanner to access desktop folder

I am trying to set up a Windows XP domain user to allow a large network copier/scanner to be able to access a desktop folder to scan documents into.  I can set up the desktop folder share it out as "Everyone Full Control" and make it work.  The problem is that everyone on the network can see the contents of the folder.  I need to have the folder shared so the the scanner can scan to the folder but only let the computer user see the contents.  The copier/scanner has a place to let the user put in their user name and password.  Thanks
257RobertsAsked:
Who is Participating?
 
Adam BrownSr Solutions ArchitectCommented:
You have two different permission settings for shares, Share Permissions and NTFS permissions. It's actually a best practice to set the Share permissions to Authenticated Users - Full Control (Or Read and Write). Then you set the actual limited permissions with NTFS security. Windows will accept the least permissive permissions. Once you determine which user you want to use for the copier/scanner you can add that user to the folder's NTFS permissions list on the shared folder with Read access.
0
 
cbmmCommented:
does the printer/scanner support ldap?
0
 
Carl BohmanCommented:
You should be able to grant permissions to the account entered into the scanner without granting permissions to everyone.  When you share the folder, set the permissions so that everyone is removed from access and only the users you want to have access are added.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
cbmmCommented:
does is support scan to ftp?
0
 
Hypercat (Deb)Commented:
I will often create a special AD account for the "scanner user." In your case, once you create this account you'd need to add it to the local permissions on the workstation so that it can access the folder, remove the Everyone permissions, and then also add the account of the user who logs on to the workstation. That should be all you need to do.  Then the locally logged on user and the scanner user would be the only ones who would be able to access the folder, unless additional permissions were added.
0
 
Hypercat (Deb)Commented:
Of course, on the scanner, you need to use the "scanner user" name and password on that end as well when you set it up to scan to the folder.
0
 
257RobertsAuthor Commented:
Ok I will try suggestions and see which ones work.  Thank You
0
 
257RobertsAuthor Commented:
Here is what worked.  I put "Everyone" under Share Permissions as "Full Control".  Then under the NTFS permissions, I unchecked the box with "Inherit Permissions from other objects" I had to then choose "Copy" and then was able to take everyone off the permissions except the desktop user.  I did leave "System" as a user.  I think I remembered that that has to be left alone.  Sorry it took me this long to post back, but today was the first day I could work on the users machine.  Thanks and let me know if I need to do anything else.  
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.