Unable to start Blackberry attachment service

We recently ran into an issue where we can't start the Attachment service on our BES server. We get an error indicating the service started but then stopped. I've tried changing between local account and the besadmin account for service credentials and we have rebooted with no luck. I've also verified that all other BES services are running, including the SQL DB services.

The only errors regarding BES in event viewer follow this format:

{user@domain.com} MAPIMailbox::GetRIMCalendar(EntryID) - Failed to retrieve email address for 'Jon Smith'

Source: BlackBerry Messaging Agent, Event ID 20298

However, these only reference one user in the domain and may not be relevant to this particular issue.

Any thoughts short of reinstalling part of BES?
kfarhangAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rob KnightConsultantCommented:
Hi,

Are you seeing any errors in the attachment service log file on the BES?

Regards,


RobMobility.
0
Rob KnightConsultantCommented:
Hi,

Depending on the version, I believe the attachment server runs as the system account on BES 4 and BlackBerry service account on BES 5.

Can you provide more details on BES version, Exchange version, how BES is implemented (on Exchange server, separate server, separate servers for BlackBerry components, separate SQL server etc.,)

Regards,


RobMobility.
0
kfarhangAuthor Commented:
The accounts had nothing to do with it and there were no errors. We eventually contacted BES who determined that part of the attachment service was somehow missing. We had to back up the BES database and reinstall.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kfarhangAuthor Commented:
Contacted RIM. Installation was corrupted. Attachment service was missing files it relied on.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
BlackBerry Programming

From novice to tech pro — start learning today.