Unable to start Blackberry attachment service

We recently ran into an issue where we can't start the Attachment service on our BES server. We get an error indicating the service started but then stopped. I've tried changing between local account and the besadmin account for service credentials and we have rebooted with no luck. I've also verified that all other BES services are running, including the SQL DB services.

The only errors regarding BES in event viewer follow this format:

{user@domain.com} MAPIMailbox::GetRIMCalendar(EntryID) - Failed to retrieve email address for 'Jon Smith'

Source: BlackBerry Messaging Agent, Event ID 20298

However, these only reference one user in the domain and may not be relevant to this particular issue.

Any thoughts short of reinstalling part of BES?
kfarhangAsked:
Who is Participating?
 
kfarhangConnect With a Mentor Author Commented:
The accounts had nothing to do with it and there were no errors. We eventually contacted BES who determined that part of the attachment service was somehow missing. We had to back up the BES database and reinstall.
0
 
Rob KnightConsultantCommented:
Hi,

Are you seeing any errors in the attachment service log file on the BES?

Regards,


RobMobility.
0
 
Rob KnightConsultantCommented:
Hi,

Depending on the version, I believe the attachment server runs as the system account on BES 4 and BlackBerry service account on BES 5.

Can you provide more details on BES version, Exchange version, how BES is implemented (on Exchange server, separate server, separate servers for BlackBerry components, separate SQL server etc.,)

Regards,


RobMobility.
0
 
kfarhangAuthor Commented:
Contacted RIM. Installation was corrupted. Attachment service was missing files it relied on.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.