How do you track done an error that is not defined..

We have SQL Server & Integrations Services 2005.
OK.. I have been doing a few successful SSIS packages this way. I put out a flat file to a directory folder the Server has access to.

Just built a new one. I ran if from BIDS it works fine. I moved the package to the IS on the Server & created a job agent to run it. It blew up with this very helpful error..

Run SSIS Package through Job Agent..
Message
The job failed.  The Job was invoked by User UNIONLEADER\wstephens.  The last step to run was step 1 (testprocess).

So I tried running the package stand-alone. it give the error ..

Error: SSIS Error Code DTS_E_ProductLevelToLow. The product level is insufficient to component 'Flat File Destination"

So I took a similar package that runs fine in the job agent. I ran the package stand-alone.. I get similar errors about product level is insufficient..  I run the normal job.. works fine.

I take the package to the bids program do minor changes upload works fine.. I take the package and rename it, and do major changes to remove all but the flat file move, but leave where it is moving it to, and all file connections alone.. Set it up to run in the job agent. I get the original error of the job agent.. "Job failed"

At this point I do not know what to try, or why I get this. A co-worker thinks an upgrade may be leaving the old packages working fine, but now not allowing us the same priviledge we had on any new packages we build.. If so this will be a major melt down, and why are they taking away functionality from their old Servers???
LVL 1
moosetrackerAsked:
Who is Participating?
 
Anthony PerkinsCommented:
It sounds like the startup account for the SQL Server Agent service is set to a Local System account or does not have the required permissions.
0
 
Alpha AuCommented:
i've encounter similar error message yesterday,

does your sql server installed with Integration Service??

please refer to this:
http://social.msdn.microsoft.com/forums/en-US/sqlintegrationservices/thread/5c799f21-c365-4c95-ab16-d670f833567c/
0
 
moosetrackerAuthor Commented:
is that what this error that says nothing more then "It Failed" means? It is not even getting in to run the first step out of the package?..

The Integration service is set up and is currently running several jobs of SSIS packages daily and has been doing so for about a year now..

I created a test package about a week back that didn't push out a flat file to a path folder, but was used to test something else. That was successful. I don't think I am doing anything different in my setup..

But it gives me one more idea to try tommorrow. I will simply create a new job in the job agent to run the one program that has similar features yet runs successfully..  I only did that with the package after I renamed it, and wittled out all the code except for the push of the data out to a folder outside the database..  I am curious to see if the unmodified package will work under a new job setup or not..

Thanks, I will let you know tommorrow.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Alpha AuCommented:
for your information, the error message i encountered yesterday is :
The task cannot run on this edition of Integration Services. It requires a higher level edition

not sure is that the one you encounter.
0
 
Reza RadConsultant, TrainerCommented:
What is your protection Level?
try with SaveSensitiveWithPassword, and set a password, and in the job set password to run the package.
this is good picture tutorial about how do deploy your package with SaveSensitiveWithPassword protectionlevel and run it as sql server job:
http://www.protalk.in/sql-server/steps-to-create-and-deploy-ssis-package-as-a-sqlagent-job/
0
 
moosetrackerAuthor Commented:
OK.. I am closing this up and awarding all three of you some of the points..

I am not going to add this to the Knowledge Base as the whole thing was very, very dumb on my part..

I have done multi Job Agent setups but I guess the majority have been with combining multiple SSIS packages into the Job Agent.  I knew on an error for those to open the History tab up, look for the package with the error and then read the error..

For some reason the single package in the Job thru me.. I was only looking at the head process in the history and not opening up and reading the specific package detail..  The generic "Package Failed" was because I was at the main level !!!

Once I could read the error, it became a simple issue of the fact the proxy only gave the directory I was trying to wright to, read priviledges..

Duh! Duh! and Double Duh!!! How long did I waste my time with this?  Way.. Way.. too long..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.