Windows 2008 Cluster node won't join due to authentication error 1570

Setting up an Exchange DAG and can't get the second mailbox node to join the DAG.  Through the exchange console, we get error;
[2011-04-04T22:14:59] WriteError! Exception = Microsoft.Exchange.Cluster.Replay.DagTaskOperationFailedException: A server-side database availability group administrative operation failed. Error: The operation failed. CreateCluster errors may result from incorrectly configured static addresses. Error: An error occurred while attempting a cluster operation. Error: Cluster API '"AddClusterNode() (MaxPercentage=100) failed with 0x5b4. Error: This operation returned because the timeout period expired"' failed. ---> Microsoft.Exchange.Cluster.Replay.AmClusterApiException: An Active Manager operation failed. Error: An error occurred while attempting a cluster operation. Error: Cluster API '"AddClusterNode() (MaxPercentage=100) failed with 0x5b4. Error: This operation returned because the timeout period expired"' failed.. ---> System.ComponentModel.Win32Exception: This operation returned because the timeout period expired
   --- End of inner exception stack trace ---

When I try to add the node through the Failover Cluster Manager, I get this error;

The server 'node2' could not be added to the cluster.
An error occurred while adding node 'node2' to cluster 'DAG1'.
This operation returned because the timeout period expired
  The cluster event that is written is:
Node '%1' failed to establish a communication session while joining the cluster. This was due to an authentication failure. Please verify that the nodes are running compatible versions of the cluster service software.

The event logged on node2 is "Failed to initialize cluster with error 0x80004005"

There was originally one network adapter in each server, but after discussing with microsoft, they will only support a two nic setup.  With one adapter in each server, getting the same error.

Tried putting the 2nd apapter on same network and a different vlan with same results.

I have researched and tried the fix in this article, but it didn't work; http://social.technet.microsoft.com/Forums/en-US/winserverClustering/thread/4b41cafb-f3cc-4c9d-bd87-bcbb0fe15740/

I have also ran the validation wizard and all test pass, there are a few warnings on the network portion, but none that fail.  

No events at the same time of the attempt to join on any of the domain controllers.  

Any thoughts while I am waiting for Microsoft?
sftech132Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pegasysCommented:
1) are they BOTH talking to the right MASTER (PDC)? As if they are talking to different servers, they can get this issue
2) If their times are different i.e. timezones (watch daylight time saving!)
3) Are the on the same subnet?
4) Are both SERVRS running the SAME exchange services?
0
pegasysCommented:
oh and are all those service .exe files all the same version as one another?
0
sftech132Author Commented:
They are both communicating with the same pdc, both logged into domain on that pdc.
Times are matched, both nsync using NTP to the same pdc.
Same subnet.
The servers are both Mailbox servers, but node2 is also running the CAS and HUB role.

The exchange version is the same on both machines.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

pegasysCommented:
is any of the advanced firewalling enabled on any of the 2 servers?

also, have trust relationships been established between the 2?
0
dhetman024Commented:
Has there been any resolution to this?  I am having a similar issue where one of my Exchange servers fell out of the cluster and now it won't join back.  I've been on the phone with Microsoft for 2 days now with no luck.  
We removed the node from the cluster and now it won't join back to the DAG or Windows cluster.
0
sftech132Author Commented:
Our issue turned out to be McAfee.  The software had to be completely uninstalled, not just disabled.  
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sftech132Author Commented:
This was tough to figure out.  Spent three days on the phone with Microsoft being passed back and forth between the Cluster and Exchange teams.  If you are having any cluster issues, start by stripping off all non Microsoft, imho.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.