Acting up host headers

I moved a host header(customer) from old production server to a new production server.  
Before then, I had a test hostheader (Testcustomer) on the new production site and everything works perfectly


I created a new website using the host header (Customer) pointing to the same coldfusion files as (TestCustomer)
and the session login part is not working properly for Customer site.
(no physical errors..just keep taking me back to the login prompt in the application)

 My concern is that:
The 2 websites Customer and TestCustomer are pointing to the same Coldfusion files on the same server.
I am not sure why host header Customer is giving different results.  

Any inputs will be appreciated
Nana HemaaAsked:
Who is Participating?
 
pcsmitpraConnect With a Mentor Commented:
oh, thats not a problem of Coldfusion, Its problem with Permissions. You may check and compare permissions for Customer with other and make same , Or for now, Stop the website Customer, and change the hostname for other website  to customer and it will work with Customer's hostname.
0
 
pcsmitpraCommented:
There is a facility in Coldfusion to define hash () and  getCurrentTemplatePath() like in this code:
<cfset this.name = hash( getCurrentTemplatePath() ) />

What does it means , is that the application name is used to map or attach with the coldfusion memory space. Which means it does react as a a completely different coldfusion name space if the application name is different. So you can run multiple of websites with separate names on same data.
You may find the related code in some file like Application.cfc, which will have code for cfcomponent and cffunction.
Hope this will help you.

Cheers.
0
 
Nana HemaaAuthor Commented:
Can you share more light on what I should do to resolve this.  I want to remove the Testcustomer if the Customer works ok.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
pcsmitpraCommented:
You can check any of the website and if you find it fine it will valid for both as same code in use. To make it working only for one application you can modify "Application.cfc". And you can delete this code "<cfset this.name = hash( getCurrentTemplatePath() ) />"
But there is no harm with this code. You can safely stop your one website in IIS and go with testing with the other you need.
0
 
Nana HemaaAuthor Commented:
In the user.cfc which controls the login which seems to be the problem .I do not see  "<cfset this.name = hash( getCurrentTemplatePath() ) />"

I removed  TestCustomer  website so that only Customer is pointing to the path --same issue.  I pointed TestCustomer  back to the same path and it is working great.  I tried renaming host name testcustomer to Customer but IIS will not let me....
0
 
Nana HemaaAuthor Commented:
can you ellaborate on this ..I do not see this code
--- To make it working only for one application you can modify "Application.cfc". And you can delete this code "<cfset this.name = hash( getCurrentTemplatePath() ) />"


any inputs...users are waiting to use the site with Customer as the host header name..any inputs  what to do to resolve this issue
0
 
pcsmitpraCommented:
what is the error you see with Customer" website?
0
 
Nana HemaaAuthor Commented:
no physical errors....There is a login prompt that validates the login and session the user to access all other links.  Even though I am able to log in ok.....it keeps taking me back to login prompt again when I try to access the other links.....  It is acting that user is not logged in
0
 
pcsmitpraCommented:
In case you want to investigate, Please tell me your version of IIS.
For IIS 6
Go to website -> Properties -> Security -> Check and compare the security here  for both of the websites.
0
 
Nana HemaaAuthor Commented:
iis7--version of iis
0
 
Nana HemaaAuthor Commented:
-oh, thats not a problem of Coldfusion, Its problem with Permissions. You may check and compare -------permissions for Customer with other and make same , Or for now, Stop the website Customer, and ----change the hostname for other website  to customer and it will work with Customer's hostname.


I stopped the customer website and changed the host name of the other website  to Customer website and the same issue again
0
 
Nana HemaaAuthor Commented:
I changed the host name back to  TestCustomer and everything is working fine....I am not sure why different host names will act differently even with the same site.  Any inputs appreciated.  I have to let users start using...the only problem is that I cannot tell users the address is TestCustomer instead of  Customer
0
 
Nana HemaaAuthor Commented:
I created a new host header CustomerInfo and that seems to work
0
 
pcsmitpraCommented:
Great ;-)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.