One Windows 7 PC can't get internet access.

I am having issues with one Windows 7 Pro PC on my small business network.

Here is the setup
Server: Windows 2008 SBS
PC #1: Windows 7 Pro, can connect to the internet
PC #2: Windows 7 Pro, can not connect to the internet
Router: D-Link DIR-655 with DHCP enabled IP range .20.100 to .20.199

The issue is PC #1 and PC #2 are the exact same specifications (Dell Vostro 230), and as far as I can tell have the same configuration for thier network adapters.

PC#1 works without issue. It is assigned an IP address of .20.104
PC#2 connects to the network, but not to the internet. It gets assigned an IP of .20.21 (preferred), which is outside of the router's DHCP scope.
The Server is running DCHP as well.

First perplexing thing is that PC#2 keeps picking up an IP outside of the Router's scope.
I have attached screenshots of some information that may help. Please ask if there is any other set up information that will help diagnose this.
 General Router Setup PC#1 IP Config - CAN connect PC#1 Route Print - CAN connect
 PC#2 IP Config - Can NOT connect PC#2 Route Print - Can NOT connect Windows 2008 SBS - IP Config
SteveHoggAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ActiveDirectorymanCommented:

It seems like you have Two DHCP servers with different scopes.  

Do you need to have two dhcp servers? if you are using windows dhcp then why do you have it running on the router?

if you want to use both like that then you can split the scopes using the 80/20 rule.

please elaborate on this thanks
0
Larry Struckmeyer MVPCommented:
Assuming you have finished the Internet and network wizards in the SBS Console:

Turn off the DHCP server on one or the other of the boxes.  I prefer to use the DHCP of the SBS not the router.  Use the SBS nic address as your DNS, and be sure that the SBS can find www.support.microsoft.com.  If necessary, run the fix my network wizard.  

If any station does not find the internet correctly, open a command prompt (get used to rclick, run as administrator), issue the command ipconfig /flushdns, then the command ipconfig /registerdns.


0
DraginMagikCommented:
on pc2...delete the NIC, reboot and then reinstall/configure.

0
Get Cisco Certified in IT Security

There’s a high demand for IT security experts and network administrators who can safeguard the data that individuals, corporations, and governments rely on every day. Pursue your B.S. in Network Operations and Security and gain the credentials you need for this high-growth field.

Patmac951Commented:
On PC2 the one experiencing the problem....have you simply tried to assign a Static IP address?  And use static DNS too? Take the DHCP range out of the picture and assign a static IP address that is valid on the network but outside the DHCP scope if possible.  That should solve the issue.
0
Rob WilliamsCommented:
>>"The Server is running DHCP as well. "
In an SBS domain the SBS should most definitely be the DHCP server and as a result DHCP must be disabled on the router. If you enable the DHCP on the router the SBS DHCP service will fail and cause all sorts of problems. If for some reason you feel the router must be the DHCP server please read the following:
http://sbs.seandaniel.com/2008/10/do-i-absolutely-have-to-run-dhcp-on-sbs.html
0
SteveHoggAuthor Commented:
ActiveDirectoryman: I turned the DCHP off on the router, rebooted PC #2 and still no network connection. It did pick up the .20.21 IP address again.

fl_flyfishing: Flush/Register DNS will be attempted when I get back to the office. Going to try it using a .bat file, but I am having a hard time even creating that. (the the remote desktop problem)

DraginMagik: I will try this when I am back in the office.

Patmac951: I have tried static IP, and static DNS previously.  no luck

The real confusing thing here is that there are 2 PCs connected through the same router. Even with DHCP enabled on both the router and server, 1 can get internet, 1 can not. I currently have left the DHCP off on the router.

Not sure if this is of any help, but in order to access the problem PC, I am have a Remote Desktop connection to the Server, then a Remote Desktop connection to PC #2. The Remote Connection to PC#2 is very sporadic.Disconnects, no connect, trying to do anything on it has been a real pain.
A remote connection to the PC that can connect to the internet is much, much smoother.  
0
Rob WilliamsCommented:
Is DHCP running on the SBS? It may be enabled but should have shut itself down when it 'saw' the router's DHCP service and will not normally automatically restart itself. Most often you have to manually restart.

Rebooting a PC will not necessarily force it to make a DHCP request. You need to run IPconfig /release and /renew to be assured.

Also you have a second NIC enabled on the SBS, it is disconnected, but needs to be disabled. Running the BPA or Fix my network wizard will error out on having it enabled. Having the second NIC enabled can also disable the DHCP service on the SBS.
0
SteveHoggAuthor Commented:
RobWill: I restarted the DHCP on the Server, I will do a /release /renew when I get back to the office tomorrow.

I have also disabled the second NIC on the server. Will let you know what happens. Thanks
0
Rob WilliamsCommented:
It doesn't seem to be related to the problem, but curious why PC1 has a VPN (PPP) connection to your server as well as a LAN connection.
0
Patmac951Commented:
The thing I still don't understand is if you have DHCP enabled on PC2 why is it picking up and IP address outside of the DHCP scope on the router.  When you tried assign a static IP address to the NIC (network card) on PC2 what IP address, subnet and gateway addresses did you try?  

Finally for testing purposes again I would statically assign and IP address to the NIC on PC2 like 192.168.20.190 using subnet 255.255.255.0 and the default gateway of 192.168.20.1.  Then statically assign the DNS and use a DNS server outside your network for testing purposes you can use 4.2.2.2 and 4.2.2.3 as secondary.  Then try the internet connection again...this sounds like a DNS issue.

If that still does not work I would consider trying another network card using an available PCIE slot.
0
SteveHoggAuthor Commented:
RobWill: I should have touched on that. PC 1 is meant to be an "off-site" PC. So I have a task that connected to the VPN on startup... I usually just disconnected it. Sorry for the confusion. It connects to the internet on or off of the VPN

Patmac951: I have disabled DHCP on the router now, and I have tried exactly what you suggest. Same subnet, router as the gateway.

When I get back to the office tomorrow evening I am going to try uninstalling the NIC, reinstalling, and also a USB to Ethernet adapter I have lying around.  

Aside from that.... re-install. Not too big of a deal, but I would like to know what is going on for future reference...
0
SteveHoggAuthor Commented:
I tried all the suggestions, and had no luck. I have fixed the problem though.
What I ended up doing was backing up the router config, then reset it back to factory defaults.
I compared all the settings in the back up to the factory defaults and found that there was a difference in the firewall settings. I reloaded the saved config, changed the NAT Endpoint settings to match the default settings, and viola!
 NAT Endpoint Settings - Default
I can't remember the settings I had, I believe that both UDP and TCP were set to Endpoint Dependent
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SteveHoggAuthor Commented:
Issue was not caused by any of the proposed solutions. Good information though!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Operations

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.