disabling appletalk on hp laserjet 2035

It came to our attention that a non-shared printer was showing up in the available printers list to any and all mac computers once they are on the network. We use these hp 2035's purely for printing personal information as local printers.

i'm under the impression that the reason for it showing up is it has appletalk running, how would i go about disabling that feature from the HP laserjet 2035?
highhill2011Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Davis McCarnOwnerCommented:
Open the printers web admin page and in the networking section will be an option to disable appletalk.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
schapsCommented:
The Laserjet 2035 does not come with a network interface standard (that's the 2035n), and you referenced them as "local," so i am assuming they are hooked up via USB or parallel cable, and in that case, the only way it is showing up for modern Macs (Mac OS 10.6.x) is via Bonjour shared. Apple no longer supports Appletalk after OS X 10.5

You can tell what type it is when you go to add a printer to a Mac, it should say what type it is. You can also download a free utility called "Bonjour Browser" (http://www.tildesoft.com/) which will show you all Bonjour services being advertised on your network and which computers are doing that advertising. If it is being shared by a Mac, simply turning Printer Sharing off on that Mac will take care of that.

Even if I misunderstand and these are the network version printers, that model does not have Appletalk. You would connect to its web interface (easiest way is via Bonjour, ironically, and Safari - open a Safari page, click the little 'book' below the back button, and look for the Bonjour option, and all Bonjour devices will show up - click the printer, and you're connected to its web interface). You'll then want to disable the protocol "mDNS" or Bonjour - older 1320n's called it mDNS, the new model might call it Bonjour.

Good luck
0
highhill2011Author Commented:
after checking it is indeed the 2035n, and it is connected via a local TCP/IP port that was only configured for the user in question. i'm going to accept both solutions though because there is a lot of good info in the second post, and as you probably can tell i need all the help i can get with mac OS
0
schapsCommented:
I am not sure why the first author's comment got the accepted solution-- the printer does not have Appletalk. I pointed that out and then described what Macs now use instead of Appletalk, called "Bonjour," and further described how HP does not call it Bonjour, but the configuration item to look for is "mDNS." Finally, the first author didn't even tell you how to access the web configuration (EWS) page, but I did.
Anyway...

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.