• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 416
  • Last Modified:

Adding a computer to a Windows 2008 Domain

When trying to add a compuer with Windows 7 Professional to a Windows 2008 Server I get this message:
n attempt to resolve the DNS name of a domain controller in the domain being joined has failed.  Please verify this client is configured  to reach a DNS server that can resolve DNS names in the target domain.
0
kheaney
Asked:
kheaney
3 Solutions
 
BoguezCommented:
At the command prompt enter nslookup
set type=srv
_ldap._tcp.dc._msdcs.domain.name

Your domain controller(s) should be listed if configured correctly. (Replace domain.name with your actual domain name)
0
 
CNS_SupportCommented:
Make sure that the IP settings of your network adapter are correct.  ie that they have been set by the domain you are trying to connect to.
Go to Network and Sharing Centre and then Change Adapter Settings.
Double click on your adapter and then Diagnose.
This may resolve your issue.
0
 
1ly4meCommented:
windows 7 default gateway must be the same IP address of DNS.
and your domain controller also have same default gateway
0
Firewall Management 201 with Professor Wool

In this whiteboard video, Professor Wool highlights the challenges, benefits and trade-offs of utilizing zero-touch automation for security policy change management. Watch and Learn!

 
Chev_PCNCommented:
In the domain join dialogue, if your are using the NetBIOS name of your domain, replace it with the FQDN.
e.g. instead of "domain", use "domain.net"
0
 
kheaneyAuthor Commented:
I didn't add the gateway as the internet was not working......will try this later when it is up and running
0
 
Chev_PCNCommented:
The default gateway should not be an issue unless your DC is on a different subnet.
Can you PING your domain controller from the PC?
0
 
kheaneyAuthor Commented:
Yes I was able to ping the domain controller...
0
 
Chev_PCNCommented:
To ping, are you using the IP address, the server name, or the FQDN?
If you cannot ping using the server name or server FQDN, then DNS is the issue.
You will need to add the correct DNS servers to your NIC settings.
Did you try using the FQDN for the domain join?
0
 
kheaneyAuthor Commented:
sounds good I will try that...
0
 
kheaneyAuthor Commented:
Nic was not configured correctly now is and everthing is good  Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now