Exchange 2010

When i tryied to reinstall Exchange Server 2010 to a new, clean Virtual PC i had this error :

Mailbox Role
Failed

Error:
The following error was generated when "$error.Clear(); if ( ($server -eq $null) -and ($RoleIsDatacenter -ne $true) ) { Update-RmsSharedIdentity -ServerName $RoleNetBIOSName }" was run: "ExternalEmailAddress is mandatory on MailUser. Property Name: ExternalEmailAddress".

ExternalEmailAddress is mandatory on MailUser. Property Name: ExternalEmailAddress

ANY IDEA
christossklAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jian An LimSolutions ArchitectCommented:
reinstall, do you install as the same name?
do you use setup /m:recover
0
christossklAuthor Commented:
I have clean the previous installation because of a "crash".
Now i am tried to install in a new virtual pc and i get this error.

With the same error crash the previous installation when i'm tried to install service pack 1.

I cannot find anything about this error.
0
e_aravindCommented:
can you please check @ the Application logs for:
Log Name:      Application
Source:        MSExchange Configuration Cmdlet - Remote Management
0
Webinar: Miercom Evaluates Wi-Fi Security

It's not just about Wi-Fi connectivity anymore. A wireless security breach can cost your business large amounts of time, trouble, and expense. Plus, hear first-hand from Miercom how WatchGuard's Wi-Fi security stacks up against the competition in our upcoming webinar!

christossklAuthor Commented:
(PID 2460, Thread 22) Task Install-MailboxRole writing error when processing record of index 0. Error: Microsoft.Exchange.Management.Deployment.ScriptExecutionException: The following error was generated when "$error.Clear(); if ( ($server -eq $null) -and ($RoleIsDatacenter -ne $true) ) { Update-RmsSharedIdentity -ServerName $RoleNetBIOSName }" was run: "ExternalEmailAddress is mandatory on MailUser. Property Name: ExternalEmailAddress". ---> Microsoft.Exchange.Data.DataValidationException: ExternalEmailAddress is mandatory on MailUser. Property Name: ExternalEmailAddress
   at Microsoft.Exchange.Data.Directory.ADSession.Save(ADObject instanceToSave, IEnumerable`1 properties)
   at Microsoft.Exchange.Management.Deployment.UpdateRmsSharedIdentity.Link()
   at Microsoft.Exchange.Management.Deployment.UpdateRmsSharedIdentity.InternalProcessRecord()
   at Microsoft.Exchange.Configuration.Tasks.Task.ProcessRecord()
   --- End of inner exception stack trace ---
0
e_aravindCommented:
Need to re-run
a) setup /p command
and
b) setup /r:m to install mailbox role
0
christossklAuthor Commented:
I re-run the command setup /p and when i run the setup i get the same error.

unfortunately somewhere else is the problem

 
0
e_aravindCommented:
IMO, RmsSharedIdentity is around the "FederatedEmail"

Check @ AD users and computers,for  the federatedmail account
Is that created?
Looking good?
0
Jian An LimSolutions ArchitectCommented:
have you use adsiedit to completely remove the exchange before reinstalling again?
0
christossklAuthor Commented:
Yes there is the federatedmail account but is disabled (is this normal?)

And yes i have remove from the adsiedit all the exchange records
0
e_aravindCommented:
yes that is OK (normal)
what is the email address for that account? is that saying correct?

0
christossklAuthor Commented:
FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042@pierre-fabre.gr

After @i is correct e-mail address yes.

I will take a look to the above article

Thanks
0
e_aravindCommented:
In my lab for the command:
get-mailbox -arbitration -identiy fed* | fl *email* ...is resulting as

EmailAddresses: {SMTP:FederatedEmail.xxxx@domain.com}
EmailAddressPolicyEnabled:True
WindowsEmailAddress:FederatedEmail.xxxx@domain.com

Is this the same over there?

Thinking about what "ExternalEmailAddress" attribute is missing\erroring?
0
e_aravindCommented:
If still having some issue...

you can delete the FederatedMailbox from the AD and re-run "setup /PrepareAD"
Then continue proceeding further with the exchange installation
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.