• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 425
  • Last Modified:

Exchange 2010: searching for email with chached mode turned off

I have a user that has reported having problems searching for email within Outlook 2007.  He is connected to our Exchange 2010 server with Cached Mode turned off.

Is the only way for the full text indexed searches to work is to have Cached Mode turned on? Or should it work with the Cached Mode turned off?
0
VoodooFrog
Asked:
VoodooFrog
  • 7
  • 6
1 Solution
 
B HCommented:
just to be sure, does this workstation have windows desktop search installed?
0
 
VoodooFrogAuthor Commented:
The workstation is running Windows 7.
0
 
B HCommented:
as ridiculous as this sounds, make sure the terminal services service is started on the workstation... WDS relies on that:
http://support.microsoft.com/kb/929361

actually - according to microsoft, WDS requires cached mode:
http://office.microsoft.com/en-us/outlook-help/instant-search-is-not-finding-items-HA010198085.aspx

interestingly, thru outlook web access, you can search instantly just fine - just thought i'd mention that
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
VoodooFrogAuthor Commented:
Does outlook not utilize the Exchange indexing?
0
 
B HCommented:
how are they connected, locally or thru RPC proxy?
0
 
VoodooFrogAuthor Commented:
Locally
0
 
B HCommented:
outlook uses WDS for searching, and WDS can only index PST/OST type email files (along with windows live mail and the rest of the home-class junk).

WDS and thus outlook, don't know how to query the server for searches that way, they just do local caches/files
0
 
VoodooFrogAuthor Commented:
I had turned off Cached Mode due to this user's mailbox size plus other issues that seemed to be resolved by turning it off. Is the only solution to the searching to turn it back on?
0
 
B HCommented:
the only way you're going to get searching to work is cached mode, or outlook web access

how big is this users mailbox, and what other problems?  maybe attacking those problems is easier

cached mode is really the way to go for so many reasons
0
 
B HCommented:
well there's always terminal server / remote desktop into a server too - or an xp virtual machine on their destkop, etc... but local cached mode is the right answer
0
 
VoodooFrogAuthor Commented:
Alright.  I just double checked the settings on the user's outlook and Cache Mode was actually on this whole time.  However, it seems to be missing emails.  The Indexing status says it is complete. Any thoughts why items would be missing?
0
 
B HCommented:
check in file > account settings - what's the delivery location?  if it's still delivering to a PST file, that's wrong and won't work

you might be better off at this point to close outlook completely, control panel, mail, show profiles, delete this profile and add a new one

the delivery location by default, should be their mailbox on the server

suggestion:  name the new profile the same as the old one, so the user doesnt freak when their autocomplete entries are gone
0
 
VoodooFrogAuthor Commented:
I am not sure about the delivery location.  However you have answered my initial question.

Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now