Cisco 877WM router simple routing configuration+wireless

Hello,

in my company we would like to configure the Cisco 877 to do simple routing as the internet connection of an office is already coming from another modem/router… not configured by us and not configurable at the moment.
What we need is that one port of the Cisco, for example FE0, was connected to the other unknown router (from which it takes internet connection) with a static ip x.x.x.x
The  others Cisco’s ports (FE1,FE2,FE3) and the wireless should have dhcp, and lease an IP from a pool of adresses y.y.y.y with a class of IP different from the router that gives the connection. There should be also a route between the dhcp pool of addresses and the FE0 port in order that users connected to physical ports and wireless users could use Internet that  comes from FE0.
We tried to configure the wireless but we had many problems only to do this simple task… for that reason we gave up as we are pretty newbie with Cisco stuff. Wireless, for example, is active but dhcp dosen’t work and if the user doesn’t configure a static ip (within the pool of dhcp) dhcp dosen’t lease an IP.

Could anyone help us with a simple config?
Thanks

This is our temporary configuration:

Current configuration : 5922 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-1084610682
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1084610682
 revocation-check none
 rsakeypair TP-self-signed-1084610682
!
!
crypto pki certificate chain TP-self-signed-1084610682
 certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31303834 36313036 3832301E 170D3131 30333235 31353437
  32335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 30383436
  31303638 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100A8B1 B46303B9 9C1745BB 717D4945 84DCED0F 4ABF9CEF 5312731B 9AD5D4A0
  7CA080C0 21F37741 2E95715A 4D23AAA9 E69298C1 18B07353 9BAD90CE 906F7014
  12DFEEE9 F743CA2A A482627A 542A768B 42557F8F 24721BA6 2C3F6CE9 754CBA7B
  E8958407 D0346517 E9C515BF 1A27CCCD 925E83CC 57014F3F FFFD778F B431279E
  289D0203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D
  301F0603 551D2304 18301680 149E7FEA B230B2FF 417AC56D 2732288E 15CA9A4F
  FE301D06 03551D0E 04160414 9E7FEAB2 30B2FF41 7AC56D27 32288E15 CA9A4FFE
  300D0609 2A864886 F70D0101 04050003 8181003B B4B99A5F 93A913A3 23494F0F
  96BABD21 396AD3A8 3FD8AC5A 8A25577E B549B6C6 E6C251C1 FBC6F024 A62E4D58
  5FBDAB1B 227012D8 5A0E796D A7A6AA42 9E20EC3E 5A7C8F80 C084E79C B36A3894
  8D03798D 062FD9C3 02024A3F 9A9F8320 8BE7FB3A EB5820BF 5CC44DC1 FD5AD5D6
  F5CCE380 4A3DFD16 6A7466C9 809EF864 FA4F33
        quit
dot11 syslog
!
dot11 ssid test
   vlan 2
   authentication open
   authentication key-management wpa
   mbssid guest-mode
   wpa-psk ascii 0 odintest
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 192.168.50.1 192.168.50.199
ip dhcp excluded-address 192.168.50.211 192.168.50.254
!
ip dhcp pool ccp-pool
   import all
   network 10.10.10.0 255.255.255.248
   default-router 10.10.10.1
   lease 0 2
!
ip dhcp pool wifi
   import all
   network 192.168.50.0 255.255.255.0
   default-router 192.168.50.1
   lease 0 1
!
!
no ip domain lookup
ip domain name yourdomain.com
!
!
!
username administrator privilege 15 secret 5 $1$N/68$0uA8Z7na3joyKdyeErtBH0
!
!
archive
 log config
  hidekeys
!
!
!
bridge irb
!
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
 no ip address
 !
 encryption vlan 2 mode ciphers tkip
 !
 broadcast-key vlan 2 change 30
 !
 !
 ssid test
 !
 mbssid
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Dot11Radio0.2
 encapsulation dot1Q 2 native
 no cdp enable
 bridge-group 10
 bridge-group 10 subscriber-loop-control
 bridge-group 10 spanning-disabled
 bridge-group 10 block-unknown-source
 no bridge-group 10 source-learning
 no bridge-group 10 unicast-flooding
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 ip address 10.10.10.1 255.255.255.248
 ip tcp adjust-mss 1452
!
interface Vlan2
 no ip address
 bridge-group 10
!
interface BVI10
 ip address 192.168.50.1 255.255.255.0
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 10.10.10.0 0.0.0.7
no cdp run
!
!
!
control-plane
!
bridge 10 protocol ieee
bridge 10 route ip
banner exec ^C
% Password expiration warning.
BalorinAsked:
Who is Participating?
 
Steve JenningsIT ManagerCommented:
. . . then just make your default route on the 877 the interface on the router that is providing internet and if you have NAT pools defined, make sure the addresses on the 877 are included.

Good luck,
SteveJ
0
 
Istvan KalmarHead of IT Security Division Commented:
Hi,

you need something like this:
service password-encryption
hostname SomeRouterName
enable secret YourPassword
enable password YourPassword
aaa new-model
aaa authentication login default local
aaa authorization exec default local
aaa session-id common
ip http server
ip http secure-server
line con 0
 password YourPassword
line vty 0 4
 password YourPassword
ip domain name YouDomain.com
no ip domain lookup
username YourUserName privilege 15 password YourPassword
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.168.2.1 192.168.2.99
service dhcp
ip dhcp pool VLAN10
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 8.8.8.8
   import all
   domain-name YouDomain.com
   lease 4
ip dhcp pool VLAN20
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1
   dns-server 8.8.8.8
   import all
   domain-name YouDomain.com
   lease 4
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
dialer-list 1 protocol ip list 1
ip nat inside source list 1 interface Dialer1 overload
ip access-list extended Guest-ACL
 deny   ip any 192.168.1.0 0.0.0.255
 permit ip any any
interface FastEthernet4
 pppoe enable
 pppoe-client dial-pool-number 1
 no cdp enable
ip route 0.0.0.0 0.0.0.0 eth
interface FastEthernet0
 switchport access vlan 20
 spanning-tree portfast
interface FastEthernet1
 switchport access vlan 10
 spanning-tree portfast
interface FastEthernet2
 switchport access vlan 10
 spanning-tree portfast
interface FastEthernet3
 switchport access vlan 1
 spanning-tree portfast
bridge irb
interface Dot11Radio0
 encryption vlan 10 mode ciphers tkip
 encryption vlan 20 mode ciphers tkip
 ssid GuestWLAN
    vlan 20
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii YourGuestSecret
 ssid InternalWLAN
    vlan 10
    authentication open
    authentication key-management wpa
    wpa-psk ascii YourWLANSecret
 channel 1
 no cdp enable
 no dot11 extension aironet
interface Dot11Radio0.10
 encapsulation dot1Q 10
 no snmp trap link-status
 bridge-group 10
 bridge-group 10 subscriber-loop-control
 bridge-group 10 spanning-disabled
 bridge-group 10 block-unknown-source
 no bridge-group 10 source-learning
 no bridge-group 10 unicast-flooding
interface Dot11Radio0.20
 encapsulation dot1Q 20
 no snmp trap link-status
 bridge-group 20
 bridge-group 20 subscriber-loop-control
 bridge-group 20 spanning-disabled
 bridge-group 20 block-unknown-source
 no bridge-group 20 source-learning
 no bridge-group 20 unicast-flooding
interface Vlan1
 description WAN
 ip add x.x.x.x x.x.x.x.
interface Vlan10
 description Internal Network
 ip nat inside
 ip virtual-reassembly
 bridge-group 10
 bridge-group 10 spanning-disabled
interface Vlan20
 description Guest Network
 ip nat inside
 ip virtual-reassembly
 bridge-group 20
 bridge-group 20 spanning-disabled
interface BVI20
 description Bridge to Guest Network
 ip address 192.168.2.1 255.255.255.0
 ip access-group Guest-ACL in
 ip nat inside
 ip virtual-reassembly
interface BVI10
 description Bridge to Internal Network
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
bridge 10 route ip
bridge 20 route ip
int f0
 no shut
int f1
 no shut
int f2
 no shut
int f3
 no shut
int f4
 no shut
int dot0
 no shut
ip route 0.0.0.0 0.0.0.0 z.z.z.z

Open in new window

cli-config-worksheet.xls
0
 
BalorinAuthor Commented:
thank for the reply,

i have try some configuration maked with the Xls worksheet, but  don't work with my 877 W-M

if possible i need to put up one simple config, in order to understand  the configuration, or if you have one configuration  with 2  separated lan   one on Eth0 and one Eth1  with the DHCP active
I could start working from that base

thanks
0
Choose an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

 
BalorinAuthor Commented:
I've a doubt... is it possible with this router configure a connection coming from another router? Can I do not use the dsl port to get internet from a rj45 cable?
0
 
Istvan KalmarHead of IT Security Division Commented:
what type of internet do you have?
0
 
BalorinAuthor Commented:
my internet comes from other router ( Rj45 cable ), and i have only one static IP to set on cisco 877 for that connection,  then i want to use other interface and Wifi to provide Internet to other 4-5 computers
0
 
Istvan KalmarHead of IT Security Division Commented:
if you have static address I advise to use the first config
0
 
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.