How to copy a network folder to local desktop using Group Policy

I'm trying to copy a folder from a network file share to user's desktop using GPO but no luck.

Copy Source: \\server\share\folder
Copy Target: %USERPROFILE%\Desktop\Folder

I'm using User Configuration\Preferences\WIndows Settings\Files

I have it linked to my OU where all my users are but nothing shows up on the desktop.

THanks,
DAve
scubadiver_daveAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jangeadorCommented:
Have you tried this:

Copy Source: \\server\share\folder\*.*
Copy Target: %USERPROFILE%\Desktop\Folder\
0
p_nutsCommented:
I would just do a bat file in the GPO startup script

Xcopy source dest

Easy.
0
jangeadorCommented:
A copy would copy the files everytime. Probably not what he wants if the files are there.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

p_nutsCommented:
Fine use robocopy

\\server\share\robocopy.exe source dest
0
scubadiver_daveAuthor Commented:
I can try the GP startup script. This folder just contains shortcuts. It's not a lot of data. People don't want their desktop cluttered with shortcuts so we have them all in one folder. So, when we have a new shortcut we just put it in the folder. So, it would be ok to copy the folder every time. I'll see if I can figure out the startup script as I haven't done it before. Any clues?
0
scubadiver_daveAuthor Commented:
I've created the script and tested it. It seems to work ok on 2008 Terminal Servers. I have Windows 7 Enterprise but the script doesn't seem to put the shortcut on my desktop. I haven't tested it on any XP stations yet. Any thoughts?
0
scubadiver_daveAuthor Commented:
Well, CRAP! Now, it's not working anywhere. I don't under stand this. The logon script was working on 2008 TS, I deleted the folders, logged of and back on and they got recopied via the script. But, now they aren't getting copied anymore...anywhere. I delete them, log off and back on but the folders aren't being copied to XP, 2003, 2008, Win 7. >:-|
0
p_nutsCommented:
Run the script By hand.

And check rsop.msc
0
scubadiver_daveAuthor Commented:
Ok. I got it. The GPO was fine. It was the syntax of the logon.bat file. Here's what I ended up with.

REM This is for Windows 7, Server 2008
xcopy \\server\share\folder\*.* %USERPROFILE%\Desktop\ /s /i /y /q
REM This is for XP, Server 2003
xcopy \\server\share\folder\*.* "c:\Documents and Settings\%username%\Desktop" /s /i /y /q


Everything seems to work now. Thanks.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jangeadorCommented:
No points for anyone? Experts Exchange has sure changed since I last participated.

Good thing you found your answer buddy.
0
scubadiver_daveAuthor Commented:
Through trial and error this is what ended up working for me.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.